Just purchased V3 not connecting

Purchased 2 new V3 Wyze cameras. Set up one using my Android phone, easily connected and worked for about 2 days/nights. Third day it will no longer connect. I’ve tried resetting it several times. I’ve also deleted the device then re-added it through the Android app. It completes the QR code scan and follows that with a Device is offline (error code 90). BTW I have several other wyze cams so it isn’t new to me.
Firmware version:
Camera not yet mounted and is located in my home office.
Is this just a bad camera?


You’re not alone. They’re having issues right now. Check the forum.
I just contacted support and they’re aware of an issue with error code 90

1 Like

Was there a solution found? Just got this camera and it does not work.

1 Like

Sorry for the trouble. We are working on fixing this issue


Since there is no way to connect to the faulty device then we should return it? I don’t see how you’re going to fix a firmware issue when you can’t even connect to the device.

If you can fix the device will it be fixed today? Tomorrow? I’m dead in the water because my version 2 only gets 4 frames per second and keeps dropping. I’m not going to wait for the return window to expire and have to rma, And why didn’t that Constantine fellow know about any of this?

I just bought mine and can not connect. Luckily I bought it from Amazon. If I can’t get it working in the next 24 hours, it’s going back.

I think it will have to be returned. I don’t think Wyze actually knows what went wrong.

I’ll let you know if I get mine to work.


Mine just came in the mail and I couldn’t get it to connect, either. Just tried all the troubleshooting steps before coming to the forum. Looks like everyone is having a problem. My existing v2 works just fine.

Misery loves company. If anyone gets it working, let us know. I just tried again and it failed.

Update: still down. boo.

1 Like

Just received 2 new Wyze cam V3 this afternoon and tried to activate them without success. I had an old V3 never activated from months ago that I took out of the closet and was able to activate it instantly. So definitely something bad with the new cameras.

Hopefully this is resolved soon so I don’t have to send them back to Amazon.

I was able to get one of my Pan Cam v2s back online. They are working on it for sure.

1 Like

Mine is up!!!


Mine is working now. It’s asking if I want to upgrade the firmware. I’m scared.

Was able to connect now.

Don’t be😉


The all clear has been reported



Yup. Took 1 min. Awesome.

1 Like

I guess I’ll try again. All of my outdoor cameras went down. I couldn’t connect them, decided to reboot the base station and then the base station wouldn’t connect, none of the outdoor cameras would connect to the other still working base station. so now I have 1 working base station that I am afraid to unplug with 1 odc almost dead that I’m afraid to bring in and charge, 1 odc (less than a year old when it doed) that the battery is shot on and 2 more odc that won’t connect. And one newer V3 that was out side and it rained ALOT. Not it barely works. Beyond frustrated.