WYZE v3 not working!

my small WYZE camera abruptly stopped working one day and i swapped it out with a new V3 unit and now that one is doing the same thing!!! keep getting an ‘error code 90’ or ‘device not connecting’ ?? my other WYZE camera(s) are working just fine, so, it’s not a connection issue, it’s something with these smaller camera(s) and it’s very inconvenient when i’m away. any feedback appreciated. thanks in advance!!

-DJ :slight_smile:

Sorry twice. Sorry you are having problems. And sorry, but there’s not enough information to offer a solution. Error 90 means in most general terms, “communications error”. This could mean a lot of things to you.

Tell us a little more. What have you tried? Let me get you started. I say this so, you will think of doing this as a routine. Wyze cameras “like” being turned off and back on hmm, I’s say 1 a week at least. Some of us do it daily. (No we don’t run around unplugging and plugging them back in. We use WiFi adapter plugs that allow us to create a schedule.

And its good for you network to restart your WiFi router. Doing so will correct some connection errors that are intermittent before they become even known to you. Think of it as preventive medicine, for your network. How often? At least once a month, some of us do it more often. Its a little inconvenience waiting for things to pop back up, but its better than waiting for a problem then trying to find a way to get everything working again.

Now, let’s ask about that Problem-Wyze. When you swapped it, did you also replace the cable and power adapter? Maybe not? Try using a spare one, and setting it up some place where you can check on it. Like watching the light on and off? Not working? Can you add it again to your network? Not working, eh? Then no, When you plug power in to the back, does the light come and and stay yellow? If so, its sort of stuck in a boot up operation. You might try reloading a 1 step backwards version of the firmware. Google Wyze Firmware install, and it will help. Pay close attention to the details in the instructions. Every step is critical.

Check back in. If not me, there will be someone else here to help move you along in your troubleshooting. (I am long winded, sorry about that too.)

Do not need to put the answers to these questions here. But want to get you thinking. Don’t answer, just look at your stuff there. What router do you have? Look it up on the Internet. In its specs, how many Internet connected devices will your router allow you to connect to it? What’s the number? Don’t need to post it here. And count all of the things around your house that could be connected to the Internet. Everything, like phones, ipad, laptops that are not on the network all the time, but sometimes,. iRoomba, all your cameras, Ring doorbell? Everything. Is the router device number, I asked about near that number? (Again, no need to tell us the number,)

1 Like

Thank you so much for all of your feedback. I did contact my internet provider for both devices and both have their original cords. Device #1 won’t ‘connect’ at all anymore. When the modem was rebooted, the replacement camera (V3) restored itself but within 24 hours the same error/issue happened. It doesn’t appear to be an internet issue since my other WYZE devices are working properly. I’ve troubleshot both smaller WYZE cams to no avail; however, I cannot pinpoint what the abrupt issue is. I’ve attached another image for reference.

yeah, that’s a terribly generic/general error message generated by Wyze. Might as well say nothing as error code 90. (If you ask me, its code for them throwing up their hands in the air, shrugging and mumbling, gosh we dunno".

Sorry, I didn’t catch your reply if it still will boot up and flash on the front. ?? Most of us know that when one falls off line, we can add it back -WITHOUT going into the app and deleting its entry there. Well, when some are stubborn like this one, I delete it and close the app, restart the phone, so the app knows I completely closed the app. Then I try again. I also have a backup never-but-stuck Wyze login account, that I use to test if I can add a device there. Less than 50% of the time, it makes a difference. When I can, I delete it, and come back to my regular account login, and add it there. Usually that works. Mystery why.


Have you tried a factory reset on the device?

I have removed my SD card and done this in the past on various Cams (more often recently). It has helped sometimes.

1 Like

i did some rigorous troubleshooting last night and got it to work, finally! for whatever reason the error usually pops up during the [late] evening hours so i will see how it goes this evening. it hasn’t fully functioned for 24 hours on it’s own yet; so, i.m hoping this is the last round of nonsense with this specific camera. will keep you abreast! thanks for all of your help! :slight_smile:

i haven’t done a factory reset yet, since the camera was new/straight out the box. however, i will keep this is mind should i have any other issues. i did a lot of troubleshooting last night; therefore, i.m hoping this has resolved the issue. will find out this evening! thanks for the feedback! :slight_smile:

1 Like

so, i wanted to wanted to wait a couple of weeks before speaking prematurely… the WYZE v3 camera has been running consistently without anymore connectivity issues… YAY! however, the only issue now, is that it will not record any sound or motion events like my old device did… not sure what that’s all about. but nonetheless, it’s at least running in the interim,

i just have to check the camera more frequently now, since it’s not recording the short clips. bittersweet, i guess. :face_with_diagonal_mouth: