Wyze Cam Outdoor Firmware Upgrade Fails

Hi All,

I searched and didn’t find any posts regarding this.

I have two WCOs and keep getting prompted to upgrade to firmware, both are currently on They both fail to upgrade every time. I tried rebooting everything (cameras, base, router), upgrading with an SD card as well as without an SD card inserted, upgrading right next to the base, and also while on the charger.

Has anyone comes across issues upgrading the firmware? The base upgraded without a problem.

Edit: I am on iPhone app beta version 2.12.40 but tried upgrading the firmware using the App Store version as well.

Same problem. Following thread.

Not much action here, guess we are the only ones with firmware issues. I haven’t been able to figure it out. Contacted support a few days ago but haven’t heard back.

I did figure mine out! The hard wire I had to the base station wasn’t directly to the same 2.4 wifi router my phone was on. Once I changed this I deleted the base station from my app, re installed everything and the upgrades worked the first time. Base station first then the camera. All while my phone was still on the 2.4. Then I swapped my phone to the 5 router. Seemed to fix it. Th e base station was originally on an expansion port hard line not directly to the router port.

1 Like

Thanks for the info. My base station is already connected directly to my router. I was able to upgrade the firmware on the base station with no problem but both cameras fail. Tried removing everything and adding back to the app, unfortunately still won’t upgrade. Will keep trying to figure out.

Thanks again.

1 Like


No luck here. Contacted support and got a reply with a link to their support page (https://support.wyzecam.com/hc/en-us/articles/360038003732-Firmware-Failed-to-Upgrade) which I mentioned I already tried. They also recommended that I go through the setup again, which I had also already tried multiple times.

Waiting to hear back…

For anyone still having this issue… I upgraded the base station to today and was able to finally upgrade the cameras after.


I was also having trouble upgrading the firmware but took your suggestion on upgrading the base station first which was successful and then I was able to upgrade the camera. Thank you this was very helpful.

Glad I was able to help. It wasn’t until the new base station firmware that I was finally able to upgrade the cameras. Previously the base station was up to date but cameras would not upgrade.

Update Android phone App, delete camera, add camera, power-cycle base station, power-cycle camera, update camera, move camera closer to base, update all, update camera–Update Failed. Change order–Update Failed. 5 or 6 attempts–Update Failed. Fresh out of newt eyes, frog toes, and bat wool.

Same thing here. I’ve now provided logs to support but have not gotten the firmware to update with any number of power cycles or any combination of steps.

Same, unable to update firmware, keeps failing. WYZE…Please resolve. Doesn’t matter if I rip-n-replace all network equipment and software, still same issue…I was able to update the wifi base unit, just not the outdoor camera itself.

1 Like

Same problem here. Any response from Wyze? Base station running .168 Cam stuck at .128.

Still seeing the same issue. I’ve not heard back regarding the logs that I provided.

22 days since my last response and this issue is still ongoing.

I’ve been having the exact same issue since trying to upgrade from a month or so ago.
I have followed all recommended steps: reboot, keep within 6 feet of base station, remove sd card, make sure base station is up to date, plugged into power/unplugged from power, deleted from account and reset up from scratch etc. Always fails. Not seeing a way to flash the firmware via sd card either so I haven’t tried that. Other things I’ve tried: Using a different phone. Made sure I was on the exact same wifi network (2.4), rebooted base station all sorts of stuff and the 8 or 9 minute timeout for the fail is excruciating. If anyone has a suggestion for something I’ve missed?

If you’re in the beta for the Wyze app, they recently released an update to that to try and fix this. Seems to have worked for some, but not for me.

I am having the same issue with my two outdoor cameras

Just another update on this. After manually flashing the firmware as stated here, I have still not been able to update the Wyze Cam Outdoor firmware via the app.