Wyze Cam OG Firmware Update Failure

I need help!!! I purchased 2 new Wyze Cam OG’s the other day, we already have Wyze Cam v3’s and Wyze Cam Outdoor, they work perfectly fine and always upgrade firmware with no hiccups. Until we purchased these OG’s… we set them up, they’re connected to the Network, but I cannot do anything with them, every time I click on them, it pops up that I NEED to Update Firmware. So I click on it, to update both OG cams, and every single time, the Upgrade Fails. With Error Code -15. I have researched, done EVERYTHING I can think of or read to do. Disconnected every other camera and device from network, so it’s only these 2 connected… Rebooted wifi, update phone apps, deleted and reinstalled phone apps… deleted cams, set back to factory settings, set up again as new cams. Place phone/cam/wifi within inches to each other… cleared app cache… EVERYTHING, and it’s still saying Firmware Upgrade has failed.
What else can we do to get these to Update and work!?!?

You can try to get them updated one at a time thru the App Firmware Update page also.

Power Cycle the cams by unplugging them for at least 30s.

Open the app and go directly to the Account tab. Do not try to open the cams.

Click on Firmware Update, find the cams and try an update one at a time. Give it time to do its thing.

Nope, that does not work either.
I also tried everything that 49brooksak tried, without any result.
I opened a ticket yesterday night, and this morning I was requested to send the cam logs. I sent them and I’m waiting for a response.

The other option is to factory reset the cam and manually flash the most up to date firmware to it. If the last update failed mid-stream, it may be preventing a new update attempt.