Wyze Outdoor Cam fails when upgrading firmware

Got a Wyze Outoodr Camera. It shipped with FW version

I am trying to get it to upgrade to the current version and it fails, no matter what.

I am trying from the latest version of the iOS app. I have the camera sitting 3 feet from the base station so no range or connectivity issues. I have tried power cycling the camera, power cycling the base station, removing and re-adding the camera to my account, and no luck.

My other Wyze cameras have upgraded fine so I know its not any router issues or anything else about my home network.

Looking around seems like the Outdoor Cameras have a lot of problems around firmware upgrades. Has anyone figured a solution or do I need to open a ticket and get the camera replaced?

@msilverman Welcome to the community! Did you try to update the base station?

You may have to unplug the base station and let it reconnect first. Updating the base station first usually works. Then the outdoor cam should update if it’s working properly. If this doesn’t help you can start a support ticket.

1 Like

I should add my base station’s firmware is up to date and I did try power cycling it, letting it reconnect and trying again. Made no difference.

i had the same happen to me. i ended up having to sit both literally right next to each other. the first tap it didn’t but the second try and it worked out. after that update then i needed to do one for the camera at the very end of the setup process. hope that helps.

Adding a post here so folks can know about my solution. I ended up having to contact support and they sent me a .zip file of the firmware update, which I then installed via the SD card method. This worked. Hopefully whatever bug was preventing it from updating was addressed in the update so future updates are successful.

1 Like