Firmware not updating

Hello All,

I have four outdoor Wyze cams that stopped working a little while back. Come to find out after calling Wyze customer service, the firmware on my base station and all cameras needs to be updated. However, the issue is the firmware never successfully updates. The gears either sit there spinning forever until I eventually give up. Or, I get the “oops, sorry, the updated failed message.”

After checking my WiFi connection, the customer service rep told me my signal was too weak for the updates and I needed to call and change the channel of the router. So, I did that, and even updated the firmware of my router itself. I have verified through a test that my router is now running more mgps than it was beforehand. But alas, when I try to update the firmware of my base station or cameras, it’s still unsuccessful. Any ideas on what to do? I am at a loss and just want the cameras to work again. Thanks!


Hi @scottf000 and welcome to the Community Forum! :slightly_smiling_face:
Try updating he WOC Base Hub first by connecting directly to your router using the included ethernet cable.
Once the base has successfully updated, try moving one of the WOC about 10’ from the Base. Make sure the cam is fully charged. It should request an update via the Home Screen → Settings → Device Info.

Thanks for the reply. Unfortunately, the base station is already permanently plugged in directly to my router via the ethernet cable and the firmware update never works.

@dr.know any idea what could be going on or what to try next?

1 Like

Is the LED light on top of the base solid blue? What firmware version is on the base now? You can add new firmware to the camera with the manual method using an SD card but none of the base firmware version are available for download. I would add new firmware to the cams first with the manual method then on the app go to account>Firmware update and try the base.
Method for the cameras: The latest version is, and make sure to follow the directions.

@Antonius Yes, the light on top of the base is solid blue. The current firmware version on the base is

I can try your method of manually updating the cameras first. Just go purchase a regular SD card? Then, can you direct me where to download the latest firmware from? Thanks for the help.


Yikes ! your firmware is from September 2020 :open_mouth: :rofl: Yes just go purchase a SD card 32GB or smaller, even a 8GB card will work because the file is not that large. If you open the method I posted you will see where is states to get the latest firmware from from the Release Notes (Written in Blue). Open that. There are directions for using Windows and Mac. I used Windows, right click on the blue number, download it to your desk top or a temp folder. After downloaded right click and extract all to the SD card and the file will be sd_update. Follow the directions as written. There was the ability to do the same for the base firmware but WYZE removed all the files. The last on and current firmware on my base is Jan 2022.

Make sure you put the SD in the cam correctly :rofl: Pins side down label side up

Base Station on Ethernet. Good, that eliminates one variable. Here are some questions for you:

  1. So you have other Wyze cameras on the router? If so, have they been able to update? There may be a port restriction in the outer blocking the update. Is the time on cameras correct?
  2. Are you running on an Android or Apple platform? What version is the Wyze application?
  3. When you go to the Account Tab → Firmware Update, Are the Wyze Base & Outdoor Cameras listed? Do they indicate “Up to Date”?

Hey @dr.know

  1. Yes, I have the other cameras connected to the router, but no they haven’t been able to update. They do the same thing as the base station (either continuously spin or fail). The time on the cameras is not correct. When I click on a camera, it shows the time and picture of the last time that it worked. It tries to connect but never can.

  2. I’m running Apple platform. The app version I have is 2.29.1 (a6)

  3. When I go to the account tab —> firmware update, it says “there are no devices linked to this account.” Which is strange because I can see my cameras on the home page, and they just say “offline.”

What other types of cams do you have ? Maybe you should go to the app>account>app setting and clear the cache. Then on the same page go to account>sign out then sign back in to see if that makes any change. Don’t sign out unless you know the password word to sign back in or it is saved on your iPhone.
Are you using the same account that you set the cams up on? this is very strange. :open_mouth:
What ever you do, DO NOT delete the Base or the WCO cams if they show off line.

Yes, 2.29.1 (March 28, 2022) is the current app for IOS.

You can login and check your account at (same password as your app). Take a screen-shot of your Home page with the Cams. Once you clear cache, those thumbnail will disappear.

"there are no devices linked to this account.” What other Wyze products do you have? Were these cams purchased from Wyze direct? Confirm these were installed and working on the same phone.
When you go to Account tab, My Account → Badges do you see your cam or other badge(s) there?

If time is not correct, seems Wyze app is not connecting through your router to the cloud. Making sure the app is connected to the internet & cloud is first order of business.

Hey @dr.know, sorry for the slow reply. To answer your questions: I do not have any other Wyze products, just the four outdoor cams and base station. I did not purchase them directly through Wyze, I got them on Amazon, and yes they were installed and working on the same phone prior to them suddenly not working anymore. When I go to My Account → Badges as you instructed, I do see the outdoor cam badge lit up, which is good.

I am currently attempting to manually update the firmware on the cameras with an SD card. I’m not sure how to update the base station since A) every time I attempt to update it through the app, it fails. And B) Wyze removed the base station firmware from their website so that I can not update it with an SD card.

1 Like

@dr.know it seems I am failing on all fronts. Today I am attempting to update the cams firmware manually via a micro SD card.
1 . I downloaded the latest firmware from the website and copied it to a micro SD card,
2. Put the SD card in all four cams, and all four times the light turned purple for a few seconds to show an update in progress, then after a few seconds turned blue again. So, I removed the card from the cams,
3. Went back into the app to the “device info” of each cam, and it is still showing the old the cams are using the old firmware.

I have now tried updating the firmware through the app and manually with an SD card and have failed every single try for every camera I have. If I can’t get this figured out, I will have no choice but to purchase more cams but go with a different name brand this time. Any other ideas of what I should try? It seems my cams are not connected to the cloud, should I try doing that?

The iOS app 2.29.2 is not working for firmware updates for some reason:

@Antonius, I see, I was unaware. Are we just currently waiting for them to fix it and issue an update?

I sure hope they are working on the update issue ?? My base is still on and will stay on The newer version shows as available on my app but I will not try to load it since it was paused twice already and I don’t know if it was ever fixed. My base and all 4 WCO are working just fine as is using the iOS app 2.29.2.

Hi @scottf000 You need the Outdoor Cam Base communicating with your App to check on the WOC firmware. There was a sequence to updating the base and if ignored, could brick the base.
My base IS on the new f/w ver and haven’t had any problems w/it or assoc. cams.

You can’t really tell if your Outdoor Cams are working or not unless the base is up and communicating. Give support a call and just focus on getting the base working.
(206) 339.9646 Monday - Friday 5 am - 6 pm PT

From @Antonius post:

1 Like

I know I’m new to this but I was having the same issue, I thought I was going to have to manually update the firmware. Then realized I hadn’t updated my Application in a while. Once I updated the Wyze App everything worked great and all firmware is updated.