Wyze Cam Outdoor and Base Station Firmware Released - 8/9/21

Happy Monday, Forum Friends!

We have a small update for Wyze Cam Outdoor ( and its Base Station ( today! This fixes a bug that caused trouble with Events if multiple cameras sent videos at the same time. :slightly_smiling_face:

Read our Release Notes:


Not showing a firmware update for the outdoor cameras I am on firmware , running app version 2.23.21, base firmware is

base station wifi connection is not working after the update. Got “Set wifi info failed” when trying to plug in wifi info again. Ethernet connection is still working.

1 Like

Beta app shows an update to but does not show up in the production app

Base station updated but not the Wyze Cam. How do I get the camera to recognize that there is an update? I signed out of the Wyze app and back in but camera still does acknowledge that there is a firmware update.

App shows these updates under Account/Firmware but the updates fail. When I look at each Outdoor Cam however, they say update with the older 170 firmware. There must be a mismatch in the firmware lookup between what the device looks up and the App.


So far I have not been able to get the new firmware for cams to show up in the production app anywhere

1 Like

I found my under the firmware section of my account, haven’t updated yet, I’m chicken :grin:

I’m unable to update either of my WCO to the new firmware. It appears to go through the motions of updating, but after 8-10 minutes returns the “Update Failed” message. I have tried multiple times with the same result, even after power cycling both the cams and the base station.

Anyone else seeing this issue?


I just tried one cam from account>firmware. It said updating but after 15 min. nothing happened so I forced closed the app. I opened the app back up just to make sure the cam was working and it is with So much for a “simple” update. :upside_down_face:


Same problem here. Base Station updated, but the WCO’s will not update their firmware.


FWIW, I was able to update manually, using a sim card and the firmware from the release notes page.

I’m that not that interested in doing it the hard way when I don’t have to. I’ll wait, the update is not that important anyway. My 4 WCO almost never try to upload events at the same time.

I could update my firmware on the outdoor cams through a beta app I have, but I will just wait and see how it goes from here with the production app

I am not physically cose to the outdoor camera so a sim card update is not an option. That is a big reason that I bought it, so that I can access it remotely. Very frustrating that the firmware will not update via the app. Hopefully Wyze is working on a solution.

1 Like

Yes. Successfully updated the WCO base station firmware yesterday (9/9) after was greeted with message saying there was an upgrade available. Went to Account / Firmware and upgraded without a problem. Repeated attempts to upgrade the WCO from the same page have failed, both yesterday and today. @WyzeGwendolyn

1 Like

Hoping they get this figured out. Firmware updates have always taken about 2 seconds of effort. Manually updating with a card will take quite some time. I just want things to work like they should:)


I suspect the device and the app lookup updates in different locations, so they get different results when the data is out of sync. I that’s the case for this update.

I performed the update this evening and once the base stations were updated, they both went offline (two in the home). I’ve power cycled, removed the ethernet cable, standard troubleshooting and no dice. I will fiddle with them tomorrow to see if they come back…