Outdoor cam firmware not updating

Hi I cannot add my new outdoor cam to Cam Plus because it says the firmware is not supported. When I try to update the firmware it says it’s all set but it’s clearly an older firmware.

So when you update, it says it succeeded but the firmware version does not increase and it still shows another update is available? Try clearing your app cache in account > app settings, then force close the app.

Hi, thanks. I did that but it still won’t update.

:astonished: That is some old firmware on that cam, I don’t even see it on the list of firmware. I think you should add the March 23 2022 firmware manually, version then update further from there.
Use a 32GB or smaller card. That firmware is from around Sept 2020 I think? If you got that camera new from WYZE I would ask them to send you a replacement cam with firmware that is not 2 years old.

1 Like

In case you haven’t already tried this… go to Wyze app Home > Account (bottom right) > Firmware Update. You may see a firmware update for your Wyze Cam Outdoor Base Station. If so, try updating the base station 1st from that all-inclusive device menu.

1 Like

Ugh. I just bought the camera. How do I update it manually?

I Posted the directions above. How to flash you firmware manually, just click on that (The writing in Green)
Make sure you follow the direction correctly !!!

ah, sorry, didn’t see that. I am not using an SD card in the cams, I have Cam Plus (that is a whole other can of worms after I tried adding a 2nd camera).

Thanks, the firmware for the base is up to date. I have tried everything except manually adding the cam firmware because I don’t have an sd card handy. I guess I will have to send it back to Amazon and get a new one.

1 Like

Other than manually flashing per Antonius’ post or returning/exchanging, the only other thing I can think of is try powercycling the cam (toggle the physical switch off/on), wait for the cam to connect to base and update the cam’s firmware from the same bulk menu (Home>Account>Firmware update). If you’ve been attempting to update from the bulk update page, you can also try updating from Home > your cam > Settings (gear icon upper right) > Device Info > Firmware Version.

1 Like

I tried the manual firmware update and the camera is not even recognizing the SD card. UGH! It’s going back to Amazon. So much time wasted.

Delete the camera and the base from your account prior to returning to Amazon. Even though the cam does not work delete it from your account anyway as well as the base or some other poor person will not be able to use them if it gets sold again.

1 Like