Wyze Bulb Color Firmware Beta Test 9/13/2021

  • Added support for Sun Match

  • Added support for Timers

  • Added reporting to firmware updates

  • Bug fixes


I tried updating through Account tab, then Firmware update section. There were 3 color bulbs currently active and showing they were waiting for the new update. I told it to update them and the update Failed on all three all at once. I tried it again all at once and it failed again. I tried individually (still in the account - Firmware tab) and it failed again individually instead of all at once.

I then went to the home tab, selected the individual device and updated there and it was successful.

So if you have problems updating, go to the home tab and update it from the home tab after selecting the device there, and it should work fine.

Update clarification: I tested doing this with a bulb group from the home page, and couldn’t update the bulbs individually that way. Going to device info and clicking on the firmware version wouldn’t do anything. If I clicked on the update popup (which shows up when I select the group), it took me back to the group update screen in the account tab and the update failed every time.

I then tried removing the bulbs from the group to see if that would let me update it individually. I then selected the device from the home tab, then clicked on the update pop-up, and it finally allowed me to attempt updating the individual device, but the update has failed 3 times even when trying to do it individually (and more times trying to do it in the group update). I will keep experimenting to see if I can get it to update these last couple of bulbs that are struggling. See what I can find out.

I then wondered about why several other color bulbs did not show up as having an update pending (my desk lamp, and my daughters’ lights…somehow they were all already updated before I even checked them, like before this post was created…somehow they updated automatically?).


I had an initial issue when doing the FW update via the Account Tab. I decided to unplug the lamp, plugged it back in, did it again through the account tab and it worked fine.

I never do a mass update, always do it one at a time for this reason. I have never had a successful update doing it all at once.


Probably a stupid question… :roll_eyes:

What is meant by sun match? As the sun goes down, the light changes?

Bulb’s color and brightness to match sun’s color and intensity, obviously not really as intense as the sun. :open_mouth:


I’m trying to update just one of many color bulbs, but can’t get this 1st one updated. Tried updating from the pop-up and a 2nd try from the bulb’s settings.

Log ID: 295500

Tried twice via pop-up and twice via bulb’s Settings… going to try it your way now.

Update: No matter which way I try to update, group from pop-up, individually from pop-up, individually from Settings, individually from Account… update fails.

But, thanks to an idea from @spamoni4, I am able to update: 1st attempt fails and shows off-line via app, need to power color bulb off, power back on, wait for WiFi connectivity verified via app icon, retry any method and it succeeds. If powercycling bulb does not show as connected, need to reboot phone/tab before attempting retry of firmware update. This process is so convoluted that production users will be seriously irate, especially if attempting to update grouped bulbs. Please fix this update process before pushing out to production. :pray:


I updated 3 color bulbs with no issue from the firmware update page, starting the update of all three bulbs at once around 6pm EST.

FWIW- i was away from home on a cellular connection and not on Wifi.


Just wondering… what app did you use to update your bulbs? I’m using Android beta v2.24.41.

iOS beta v2.24.41

1 Like

I’ve updated 5 now, but it’s a lengthy process waiting for the initial try to fail for each. :confused: I have 2 individual and 3 in a group updated. Going to hold off updating any more in case Wyze needs more logs or whatever.

I wish we had the ability to individually update grouped bulbs from the Device Info page.

I wish we had individual control of Sun Match for grouped bulbs… it all in the group or none.

2 of the 3 were in a group, the other a lone back porch light.


I am experiencing the same thing here with Android beta v2.24.41. Your experience describes what I am having on 2 remaining bulbs in my office.

They keep showing as offline on the app now. I can select them from the home tab and change their color or brightness or power even though they are “offline” though. I have tried rebooting them and rebooting my phone and doing both together, but I still can’t get them to show as online or get the update to be successful everytime I attempt it.

Log 295670 & 295671

(my Office Light 1 and Office Recessed light)
Several others have updated, but those have failed as many as 10 times now in various attempts and have shown as offline for a while now. I can still control them through the app, but I don’t think they work with any rules or automations anymore as the app thinks they’re offline.

(I do have a few other color bulbs that are powered off right now and I haven’t tried updating yet. I might save those in case they’re needed for further testing or something…but so far I would strongly recommend against making this public, it would be way too confusing for too many people, and I am not even sure if the ones it failed on will come back online or not. I will monitor and report).

1 Like

Cut the power to the problem bulbs for about 10 seconds, power back on, wait a minute, refresh home page by pulling down, check to see if problem bulb shows online and if yes, retry update. If no, boot phone and recheck bulb status. That’s what I’ve been doing.


You are right. Leaving it off for more than 10 seconds (instead of just 2-3 seconds), seems to have cleared the RAM enough to make a difference. It showed back up as connected in the app. I will tell it to update and do the same to the other bulb and report back after a couple of attempts involving a long off period and rebooting.

1 Like

I got them to work (after over a dozen failed attempts on both these bulbs)!

So, after the initial “off for over 10 seconds” reboot, I tried to do the update and it failed again.
Then I tried the following:

  1. Turned off Both bulbs for at least 15 seconds
  2. Turned the bulbs back on.
  3. Rebooted my phone
  4. Loaded the Wyze Beta App and did a “Force Stop” on the app while it was open. Then reloaded the app.
  5. On the home screen I selected the device
  6. I got the pop-up asking if I wanted to install the firmware update, I hit “Cancel” on the popup
  7. I selected Settings
  8. I scrolled down to the option that says “Check for Firmware Update” (and selected that)
  9. I then installed the new firmware and waited for completion
  10. It announced it was successful this time!
  11. I then went to the other bulb and repeated steps 5 through 10 (including it being successful for the other bulb this time too)

I don’t know if every single one of those steps was necessary or made a difference, but I wanted to list them all exactly as I did them just in case. It is the first time I tried a force-stop on the app. It is also the first time I tried simultaneously both rebooting my phone in addition to leaving the bulbs off for at least 10 seconds.

So after a dozen failed attempts, the above worked for both bulbs that were otherwise refusing to cooperate. Great suggestion @Seapup ! I think we might have found a work around for anyone who runs into this problem. It would still be ideal to not have this issue happen in the first place, but if it does happen to someone else we at least have something to recommend that appears to have worked.


Tried the firmware update on two color bulbs this morning. First one worked immediately. Second failed on first attempt. Power cycled the bulb and the update finished successfully on the next attempt. Did both via the account tab.


I (with much angst as this is what caused my last bulb to become permanently disabled) turned off and on 3 times to put the bulbs back into pairing mode, 2 out of 4 needed to be paired and 2 stayed paired, paired the 2 (only 1 was new). Updated each bulb individually by selecting each one but updated them all at the same time. 3 out of the 4 updated, the replacement bulb being the only one being non-compliant but it was recognized as being connected in the app and on my router and was responding to the app. At this point, as it is functional, I have not tried to update the new bulb again out of fear this will cause it to cease to work with the app. The Power off for 15 seconds did work in successfully updating 3 of the 4 as well after a few attempts. I believe it helps but it’s not a guaranteed work around but an additional solution to try. I feel like something is interrupting the update process enough for it to fail. I may try plugging it into a different light socket closer to my main router and see if I can update it with less chance of interference and then put it back where it belongs.

I have looked everyday and still don’t see this firmware update… I am on the beta app program. And have the most updated beta app too… am I doing something wrong, or is it just so many of the beta public gets the beta firmware?

Samesies… been checking every few days.

Check under your account and go to about, then beta program and make sure your color bulb is listed as a device that you are beta testing. If not click on edit and add a check mark and you should be able to update the firmware for the bulb without a problem after doing that.