Color bulb continual firmware update failure

Hey i just got a bulb color and it keeps nagging me to update the firmware. Downside is everytime I try it fails in the end.

Ive tried deleting the bulb and re adding it multiple times in the app, power cycling the bulb, unplugging it for a variety of different times. Clearing the wyze app cache , updating firmware from the bulb menu and from the account menu. Ive tried well over 20 times in the past couple days to no avail. Rebooted phone all ends the same way. I have no issue connecting to the bulb and chaning settings once i re add it but it will not update firmware.

Current firmware is 1.2.0.259 and it wants me to go to 1.2.0.429

My wyze app is the latest version as of today with the android tablet crash fix, still no difference though.

2 Likes

Same issue here, I would like a follow up on the issue
thanks

1 Like

What type of fixture is the bulb in? How far from the wifi source and what’s in-between the two? What type of wifi network gear do you have?

Have you tried moving the bulb atleast closer to the wifi source or a different fixture or lamp for troubleshooting? Sounds like you’ve done all the troubleshooting except for those.

Same issue here. I’ve tried two different lamps - one with a 3-way switch, the other with a 1-way switch. The lamps are within 4 feet of my access point.

1 Like

Same issue here. The bulb is showing between 2-3 bars of WiFi signal

Having the same issue. The bulb works fine on version 1.2.0.359, but the update to 1.2.0.429 fails every time. I’ve tried moving the bulb to a different lamp and both are about 8ft away from the wifi source (Google Wifi). I’m on the latest app version, have cleared the app’s cache, deleted and added the bulb at least 4 times, turned the lamp off and on multiple times.

Just an update I recieved a second bulb as a replacement and it as well fails the update no matter what I try. Ive tried multiple fixtures as well now and all are within 10 ft of an access point and show full bars in device info and still fail firmware update.

My wyze app is Beta
And im in Canada if that matters at all as i know they just launched alot of products here recently.

Both bulbs have firmware 1.2.0.259 and it wants me to go to 1.2.0.429

Also have tried updates using data with same failure in the end.

I am wondering if there is a batch of bulbs that is lacking some critical component that prevents upgrading. This is really a question for the Wise folks at Wzye.

I wonder…I purchased my bulb from Amazon. Did others with this problem also purchase through Amazon?

@luketremblay FYI, I’m also in Canada (QC specifically), and I get the feeling that @gfortin6 might be too based on the last name?

I got mine online from the new Canadian Wyze shop.

I’m also from Canada (Qc) and I got mine from Wyze shop

From Canada, but direct from Wyze shop…seems like this is something wyze needs to look into and not an operater error…be nice if they would review this or chime in, the only thing i get from support is the reset steps and to try again, which clearly does not work…

Agreed! It seems that the community has done everything that’s been recommended. It’s up the mfgr.

I bought 6 color bulbs and only one accepted the update. The others just fail. Initially they would fail and require resetting the device. Now they eventually recover on their own. It’s very frustrating. Everything about the bulbs is frustrating.

Same here cant update

Hopefully enough people chime in to make it known. Definatly seems like an issue with it being used in canada as far as pushing firmware update for what ever reason

I’m in the States. They must not sell enough of these bulbs to notice none are updated to latest firmware.

Oddly, today, just on a whim, I thought I’d try again --and voila! it worked (I’m in the US, so pardon my French). Practice, or persistence, makes perfect. I wonder if the problem has been that the servers are overwhelmed. It appears that everything has to go through some form of central server --several weeks ago, their system went down, and I couldn’t operate anything in my house for about 24 hours. --something about AWS servers.

Same here. Bulb was a freebie from a bulk Wyze purchase through their store(Canada as well). Tried multiple times, different location, no update. Noticed that in the notes the newest firmware fixes firmware update issues…so maybe it’s known?

OMG got it to work for both bulbs! Turn off the light first within the app before updating firmware!
Exact steps:

Via app; Tap on the color bulb.
Tap the off button which is just to the left of the “brightness” slider.
Tap “Settings” > “Device Info” > “Firmware Version” and run the update.
it worked for me

5 Likes

It took me several tries with the bulb turned off by the app for the firmware to update.

1 Like