Cannot update color bulb

Color bulb does not update

If this is a new bulb and you can’t get it to update to most recent firmware version, while trying to install it for the first time, there is another thread on WYZE that described this same issue and stated to first turn off the bulb then turn it back on, then it’ll update to the latest version of firmware.

See this link to confirm it’s the same issue and the solution.

1 Like

Hey folks, I’ve tried the “turning the bulb off method” but it still fails and as soon as I go back to the main screen that shows all my devices after turning it “off” it automatically turns back on and the update fails. Super frustrating.

Any other ideas?

Have you tried to clear the App cache? Go the the Account Tab, scroll down to App Settings, then select Clear cache…then try the reinstall again.

Yup I’ve done it several times. Even used another phone to make sure it wasn’t my phone.

Wyze seems to be going downhill in general with its app and how it’s devices work. The company showed a lot of promise in the beginning, at this point I’m one more bad product away from switching from completely to a new company for my smart home needs

I am sorry you are still having issues updating your bulb. After you power it off have you tried updating it from the bulk update page under Account>Firmware Update?

1 Like

Yessir, I have tried that as well. No dice

Do you have any rules enabled that would turn the bulb right back on? Are you turning the bulbs off via the app? The only thing I can think of here is you’re turning the bulbs off via the wall switch and not the app and turning it back on and the power recovery settings set to turn on after power loss. But that last one’s a shot in the dark, looking for your confirmation. Thank you

1 Like

No rules are set at all.

Using the app to turn it off. Not physically turning it off by the switch.

The app and bulbs are legitimately malfunctioning.

Have you tried to deinstall and reinstall the bulb by chance? Also, since they just updated the IOS app, have you tried to delete and reinstall the app on your device? I’d also suggest a call to WYZE Support to verify failure.

I have done all of the above several times. Wyze support basically just told me That they will ship me replacement bulbs and if I’ve done all the above there’s nothing else they can do

Just updated my Wyze app, factory reset bulbs, cleared cache, tried turning bulb off from Home Screen and the bulb menu itself. Tried settings firmware update and bulb menu firmware
Update. Still failing

Just a curious question….How many bulbs are you having fail with this failure?

Both bulbs that I purchased from Amazon, on the Wyze store on Amazon

what version of the firmware does the bulbs have on them right now? And one is the previous before that. I think