Wyze color bulbs not working

So my wife bought 4 color bulbs and i set them up yesterday. Well 3 of them connected. I saw the firmware update but it wouldn’t update. Today when i got hime from work none of the lights were connected. Tried several times to reset them but they never connected. I am at a loss. I have tried everything that Wyze recommended but no luck. I sent an email and all they did was send me a email ask me to rate their services.
Any advice???

I had problems in upadting the firmware in my white and color bulbs when I first got them.

I saw a post someplace, to make sure the bulb was in the off state (not with the wall switch turned off, but with the switch turned on but the bulb turned off in the app).

So I did that and the firmware worked.

Since setting them up, I have never had a problem with them being connected - they have been turning on at sunset and off at 10:30pm for several months.

Since then, there have been some more firmware updates, and I just made sure they were in the off state, and they updated with no problem, and they continue to work perfectly.

I originally bought 4 color bulbs, and I added all 4 when I got them. Then I put 2 bulbs away for several months, and recently got those out again, and there was another firmware update since I first set them up. I just made sure they were in the off state, and they updated fine.

To re-add the bulbs if they did not connect initially, turn the light switch off and on 3 times, and start the setup over again. I had to do this when I set up a new wifi network with a new name, so I had to re-add all my devices to my account again. I did not delete them before re-addng them, and when I re-added them, they recognized they were already in my account, and they preserved all the settings and rules from before, rather than being added in twice.