Wyze Battery Cam Pro Issues

Hi,

I just installed [Wyze Battery Cam Pro. I see that the Motion Events are not generating video clippings ( i dont have any subscriptions though) instead it creates event photo but when i try to play the video it says “No video available at this time” and “Jump to SD” option does not have anything there. But sometimes, i am able to get the video clippings in "Jump to SD"option.
Note: My Wyze battery Cam Pro has “Events Only” in Advanced Settings with Record to MicroSD cart turned ON. I also have MicroSD card installed in the Wyze Batter Cam Pro.

I also have Wyze Cam V3 which generates short video clippings for motion events (i dont have any subscriptions here either). I dont see issues here. Video clippings for any motion events are always available.

Please help with wyze battery cam pro.

Thank you

1 Like

I’m experiencing the same issue and have been since purchasing the Battery Cam Pro. I have a Wyze 256GB microSD card installed and events are recording (as does continuous if I choose that option), but accessing the events never works. Jump to SD never works. Like you, it just says no video available at this time. No ability to skip forward or back to find any events or any action of any kind. Clearly the events (and the continuous recording) are being captured, so it would seem to be a software issue, but it hasn’t been fixed and doesn’t appear to be getting the proper attention. Frankly, this is one of the big reasons why I’m not willing to pay for Cam Plus - since the basic operations that are expected are not functional. And I have a lot of Wyze products; I’m very much a fan. But so far, this product has been a huge disappointment. I can only use it for brief periods to continuously record (on battery) so that I can view happenings live.

I can’t believe this company has degraded the experience as much as they have. Frankly, they even changed the way the software works for the Floodlight Pro compared to other cameras like the V3. Different SD card and access capabilities for every one of the cameras, which is incredibly stupid and frustrating from a company that should be better. I’m hanging on in hope of an update that will fix this product, but otherwise expecting this to be a useless brick. Naturally, when I reached out for support, I got nothing in return. Submitted a diagnostic log, but nothing came from that either.

Here’s hoping they address these major issues ASAP.

Thanks for your response. I too have lot of wyze products in my home. Hoping Wyze will help us resolve the issue. I still have some time to return this product. Expecting someone from Wyze to reply to this thread. Not sure if there is any alternative to this wireless cameras for driveways (outdoors).

Same “no video available at this time” issue here which i posted more details about it the other thread that guy69 started.

I too have a Battery Cam Pro where only the video clips are broken. I get “Error code 05: Failed to fetch the video from the cloud”.

I have spent some time troubleshooting. The same camera works fine if I tether it to my cell phone or take it to the coffee shop, where they use Comcast internet. However it is broken on gigabit fiber for both my neighbor and for me. We use Centurylink fiber GPON.

My other Wyze cameras work fine. I bought a second WBCP to test and it is similarly broken. I’ll test it out in a few other areas to be sure.

If anybody is willing to share which ISP they are using, (and if you know whether it uses pppoe) I would like to see if this is relevant.

I’ve resolved my issue with a workaround on my router, but the core bug belongs to Wyze.

The battery cam pro video uploader can not handle a link with MTU less than 1500. [Even though other wyze devices work fine] If you are using gigabit fiber, your ISP probably gave you a router with MTU set to 1492. You will need to change your router so that the pppoe MTU = 1500 and the WAN ethernet MTU = 1508.

This worked for me. Instead of getting “Failed to upload” and “Error code 05: Failed to fetch the video from the cloud”, and I am getting video clips.

Egad. We are with century Link. This has been so frustrating! I’ve been emailing back and forth with WYZE support on this, but they do not seem to be that interested in this fix. Another user on Reddit found the same workaround you did. However, on my Modem (C4000XG) it only allows me to set the MTU Value on the Wan to 1500. It will not accept anything higher. And when I go to WAN settings there is no option for MTU Value. Can you tell me where you found the second Wan Ethernet MTU you mention? I feel I’m so close to fixing this. I would appreciate any help!
Thanks!!!

@skiman270 I brought my own router to Centurylink fiber (Edgerouter-X) and am able to configure it like this. Sorry, but I bet the C4000XG won’t let you. It’s unclear which of those two settings your router is actually allowing you to modify, but if setting wan MTU to 1500 doesn’t work then I guess it’s not the right combination of settings.

Also, that reddit thread is probable me. Just trying to get this out there in case it helps someone else.

Thank you for the reply. I’ve been corresponding with Wyze about this and have shared these threads and my attempts to fix this. But I’ve been getting the same canned emails from them, so my guess is this won’t be solved any time soon. It sure seems like it would be an easy fix, since I have two Wyze cameras working seemlessly on my network, but this one is not. Here’s hoping . . . ;0)
Thanks again and great job finding the problem!!!

I, too, am hoping for a fix for this. Have 4 of the BCPs and they’re almost useless to me if the video isn’t captured.

I hear you. Very frustrating to have two cameras that work and two that do not upload the videos. This should be a simple fix from their end. I wish they would prioritize a quick firmware upgrade to fix this.

update: Last couple of days it has been working flawlessly now. Only did two things since my original post. Ran about a 234 ft extension cord to the testing location and now have the battery pro cam constantantly plugged in to a 1A power adapter. The other was doing a full format of my samsung evo select 128Gb sd card using my laptop. I also have it set on continuous recording. I don’t know which if any action helped but so far, so good.