Wyze App 2.15 Released! 11/9/20

With this app release, I have a locked Person filter button on my Events screen.
I pay monthly for Person Detection so this should be available.
I do see Person events in my detected events and also see the locked Person filter button.

However, if I pull up the Filter screen I am able to select the Person option (in the CONTAINS section) and accomplish a filter that way.

The two approaches (direct Person filter button on Events screen, and Person select on Filter screen) should be consistent. AND enabled for folks paying for Person Detection. Actually why lock it at all? Just let it be whether someone pays for Cam Plus or Person Detection. It won’t do anything if there are no Person events.


Still nothing in the app store.

1 Like

Sorry, I’m referring the version I’m currently running on my iPad, WyzeBeta 2.15.13 … it appears to be the latest Beta

1 Like

I’m having the same issue and customer service was no help whatsoever,

Still no update in the apple appstore for this. What’s the hold up Wyze? I know that Apple can be slow but this is annoying. I hope the app updates in the appstore before I get my V3 ha

It’s now in the Apple appstore


Fast foreword! Zoom Zoom!

Updated to the new app iOS 14. Have a lag starting events, some events won’t play and some start and then get “stuck” and won’t play after a certain time frame. These errors are new with the new app.

iOS 2.15.22
Firmware (V2s) (Pans)

I just tried the new player. Out of 45 events, there is only 1 who does not want to play. The cursor advances but the image is frozen. I also tried events that didn’t want to play with the beta. No problem reading them. :+1:

The problem with the correspondence between the time of an event and the playback which had been present since the last 3 official updates has disappeared. When we watched an event and clicked “playback,” it always got us to 5 minutes of the present time instead of bringing us to the event. :+1: @Seapup

With the last betas(firmware and application), I had no more Failed to upload event(3-4 sec events) It should be the same with this official release. :+1:

I still have to test the new detection mode to see if motion still be detected even if the zone is grayed.

Good job @WyzeTeam . I am very satisfied of this update.:slightly_smiling_face: I’ve been using a beta version for several months due to the event bug and playback. Now it’s time to use this official release.

Edit: My joy was short-lived. Since midnight, I have had several problems reading the events. The same ones I brought back during the betas. It only happens on 12 second clips. CamPlus do not have this problem.


I had these different issues with the beta on about 20% of the events. I just tested the official version. Only 1 in 45 events did not want to play. Image frozen but cursor moving forward. I hope I didn’t rejoice too soon. So far, I have it installed on my device which is iOS 12.4.8. I don’t have it yet installed on my iPad which is iOS 14.

1 Like

iPad iOS 14 - event to playback time working correctly now. Still getting the same amount of failed to upload events and clicking ok takes me to the top of event list.

1 Like

I haven’t had any for 12 days, day of firmware updates v2: 4.9.6. 207 and Pan: 4.10.6. 207. Recently, the .215 came out and still haven’t any.

Before that, I didn’t have many. It’s hard to see why some updates fix the problems for some but not all :thinking: If you’re sure the problem isn’t with your network, the guys at wyze are going to have some work to do to resolve this error for everybody. :slightly_smiling_face:

1 Like

My joy was short-lived. Since midnight, I have had several problems reading the events. The same ones I brought back during the betas. It only happens on 12 second clips. CamPlus events do not have this problem.

If anyone is interested, I can post some of them.

My events lag unless I filter only one cam at a time. They then go pretty quick. Otherwise the lag on events loading is several seconds long. This is all cams that are Cam Plus or otherwise. I have not had a single fail to upload error or missing fragment error. However I am on the beta firmware for the cams and have all AI functions disabled due to AI bricking 2 of my cams.

Just got the iOS version of the app update today and am having the same issue others here are having. Seems like now every update makes new issues. Here is a suggestion Wyze…pull all your staff off making new products. Then hire people that actually know how to write code and focus on your current product software issues. Don’t make changes for the sake of change, make changes your customers want. Quality not quantity.

1 Like

Disabling the AI has helped tremedously. I’m not going to enable it either anytime in the future. If I can’t tell the difference between a package and a cat then I have more problems then Wyze has with these errors. Although I don’t like how it overtakes the entire events screen and you have to do all that scrolling to just get to the cams

I like the new speed feature, but where we really need the ability to watch at faster playback speed is when viewing the playback from the sd camera.

I guess it’s good at the ffw as a lot of people wanted it. But glad they fixed it for people like me who want normal speed. Otherwise no difference between that and time lapse imo

I seem to have a new feature but I’m doubtful it’s app update related. After months of PD working almost flawlessly, it is now identifying cars and school buses as people. Thank you Wyze, always an adventure.

1 Like

I knew it wouldn’t be easy on the announcement. There were already difficulties to identify as a person and they want to add packages, cars, boats, planes, pets, persons’ names, snow, rain etc …(sarcasm).

It’s good for sales but when you start using these features you quickly realize that it doesn’t always work as it should and some basic functions suffer.

1 Like