Wyze Air Purifier Not Updating AQI and Graph in App

In the App for my Wyze Air Purifier on the Insights page the Indoor AQI History is supposed to put a dot on the graph every hour and on the front page the Indoor AQI circle should update every hour as well, but neither are updating. I did discover that if I unplug the machine and plug it back in, then check the app both the AQI and graph will update, but nothing after that, even 24 hours later. Others seem to be having this same issue. I contacted Wzye by email and they replied with a cut and paste answer that didn’t fix the issue. If someone has come up with a solution, I’d like to hear it.


Hi, may I know if you have submited the log so we could check what could possibly cause this? Please provide me the log number if you have done that. Thank you so much!


Thank you! I will go ahead and look into this case. Could you please verify me with one thing real quick? You did mention everytime the purifier reboots you will get one updated AQI number. What are those numbers exactly? Please list them if possible so I could also have the team to check. Thanks!

After I unplug and plug the purifier back in then the app shows an AQI number that was on the purifier display. And then it never updates again on the app. I’ve unplugged and plugged in the purifier numerous times so I have various numbers on the app when I did this like 23, 1, 10, and so on, it’s whatever is on the purifier’s display at the time.

Understood. I will keep working on the log you have submitted. Just a quick reminder on the AQI update scheme here for your reference. It is not a time-triggered update. If the AQI is lower than 116, it will only update under following cases:

  1. network reconnect
  2. Device reboot
  3. Device has detected that the AQI number changed out of the certain range, for example it changed from 20 to 50
  4. And if the fan is not running the AQI will not update

Considering your AQI is really low, the case might falls into the third case here. I will definitely let you know if there is any update on the log here but just give you my thought for reference. Thank you!

Then why does the product information picture about the air purifier show dots on the app graph page every hour? And on the main app page for my air purifier the AQI also shows an update time. Right now that number has been 1 on the app for over 24 hours. Seems pointless for it to give an update time every hour or so yet the AQI number hasn’t changed.

This is how Wyze advertises the graph. Look at all the dots, one for each hour and most are below an AQI of 116.

Hi, could you please resubmit the log one more time? We seem to have a bit issue retrive the yesterday’s one. Thank you!

Indoor AQI not graphing - #29 by Alien88 literally have a topic on this for 3 weeks since I got it.


Hi, could you please resubmit the log and let me know what is your log number? Thanks!

Did you get it?

Still no dots showing up on the graph and the AQI has not changed on the app. What’s the point of the app showing when it updated yet doesn’t show the data? This makes no sense!

1 Like

Yep I got it. They are working on it. Thank you!

And is there any possibility that you could try to make some sort of smoke around the device so the AQI can be increased. If that still doesn’t trigger the AQI update on your app, probably the sensor connection inside the device is loose. Thank you for your patience!

So at midnight the AQI changed on the app to 002 and I got two dots on the graph, one was at midnight and looked to be 002 AQI. The other was at 1am and was around 001 AQI on the graph. This is still not acceptable and certainly not what the Wyze promotional picture suggests should be happening. I may have a defective machine.

Thanks for your info! Please do me a favor and submit a new log if you don’t mind. Since this log should have those two updates in the midnight. I will have R&D team take a look again and see if there is anything wrong with this device. Thanks!


Clearly something is wrong with my machine!

So on the app for my air purifier the AQI has been 11 all day and I now have four dots on the graph for 12am, 1am, 7am and 8am, all are below the PM2.5 Health Guideline dashed line. So where is the problem, in the app or my air purifier?

So it appears while the app shows the AQI updates about hourly, the number actually never changes. And for this new 24 hour period I have only one dot at 5am on the graph, which looks to be 1 AQI. This is so frustrating.

1 Like