Wyze 47 Watch stuck on update loop

Wyze 47 Watch beta version 0.12.49 stuck on update loop, anyone else having this issue?

Yes, stopped the update, rebooted and tried again, it took. Afterwards it wouldn’t connect so ended up doing a factory reset on the watch 47. It connected after that.
Note: History is server stored.
-but- The 0.12.49 is now having trouble establishing connection again. . . ymmv

edit: Did a watch Restart and eventually it connected.
Additional discussion here.

1 Like

My watch 47 fails to upgrade to 0.12.49 from 0.12.48. I’m using iOS 14.6 on an iPhone 8 where the Wyze app is set for Beta.

When trying to update the firmware on my Watch 47 the following happens. The watch syncs successfully.

  1. App downloads the firmware

  2. Watch shows update %. Gets to 18% and goes back to 0% and fails at 17%, then starts over at 0% etc…. Update fails on watch after fourth attempt.

  3. App keeps trying to run firmware update.

The app progress bar does jump to fully lit when watch gets to 18%……

Rebooted app with same result.

All you have to do is make sure you close out of the wyze app, go into your phone settings and forget the watch in bluetooth, reconnect it and then re-pair, retry the update and you should be good! This worked for me after the same issue.

I was having the same issues updating as well using my iPhone. The following steps is what eventually worked for me:

  1. Factory Reset using the watch interface:
  • Settings → System Control → Factory Reset
  1. Remove device from the app (this should clear the plugin data for the watch)
  2. Forget watch in phone Bluetooth Settings
  3. Add watch to Wyze App (I did it manually, did not use the QR code), complete initial setup
  4. Update firmware

Hopefully this works for you.

Thanks a bunch, this worked, easy to do.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.