Wyze watch 47and wyze 47C not connecting on wyze app ios

I changed my phone and tried to connect my wyze watch 47mm and a new 47mmC but cannot connect to the app on iOS. When I try to connect I get message saying " Pairing failed, Please restart the Bluetooth or reboot your watch and try again". How can I get my watch to connect?

Welcome to the community @nigiel.hall

Check to see if you have Blue Tooth and Local Networks on.

These are my settings:


I have these settings also but still no change.

I have the same (if not very similar) issue. I swapped phones. I reset my watch and it allowed me to pair the two initially. I messed up and tried to go back and change info and couldn’t locate it within the app so I attempted to re-pair the watch. Now I get the same error. I’ve restarted the app. Deleted the app and logged back in. I keep getting a pairing failure notification also. This is frustrating and apparently, live chat cuts off at 10pm. This is all after having to create a new account and swap all my cameras over to that one, finding out that my Outdoor cams are worthless now because I can’t get back into my old account and now the watch isn’t working. Wifi network is up. Bluetooth is up. Hoping someone can help.