Watch 47 fails to pair after firmware update

Anyone successfully update watch 47 firmware with watch still able to pair with their phone?

  • Watch initially paired after charging
  • Followed prompt to update firmware
  • Firmware update indicated “success”
  • Watch unpaired upon reboot
  • Followed all tips and suggestions on Wyze website without success
  • “Forgot” watch in app and in phone Bluetooth
  • Phone rebooted several times … app and Bluetooth turned off and then on again
  • Watch shows QR code, but watch doesn’t pair with the code or “manually”.

My colleague had an issue his watch and the FW upgrade, he has an iPhone. I had no issue and have an Android.

He had to forget the wyze BT connection on the phone and then reset it up. So it may be worth, forgetting the BT Connection and deleting the watch from the Wyze App and then setting it up again.

He had also rebooted the watch as well.

Thanks for the response. I’ve already already followed that procedure without success. Watch doesn’t show in the app and its Bluetooth profile was deleted. Starting from scratch … no joy.

1 Like

Yea, I understand. He had to also, so it wasn’t that bad for him as he just got it. I, fortunately, had no issue. As I indicated, I have an Android Device and he has an iPhone. Wonder if it is App/Phone specific. What device do you use?

Similar issues with android 10 phone
Did a firmware upgrade after initial setup and now I can’t get it to connect. Turned bluetooth off and on. Rebooted watch, rebooted phone, removed watch, added it back etc…

Adding watch failed several times then got lucky and it paired. But a minute later after trying to change wallpaper via sync it disconnected and won’t connect.

Anyways it is brand new so there will be issues, however if they need to create a new firmware, I’m not sure I’ll be able to apply it if I can’t connect.

Got watch today and it doesn’t stay synched, constantly losing synch with android 11 phone.

The only additional item my Colleague did to get his to work was to do a Factory Reset of the Watch itself. He did have to delete from the App and delete or forget the BT entry in the phone as well.

To do a Factory Reset, go to the watch, swipe left, swipe up, then tap on the gear. Select System Control and then Factory Reset.

After he did that, he added it back to the app and paired it without issue.

Thanks for the info. That was one of the things I did in my troubleshooting. Glad it worked for him but I’m starting to think there is an issue with the software/firmware and most of us are kind of stuck until they sort it out. I understand we are kind of the early users so they will get it sorted eventually,

Sorry to hear that. I am sure they will come out with a fix. I have already noted a potential bug with notifications from emails. Mine, at least, appears to only provide the From and To, but not the Subject or email body.

Just got my watch 47 today. I had the exact same problem. I have tried all the trouble shooting steps. Started on my Android phone then tried on another Android. Then tried on wife’s IPhone. Exact same results as you. I’m getting kind of tired of Wyse rushing half baked products out the door. I had a problem with a Wyse thermostat and waited over FIVE WEEKS for any kind of assistance from the support team. Kept telling they were “really busy”. Never resolved it and sending thermostat back. I’m sure as back not waiting 5 weeks for them on this issue. Watch goes back. Seems like Wyse is getting out of their depth. Too many products too fast and jamming them out the door. I used to be a real fan. Not anymore.

1 Like

I performed the factory reset after trying all other options.

All I get now is the QR code to pair the watch … which fails every time.
I’d try another factory reset, but the procedure mentioned in a prior post doesn’t work from the initial screen … swiping gestures don’t work.

Needles to say I’m as disappointed as others who are experiencing the same issue.
I hope that Wyze has a recovery strategy to get the watches working once again … or every one of them will have to be replaced.



Moderator Note: Personal information has been manually removed from this post. Such information often gets included inadvertently in an email signature block when replying by email. The forum software attempts to automatically remove email signatures but it is not always successful. When replying to the forum by email, it is best to remove the signature block yourself before sending.

1 Like

So an update on my issue if anyone is interested.
I seem to have some connection stability.

Unclear if the steps I performed had any bearing in the result but here it is…

I could randomly get connected for short periods of time. Like if I try 10 times, I might get connected once.
During this time, I have removed one of the three wallpapers so that I could upload from the app a different wallpaper.
This usually fails to sync, but after tons of trial and error, I did get this wallpaper to sync(it usually fails).

Bye, this sync literally took around 10 mins. It makes me think that there is more than the wallpaper syncing and maybe whatever data synced was relevant to the connection issue.

Anyway, I’ll see if it remains stable.

I hope this helps, stick with it, this process fails way more often then it success.

1 Like

Same for me, fails 9 out of 10 times, see error pop up a lot with code 24-101

Update: I received a email this morning offering “the possibility” of a replacement.
I replied with the requested name, shipping address, contact #, purchase date (12-1-2020, received on 3-19-2021), model number, and order number.

We’ll see how quickly they respond and whether the “possible replacement” occurs.

@p1066wilson What did you do to initiate this email from wyze?

I contacted their customer service portal last Friday.
Had to navigate through several FAQs and indicate that my question wasn’t answered prior to being offered contact via the email option.
Initial response was about four hours later with the generic “try this procedure” linked to a FAQ that had failed multiple times.
Responded with that information and then received the “possible replacement” email this morning.
Over 7 hours have passed since my reply and haven’t received further information.

I had the exact same problem. Very similar to what happened to my Wyze Vacuum. May have to get a replacement like I did with the vacuum. It doesn’t seem like it can pair again with my phone to update, so unless it can plug into a computer with the charger cord and update the firmware I don’t see a solution.

I have an iPhone. Apple did an update this weekend. Before the iOS update, no issues with my watch connection. After the update I had to turn the Bluetooth on for the watch to reconnect. I’m also running a Pebble Time Steel and it reconnected without me having to do anything.

Another update: My issue was escalated to a “Wyze Wizard” who issued an order for a replacement watch along with a return label for the defective unit. The watch shows as “shipped”.

I’m pleasantly surprised that my issue was thoroughly addressed within four days of the initial contact … including a weekend.

I’ve also asked the “Wizard” whether I should attempt a firmware update when the replacement arrives. I’d hate for a second unit to be “bricked” when the update is applied.

We’ll see …

Useful update, thanks. I’ve submitted my own case and in early “please try this again” stages. Hopefully I’ll get the same outcome as you. Weird, they seem to have a major issue here. Seems like there might be an error in the new firmware or update process but I haven’t seem any changes in the app. Maybe they’ve fixed it in the new firmware that is being downloaded. As you say, hope it doesn’t happen again.