Watch Firmware Updates Failing

I pulled out an old Wyze Watch 44 - I think I bought it at launch and never activated.

It says it’s on firmware version 0.2.87 -current is 0.3.65

I have been unable to update this - I’ve tried various networks all day long.

I tried to contact support via chat - but they were convinced it was “local network congestion” - even though I updated firmware for a camera and several bulbs and didn’t have any problems…

I did try several times throughout the day on different networks - even when I was on a very strong 5G cellular with 140 Mbps down and 60 up!

Usually I get an “Oops…” message. Occasionally it would look like it started, but the download / progress meter would never move.

Honestly, I suspect there is a problem with it being such an old firmware - any thoughts?

1 Like

Did you try to reboot the watch. Hold the button down and you should get a message about rebooted the watch. I would try that and then try to install the FW.


Thanks - I’ve tried rebooting and even making sure to pre-charge the watch to 100% before attempting.

The problem seems to be the Wyze servers - the phone (phone app) reaching out to the Wyze server to grab the firmware update.

It seems like it never “downloads” the firmware from Wyze.

** I was able to watch the process from my router’s bandwidth monitor. The watch is not moving any data, although it says it’s max connection is “72.2 down / 72.2 up” based on the 2.4 channel. I can see all of my cameras randomly spike bandwidth usage, but the Watch never seems to move. I turned off every stream in my home and even disabled all of our phones - the router bandwidth monitor never went above 10Mbps download and averaged closer to 1.8…there was plenty of bandwidth for the phone / app to download the firmware!

Honestly, I suspect there might be an issue with how old the current firmware is - maybe a preliminary compatibility check…but I can’t seem to get Wyze tech support to weigh in on that idea…so I’m trying everything I can!

Unless I am mistaken, and I could be. With the watch the firmware downloads to your phone and the phone will send it to the watch. So you would never see the watch on your router moving data and disabling the phone would definitely make it not work.


That’s what I thought too - but when talking with Wyze tech support they were “concerned” with the amount of “congestion” on the 2.4Ghz Wi-Fi band (ironically, it’s only a bunch of Wyze devices / cams / lights / etc.!!!)

They were specific about the 2.4 band too - obviously the phone is going to get much more bandwidth on the 5 Ghz band and that’s the preferred connection, so I had to force the 2.4 network too.

That led me to believe the Watch was trying to connect directly over Wi-Fi…

Like you, I assumed the phone / app would handle the bulk of the work downloading / extracting files / etc. and then use Bluetooth to transfer the data. It seems like the phone processor would be much more suited for that type of work!

When I mentioned disabling phones - I was just trying to isolate and give the connected phone and the watch as close to 100% of the bandwidth that I could - both local area Wi-Fi bandwidth AND all of my available internet connection.

I wonder if they are using just basic trouble shooting and got confused or if I am wrong. Let me do a bit of digging and see what I can find out. Do you also have a ticket number from when you called support?

1 Like


I was assuming they were doing basic troubleshooting as well - obviously I was frustrated but tried to follow their directions to keep the process moving.

However, later in the day I did see my Watch 44’s MAC address in my router’s attached device list on th e 2.4 SSID…so I don’t know!

I also tried updating from the phone app while on a strong T-Mobile 5g cellular data connection (120+ down, 40+ up!)
It still didn’t work, but I didn’t get any error message ( like please connect your Watch 44 to Wi-Fi…or anything…)

Wyze Ticket 2070226
I submitted a couple of logs as well 584097 / 584132

Thanks again - I realize it’s not a super big deal - but one of the reasons I think I need to update is that I don’t have the Shortcuts (or weather) on the Watch 44 list of apps (they both appear in the phone app)
I can update watch faces, sync data…but for some reason Shortcuts and Weather don’t appear on Watch44.

I just left a FitBit which I was using for years - I was looking forward to using the Watch to control my Wyze ecosphere of devices!

Ok, I only have the 47 running, (I have a 44 not in use but I would have to find it). When you go in the phone app then into the watch there should be ‘watch app display’ is weather and shortcuts listed there?

1 Like

OP is running the old 44 base firmware 0.2.87 and needs to update to get the app display feature. Also needs to make sure Wyze app is up to date.

1 Like

Yes - in the phone app I have both Weather and Shortcuts - I’ve even modified weather, defined a city, etc. and I do have 6 shortcuts added / active.

Good to know!

I was assuming that was the case - and that’s what’s prompted me to try and get a fix from Wyze!

I’m guessing there is some issue upgrading with such a wide spread in the firmware - just hoping to get some type of resolution. The Watch isn’t totally useless…but it doesn’t have the software or feature set of the Fitbit I left. If I can’t utilize the primary feature (Wyze ecosystem control) I’m not sure it’s a great replacement.

I think I’ve got a Band and 47 too - however I’m not too optimistic those were ever updated!

It seems like there should be some type of upgrade path - even if I had to run multiple firmware updates to get current!

1 Like

Go to Wyze app Home > Account > Firmware Update and see if you have updates for your 47 and Band. If you do, try updating them. If neither updates successfully, it tell us where to look next.

Also… if your 47 or Band haven’t been fired up for a long time, you should charge them before attempting a firmware update. Loss of power during firmware update may result in a brick.

1 Like

Looks like there may be a possible issue with firmware updates for watches, the team has been informed and are looking into it


I’ll try updating them tonight.

It does show the band has pending updates:
Watch 47: Latest 0.12.49 / current 0.12.49
Band : Latest / current

1 Like

Thanks!!! I’ll still try and update my Band tonight…assuming I can find it.

I need a Wyze shelf or box or something to organize all these!

1 Like

Interesting… I successfully walked another user through a 47 update last night.

1 Like

Well my Band updated just fine:
Latest Version
Current Version

After seeing how quickly that upgrade completed I tried poor old Watch 44 again - still no luck.

Occasionally it does “freeze” or lock the phone app up with a progress indicator. I left my phone on, plugged in, and next to Watch 44 overnight and the progress bar never moved and the app never “recovered” and required a force-close.

1 Like

Good to know! :+1:

There may be a problem with Watch firmware updates. WyzeJasonJ is looking into it.

The only other thing I can think of to try is a reset. If you do this, you’ll lose any stored data. To reset, swipe up on the watch home page/face, tap the Settings icon, scroll to the bottom of the list and tap Reset. Then go through the setup procedure.

1 Like

I just purchased a Wyze 47. I keep getting the notifications that a firmware update is available. However, the iPhone app says downloading but never gets past that point. The download progress bar never moves. Yes, the phone and watch are near each other. So, I’ll be interested to hear when/how this issue is resolved.

1 Like

Thank you for confirming! :+1: Wyze is looking into the issue. We may not receive a status until next week.