Wyze Watch 47mm Firmware Beta Test 4/20/2021




  • Fixed a bug that prevented the touchscreen from responding

Just checked and the FW update is not available on my Android Device. Still at 0.12.41.

Same here - Android 4/21/21 0824 CST no offer to update when I check FW

Is there a scenario to test this bug fix that we can do? I updated to 0.12.42 but touch responsiveness seems to be about the same. Not that I noticed a scenario where it was not responsive.

It showed up for me today… Had to go into the watch on the app and get the FW update notification. The update did not show up in the Firmware update page.

I don’t see it yet… :frowning:

May not be a bad thing… 40 minutes in and the Upgrade gear is still spinning… App Says Downloading firmware watch is on and 1 inch from my phone… Doesn’t appear to want to complete the update.

About to stop, force close, clear data and try again.

I did that and still no FW for the watch. Mine remains on .41.

Yep… the FW will not install for me. I get the prompt to install it just never does.

I have restarted the phone and watch, force stopped the app, cleared cache, logged out and logged back into the WYZE app. None of the above has resolved

Samsung Galaxy Note10(+)
Android 11
WYZE v 2.19.14

I don’t even see it to try and load it. You got further than me. :slight_smile:

Been really windy here, a lot of notifications. However, difficult to connect to live stream. Once the wind died down, I was able to connect to the live stream. I looked at my router as it provides all connected devices and their upload/download Kbps. Some camera’s were showing 711Kbps upload. that is a lot.

I joined the Beta for Watch 47 yesterday. Just went into the app on my phone, tapped the “Watch 47”, and immediately got a notification for a FW update. I told it to go ahead and it went through a somewhat lengthy update, showing the progress screen on my watch. It said the update was successful and then rebooted. Checked the “About” information and I’m still at .41. Which is where I was before this phantom update…

Tried again today… 3 times got “Whoops Failed”
4th Attempt stuck on the Firmware Upgrading Gear Grinding again.

4th attempt failed after 30 minutes of gears grinding
Log ID 188778

LOL – you are a glutton for punishment.

At least you can see it, I have no reference to the .42 FW.

Is what it is… I’m just trying to be a “Good” beta tester :slight_smile: I barely even wear it.
My Galaxy Gear takes priority and being an old school soldier. I still wear a watch on the daily.

1 Like

I really like the Galaxy watch look. But since I had a Pixel, I decided to get the TIC Watch and wore it for the longest time. Now it is in its box in my drawer.

Being at home Teleworking, seemed to curtail the watch wearing. However, I am wearing the Wyze watch. As you, I want to be a good Beta Tester :wink: .

Maybe Wyze will come out with a round Watch with a more rugged look and faces.

Only .12.41 here as well (android) wondering if this needs a software update before it will work and thats whats holding it up (though in checking, probably not. My app autoupdated to 2.19.15 yesterday)

Same - waiting for the .20 version of the app. Maybe that will allow for it. Not sure when it will be released for Beta Testing though.

This is the version I am referring to

@WyzeAndy -
It’s been 4 days, why are the updates coming so slowly?
It’s still not showing up for me.

2.20.03 does not trigger the watch update. Still .12.41