2.22 app, Wyze cam v3 & Watch 47 firmware Beta Test 6/23/2021

No problem. Thanks for the clarification. Thought I was missing something.

Like last go around only about half of my V3s updated without being power cycled first. I still have one at a remote location that won’t take update. I will power cycle and try again tomorrow. Software restart doesn’t help.

In my case, when I did the upgrade, it did .18 first. Once the .18 was completed it stayed indicting that there was an update for the camera I just updated, it was .19.

So basically, there will be 2 updates per V3 camera

1 Like

v2.22.11 FINALLY showed up for me on the Play Store for my android, but TestFlight still thinks that my v2.21.26(2) is current for my @#$%^& iPhone.

The good news is that v2.22.11 for the Android fixes the white bar at the bottom during playback when in landscape orientation.

It was on TestFlight this afternoon for about an hour. They have removed it after. I did the v3s firmwares updates in two steps without issues. I don’t know why they have removed it from TestFlight.


Anyone else have problems updating the Watch? Mine gets to 16% then starts over and repeats. Then says update failed. Another guy on Facebook said he was having the same problem. Except his was getting to 12%.

1 Like

Mine updated without issue. sometimes you can restart the app and it will work

1 Like

mine did fail the 1st time, not sure what % it was at. 2nd attempt was good

1 Like

Thanks I’ll try that.

Regarding upgrade
I had just upgraded a V3 to .18 a few hours prior to reading this thread, it went through fine, reported success so I continued.
But @WyzeAndy I’m wondering if I will have to do a multi step process to upgrade from (for instance) 4.36.0.252 to 4,36.3.19 (or a future version).

1 Like

Cool, thanks for the update.

Curious, when you go to the FW update page, the camera on 4.36.0.252, does it show up as needing an update and to which version?

I’ll check.
/edit
no it shows latest version 4.36.2.5, so it looks like I’ll have to do multiple updates.

Tried that and still same result. gets to 15%-16% and restarts. Restarted app and watch.

Have you tried clearing cache from within the app?

I have set testflight to update Wyzebeta automatically on my iPhone. I get the autoupdate once Wyzebeta is forceclosed on my phone.

I have the same issue. The watch either drops connection or restarts the download. It will continuously do this unless I force close the app to stop the update process. Restarting the app on my iPhone doesn’t fix the issue.

I was able to get my watch to update. Here is what I did:

  1. Factory Reset watch, using watch interface
  2. Remove device from app
  3. Forget Bluetooth connection to watch
  4. Add watch back via app

After doing that I was able to update the firmware and add watch faces.

1 Like

Ahhh … the old hand grenade approach … I couldn’t update either and that worked. Something is amiss. First had charging issues … phone dying in a day… then update issues. Cameras have issues with cam plus uploading data… camera updates fail constantly and I have to retry… very upsetting

No need to be upset. You don’t seem to be one that vendors target for ßeta programs. ßeta updates are not usually an preview of fixes; they are most often an preview of new capabilities, with plenty of bugs mixed in. Vendors hope Beta participants will help them identify fixes by submitting constructive reviews with logs, to help them fix things before the official release.

For a smoother experience, I would recommend dropping out of all Beta software & firmware updates and just going with the more normal production software & firmware updates. Much less stress for sure! :slight_smile:

5 Likes

I will also say, after this update, battery life on my watch is MUCH better. 14 hours or so later and only a 2% drop. Previously I’d be down 40% or so.