Wireless cameras won't connect on Wyze App

Two of my outdoor wi-fi cameras will not connect through the app even though they record events and send me notifications on any movement. I have brought them inside to ensure wi-fi connectivity is not an issue but am still having the same issue.

Also, a third wireless camera keeps getting confused with the other two wireless cameras and briefly shows images from them before returning to normal.

I have reset both offending cameras and have also cold-booted the base but the problem persists. As a result, I can’t watch live view of the two cameras.


Have you power cycled the hub?also log out of the app and then back in. Do you have the set up with cam + or cam light?

Yes, we have cycled the power of the hub and also the cameras. Both cameras are CAM+. Also, deleted both cameras in the app and re-added it but problem persists.

One similar camera that DOESN’T have CAM+ works fine except it keeps showing images from the other two cameras as thumbnail. When I touch the thumbnail on this third camera, it shows the actual live pictures without any problem.


Sunil Sinha

Interesting thats so weird,try to plug the camer into the charger then let charge for 10 minutes then try to connect to the camera

Unfortunately, I have already done that without success. Last night I deleted both cameras from the app, reset the cameras by pushing the reset button in the back, added back to the app; reset the base (twice), and then left to charge all night long.

This morning, battery was charged 100%, it is still recording movements and sending notifications but the app won’t connect to the cameras. Gets stuck at Getting video data (3/3) screen.

Have also restarted the Iphone.

1 Like

Well if there less than 1 year old do a warranty replacement at Wyze

Turns out I am not the only one. Pretty close to what’s happening to me. Mine also happened 4-5 days ago. Also, I think I’m past 1-yr period since buying it.


One of the cameras is still less than 1 year old so I guess I can get an exchange on it but I still don’t think it’s a camera issue since two cameras won’t go bad at the exact same time. Moreover at least another person is reporting similar problem that started right around the time my problem started.

1 Like

Use another device and try to connect with it

This appears to be a bug, as this is being reported by others (including me).


Thanks for confirming. Yes, I am pretty sure it’s some sort of bug and perhaps an update would resolve it.


1 Like

Mine just started doing this same stuff within the last week. Hopefully there is a quick turnaround on a patch.

1 Like

Someone in another thread said take cameras out of the ‘group’ and that would solve the problem. Tried and sure enough, they are working outside the group. Hopefully, there’ll be a quick update for this bug. Thanks to all.


I have no issues getting my 4 WCO to open in live view when I first open them, they all load in a few seconds. “BUT” if I make a change in the settings and then tap < in the app to return to live view before closing, the cams just spin 3 of 3. Using iOS app on iPhone I just quickly force close the app, open the cam and it will again load in a few seconds, Annoying

I just updated WCO firmware to and it seems to work better (For now) :joy:


My 4 outdoor cameras are doing the same thing, has there been any resolve?

I had a weird thing pertaining to this. I have two outdoor cams. One in the front yard and one out back. The out back camera was working fine and the front wouldn’t load in the app. So I thought I would just move the camera outback and move it to the front and rename the camera to front and now it won’t work either. It’s still capturing motion as I still get events notifications and videos from the cloud. I’m just going to wait until they figure this all out before I worry about it I have 17 other cameras that are covering everything anyway.

If you have the cameras in a group, take them out. That seems to fix the issue for now.


Interesting. That worked. Would have never guessed. Thanks a lot

I don’t know what a device group is but my outdoor cams livestream after I disabled the VPN software.