Video plays but cannot be downloaded

Go to settings, scroll down to the WYZE app, tap the arrow. Next to Photos it should say all photos.
I personally think it is a Cam Plus issue.

All were turned on , tried viewing from another device and still can’t download , even changed settings to auto on camera and created an event and won’t download to phone or iPad on the same network …I could blame it on internet settings but encountering the same issue on Century Link network at primary home in another state and Zona Wyyerd in this state .

I just turned off cam plus for this outdoor camera and created an event and still won’t download that new event to my device :woman_shrugging::woman_shrugging: or my other device .

I’m beyond frustrated. Has to be some setting somewhere or faulty outdoor cameras but that would be 3 bad outdoor cameras .


An update overnight now to the most recent version of IOS security fixes 16.1.1

It’s not the cameras. If your read my old post above you will see I had the same issue and finally gave up.
One more thing to try. You could take one cam off of Cam Plus, go to your account on the WYZE Web site and get one free version of Cam Plus Lite. Put it on the cam without the cam plus and try it out. I have CP lite on my 4 cameras, They do have a cooldown of 1 min and only record 12 videos but I can download them and they are backed up to the base station also. I also have some of the cams doing scheduled event recording to the SD in the cams, set for 30 days, no cooldown, max video duration set for 2 minutes each. If you don’t like it just put the Cam Plus back on the camera and wait to see if a fix can be made.

I was in the process of checking that same thing before you emailed and surprise surprise it worked and could download video :thinking::thinking::thinking:. Now I also shared the camera with my sister so hoping that has no affect on it …but I’m reverting my outdoor cameras in both locations to cam lite for now . I’m going to go back to Wyze with a log now explaining what I have done and why it is now working. I’m paying for Cam Plus unlimited because of all cameras but not getting what I’m paying for if they can’t resolve :face_with_symbols_over_mouth::face_with_symbols_over_mouth:

I appreciate all the help from you 2 on Wyze forum to at least get me a temporary fix !! Thank you. BUT this is something Wyze needs to fix !!!


Good luck. WYZE even sent me a different base station to try which was nice of them but it made no difference and was a pain to delete the old base and set up the 4 cams again. You are correct then need to fix it.

Update …I just finished a chat with Wyze again expressing frustration! He had me reassign the cam from lite back to plus , create an event and guess what it works now and can download on phone :woman_facepalming:t3::woman_facepalming:t3::woman_facepalming:t3:. It only took since May and the cost of a new camera to resolve and you alls suggestions .

I have unassigned and reassigned before but never assigned to lite and reassigned to plus . They either fixed the flaw today or something… hope this continues to work and they get their Wyze reps up to speed.

Right now it is working in Cam Plus to download video​:tada::tada:

Thanks again for all your help guys!

Do you have any hair left after this ordeal? :rofl: I just got more gray after my episode. Hope it stays working.

I have hair but like you getting grayer by the minute! We actually can’t get any grayer but could pull out😂

Thanks again

Glad support was able to help. That’s a strange issue, but we will see if it continues to work for you!

Well interesting I left and returned just now. Cam on Plus went to events and surprise surprise it wouldn’t download again. So I unassigned and assigned to lite then back to Plus then created another event and now I can download. So obviously it may work off and on but only safe way us Cam lite until they can figure this issue out permanently


FYI the shared camera with my sister won’t download at her house either :woman_facepalming:t3:

My biggest concern now is with update to home monitoring requiring cameras need Plus :woman_facepalming:t3:

Well only way it works is with Cam lite …any suggestions cuz a waste to have cam plus if it won’t work?

Go thru the process that fails, submit a log after, then post the log number in this thread, and contact support that you want that log number relayed to the devs. Sure sounds like a bug.

801085 Log ID

Please submit this to developer!! I have sent numerous logs cam plus won’t allow download event. Cleared caching, unassigned reassigned outdoor cam to cam plus, only way to download event is on cam Lite. All current firmware. Can’t use cam lite for new update tonight HMS. All cams download except outdoor on CP

You’ll need to contact support to get that to the Devs.

Did but not sure they will do anything :woman_shrugging:

Nine months later, and I am suddenly having a similar problem. I am finding it nearly impossible to download videos generated by a motion event, but I can save “live” recordings and automated events to my iOS devices without problem.
I posted to Reddit (at (Reddit - Dive into anything ) and received a couple of thoughtful replies but no solution based on discussion there or here. I also submitted a support request directly to Wyze.

Follow-up. 3 days later and, without making any other changes, downloads seem to be working again. ??!!?? I’m not ready to call this “solved” but, even if I can get back to just sporadic problems, given all the other advantages of Wyze, I’m willing to stick with it. Also, I will note that I got a thoughtful email response from Wyze support. They didn’t suggest anything that I hadn’t already tried, but it does give me a support ticket and email trail to refer to in case the problem occurs again and I log the event.