Recorded events not downloading

This home camera started off great then went to crap! Has anyone experienced their recorded events not downloading to save in app? Events are recording but not all are saving when I download. Clearly an app issue bc sometimes it downloads to save, no problem. Recently most of them do not. My Ring downloads and saves no problem.
I’m so frustrated considering events are up to 15 days before removed and I’ve paid for the YEAR ON TWO CAMERAS. It’s been 4 months. The last two months service has not been provided

1 Like

I’ve had issues with downloading and saving videos from all of my cam v3 cameras while using the cam plus service.
If I use cam plus lite I can download and save videos
from my cam v3.
This has been an issue for 6 months.

Ugh. 6mths??! That’s terrible! Shame on Wyze for not fixing this problem.
I cannot believe subscribers paying for subscriptions, cannot get what they are paying for. The whole purpose is to have peace of mind, record and save the events needed. BEFORE disappearing in 15 days-
This is terrible service!!

1 Like

Questions for those who have posted…

I have 26 cams on Cam Plus: VDBv1, PanV1, V3, V3Pro, PanV3, OG S and OG-T.

One thing I notice is that both of you are using iOS devices while I am using Android, so that may be one possible origin… App Version.

This thread is tagged CamV3. But do you experience Cloud Event Download issues with any other model cam Event Videos?

When you click the download icon after the event has fully played, what happens? I find that it takes an excessive amount of time “loading” before it shows me the “Successfully Saved to your System Gallery” message.

If you click the Share icon, do you get similar issues with downloading the file for inclusion in another app, perhaps email?

1 Like

I just tested my cam v3 using cam plus lite and I am able to save videos from the Wyze cloud, I saved 12 videos with no issues.

When I use cam plus (the paid version to allow longer recordings without a delay) on the same cameras I am unable to save videos from the Wyze cloud.

The problem is with Cam Plus recording and downloading and saving them. I’ve contacted and placed work orders with Wyze at least a dozen times if not more.
They still have not come up with a fix or a response to me.

Maybe if more users report this issue something may get fixed.
If not, I will not renew my cam plus, since it doesn’t work.

1 Like

I have the same issues with my outdoor cam ver1 also. When my cameras are using cam plus lite and record the 12 sec videos they will save with no issues.
When I switch the same cameras to cam plus my videos will not save.
When I try to save videos with the download button or share button the icon spins and states loading.
Ive let it try to download for several minutes, never completes the download.
Occasionally one video may download and the next 40+ won’t . A successful download takes less than a second when it actually saves one.

1 Like

Im not sure what to tell you. I don’t have iOS so there isn’t a way for me to test this to confirm it. I have Android and it downloads fine.

I do recall that others have mentioned issues with being able to download events, but mine have always worked so I haven’t followed those threads too closely.

I am tagging in the other @Mavens to see if any with iOS can duplicate the issue or locate threads where this has been reported to Wyze and they are working on it.


I am not having any trouble saving Cam Plus cloud recordings from V3s or WOC V1s on the current production app of 2.41.5 (5) on my iPhone 13 on iOS 16.4.1 (a). What version Wyze app are you using?


I am using the same 2.41.5. All firmware is up to date.
I’ve tried saving videos on my iPad, iPhone and my wife’s iPad and iPhone using Wi-Fi and LTE, very seldom does the Wyze program allow me to save anything.
I’ll try 20-30 different videos, sometimes I may get lucky and one or two will save other times none.
When I tap the download button or share button the icon states “loading” and just spins.
We have fiber into the home 1gig up and down for internet.

Today I tried downloading five videos they all saved fine then videos after the five would not save.

Yesterday I tried a dozen downloads and none of them saved.


I saved about 10 more with no issues. One thing to try would be to delete the app, and load it anew. That would eliminate any possible corruption in the documents in that folder. Your camera settings are kept on the server and will be fine, but you will need to re-login and re-authorize access to the photo section, location, Bluetooth, etc.

1 Like

I tried this on a third iPad and it still won’t save properly.

Events are not downloading for days. Spent a long time on the phone with WYZE. No solution! We are IT people and nothing we are doing wrong on our part! It’s WYZE. Their product does NOT perform as advertised! We are paying monthly for a joke at this point !

When I try to save videos this is all I see,


Yes. The same thing happens to me and I have an iPhone. This never used to happen. It started happening several months ago. Once in a great while the download will work as it originally did, but only one time out of multiple attempts on multiple event recordings. I created a similar post today. I’ve tried many of the fixes that others have found to work for them, but they don’t work for me. The only workaround I’ve found on my iPhone is to record my iPhone and then edit the recording to get to the event recording. It’s lots of extra work.

I am still having the same issue. Several videos will download and save and other times none of them will save. Wyze is not looking for a cause, not enough users are complaining

I didn’t have this problem until I recently did a bunch of updates. Now
I can’t download anything. I have an iPad. I’m guessing they changed the software or firmware or something so people couldn’t do this anymore?

I use iOS devices on iOS 17.4 iPhone and iPad with app iOS 2.50 and I downloaded six different video event in the last 20 minutes today.

I still have the same issue with my cam V 3 cameras only. My cam V2 cameras download videos fine and the new cam V4 download videos.
I tried saving videos on a new ipad, same issues.

1 Like

I’m STILL having this very same problem a year later. When you’re stuck paying yearly for services you don’t get is super frustrating!! Figure it out Wyze