Vacuum is Confused

When I first got the Wyze Vacuum, it mapped an vacuumed without issue. However, now when it goes under the Master bed, it seems to get confused and starts to build ghost rooms and loses its orientation of where it is. I ended up blocking off the Bed area which allowed the Vacuum to complete the bedroom. I am not up to speed on exactly how Lidar works yet, hence my question, could the metal curved Bars (U Shaped with the U hanging towards the floor) under the bed be causing the problem with reflections from the Lidar? I also have a piece of wood in the back of the bed which is open at top and bottom, could it be having issues with distance? the front sensor may see the wall, but the Lidar would see the wood piece. Here is my Vac Setup:

Device: Android 11 on Pixel 5
App: Beta 2.17.31
Vacuum FW: 1.6.97

Here is a picture of what under the bed looks like, the image is looking towards the headboard side as this is where it is getting confused. In addition, I did put a No Go Box there, but it still has issues.

1 Like

I’ve found that the vacuum begins drawing phantom rooms (distorted versions of actual rooms) when it momentarilywifi looses Wi-Fi connection or if it’s wheels are lifted off the ground.


Interesting. Well Wheels have not left the ground. WiFi is perfect on my house, but I do have a Mesh Network. The Vacuum seems to want to originally connect to my Living Room Deco which is at the other end of the house. I have a Mesh point in my MBR, which it will switch to. Wonder if the switching is causing the issue. I am set for Fast Roaming, and even turned of Beamforming. Wonder how I can test this.

Thanks for the feedback - gives me something to look at.

Did you get yours corrected? are you on a Mesh Network?

while running at some point when it is in between the router and the mesh point, put a tin foil cover over it ( the router) and see if it shows the same behavior ( as it does when the problem occurs) when it tries to switch to the mesh point. the tin foil should act as a faraday cage basically. see if you can get the behavior to repeat.

idea #2…you could also remove the mesh point so that it wont even TRY to switch and see if it maintains it activity.

1 Like

Unfortunately, the living room is the primary Deco. I will try the aluminum foil trick, but I shouldn’t cover the Lidar, correct?

I also turned off Mesh on the Vacuum. This is supposed to remain connected to the deco it is on, but not sure will see.

It will continue shortly.

Thanks for the suggestions. I will report back.

1 Like

yeah dont cover the lidar. the lidar helps the bot navigate itself through the environment


1 Like

I installed a better router and an extender which seemed to prevent it wandering off into the ether. Still happens when I have to rescue it when it becomes confused by a patterned rug which includes black stripes.

Cool – thanks. The Deco’s have been great, Just need to work out what the best configuration is for my setup I guess. Maybe I have too many Mesh Points for the size of my house. :slight_smile:

Just got done speaking with the individual from TPLink about some settings in the Deco. Figured I would share this with anyone else who has a Deco:

  1. My Vacuum ran fine after making this change: In the Device List, went to the settings area for the Vacuum and there is a switch to turn off “Mesh Technology”. he indicated that this will keep the device on the same Deco with no switching. I did this as one of my Deco’s is in the center of the house and is what the Vacuum is connected to. Once I made the change, I did not seem to have any issues. It remained on the Living Room Deco the whole time. Before setting this, the Vacuum was still drawing ghost rooms and was getting confused.

  2. Beamforming is to extend the range of the WiFi by manipulating the Mesh and focusing on devices. This can be on or off, he recommended on unless you notice any issues. Note that there is 2 type of Beamforming: Explicit and implicit. Explicit is really only good for AC and N WiFi. It is expected to work with devices that also have Beamforming. Implicit does not rely on the device, it attempts to extend the range of older devices, the router takes care of everything.

  3. Fast Roaming, turn it on as it will be the most efficient way to switch between devices.

They also stated that if you have devices which don’t roam, turning Mesh Technology off for those devices would not hurt. He did not say you have to, but did say it would not hurt. It would basically stay on the device it is connected to when you turned it off. However, I have a new Chromecast Google TV, turned Mesh off on it, but it still seemed to connect to other Deco’s. Not sure what was up with that or if I did something wrong. :slight_smile:

But in any event, this is a long way to say, the Vacuum did finally work as it did when I first hooked it up. The biggest difference was Beamforming was on when I did it the first time, which probably kept it connected longer. When I turned off Beamforming, I started seeing the ghosting issues, turning off Mesh Technology for the Vacuum seemed to have cleared that up. But I will test again tomorrow and see. It needs to be repeatable.

Thanks for the comments and feedback. It at least pushed me in the correct direction.


that is VERY good to know. as we are on the frontlines of trouble shooting im going to tag in some friends here so they are aware of this as I could see this being needed again sometime in the future. @Mavens I’m sure something along these lines would apply to other routers as well!

this is very good information for roaming technology in case Wyze comes out with a flying camera or a robotic dog (possibly sharks with lasers!) or something I don’t know about. thank you for posting back. glad you got it figured out!

1 Like

Interesting. I run four access points on a mesh with Synology. I have been experiencing the same issue. Also the same issue happens when it claims underneath a metal decorative corner shelf. It also happens nearly every time it has to go out for 3 or 4x to cover my house. I have an AP at both ends of the house, then one in the middle in the basement. I also have one outside in the middle of the house, but I doubt it picks that one up. The whole mesh thing might be an issue. I hope more of use monitor this and report. I have never had my Wyze vac complete the entire house without failing. I just reset the whole thing again for the 10x at least and did a quick map. I relocated it to a whole new part of the house. The first time I reset it in the new location in the Great Room at the far end of my house it was confused again. It always seems to be my Great Room where I have one of the APs that it ghosts and gets confused. Having it identify rooms is a complete waste of time and I merge and split. Unfortunately you can only split “horizontally” to outside walls. I have an open floor design with the stairs basically splitting the house in half. Today after the reset, it finally actually clean the Great Room without ghosting and as an individual room, I have never had it successfully clean an individual room. I actually had it clean a second room at the other end of the house and it worked too. Unfortunately, when it created the map it has my house at an angle then it tries to clean perpendicular, so it does not clean perpendicular or parallel to my house. It creates my house perfectly north and south, so to speak, 1 out of 10 times.

Any ideas would be appreciated. I am afraid to reset it again as it actually cleaned a couple of rooms.

1 Like

watch it and make sure the charging contacts arent connecting to anything as you said it was metal. people have reported that being the reason it stops sometimes ( although I havent had time to replicate) the metal itself might also be blocking signal.


That is what I experienced as well. Unless you have an implicit Beamforming option, your devices may not be taking advantage of it. Implicit allows for older devices including 2,4G. this is also known as Beamforming+. Explicit only really works with AC and N. I actually turned it off and my Alerts/notifications seem to be coming in more frequently now. If a person walks in front of my camera, Alexa Announces, it appears in my events tab of the app, and I get notified on my phone more consistently. In the past, I would be notified via Alexa and the events tab, but no notification on my phone.

Also, the Fast Roaming is a must, this is how it switches between devices quickly to minimize drops. I think this is what I was experiencing with the Vacuum when it tried to switch to another Deco.

If you can, I would try turning Mesh Technology off only for the Vacuum. but make sure it is connected to a device that can cover most of the house or the area’s where you currently have issues. Just as a test.

I will let yo know what happens in tomorrows test. my MBR has continual issues as indicated in the OP. So if it works tomorrow, I would say it is as close to fixed as I can get it. :slight_smile:

Interesting, did not even think if this. Good to know.

1 Like

No joy his morning. Set the vacuum off to do the hallway. it initially got confused in the beginning and then ended up trying to vacuum the MBR as the hall. I put the vacuum in the hall and restarted it, no lick either. I cancelled the cleaning and let it go back to the base. I then kicked it off again, it actually did the hall this time. but instead of returning to the base, it went into the guest room as it was the hall. When I told it to return to the base, it headed towards the wall and not the base. :slight_smile: I moved it to the hall way and then said go charge, it spun twice to figure out where it was, then took off and docked.

Guess this is why we test. :slight_smile: I will be cleaning the Lidar and sensors to see if that helps. I may even remap the house. Not sure if Remapping will do it.

@Bam / @jawarters / @HowardP

I did some more testing as you can see above. I have definitely confirmed that it is related to the WiFi signal. Would be great if the floor plan was actually stored in the Vacuum so that it could use it locally and not require WiFi while Vacuuming. I guess it is that way so that the app can display the path and where it has cleaned. In any event, here is how I determined this:

First thing I did was cleaned the Vacuum, Lidar, front sensors, edge sensors etc. and did a run. Did not work - still got consfused.

As I indicated I have a TPLink Mesh Network consisting of the Primary Node in my Media Closet at the primary end of the house. I have a second node in the Living Room, which is 1/2 way between the first node and the back of the house. I have the third node in my MBR.

I rebooted the Living Room Deco, which forced the Vacuum to connect to my Media Closet Deco. The signal was great as it is midway. I rebooted the MBR as well - wanted to ensure I was starting from a common point. The only Deco I did not reboot is the Primary one (Media Closet). Now that the Vacuum was on the Media Closet, I turned off the Mesh Technology for the Vacuum and sent it on its way, 1/2 down the hall the signal went from 3 bars to 1 (and was yellow indicating it is a weak signal). At that point the Vacuum started getting confused, spinning in circles and ultimately ended up in my MBR as if the hall magically got extended. I decided turned on the Mesh Technology to see if it would switch, to no avail. Stayed on the Primary Deco. I then stopped the process and decided to have it go to the charger. Again, it started off heading in the correct direction, but ultimately got lost again.

I then Rebooted the Main Deco (Media Closet), this forced the Vacuum to join the Living Room deco (Mesh Technology was on). I then turned off the Mesh Technology and left the Vacuum on the Living Room Deco, and it succeeded. Did not even hickup at all.

So in conclusion:

  • Yes it is related to a WiFi signal Issue
  • Turning off WiFi Mesh did work. But I did baseline everything again to start from a known state. If you device is not mobile, you can turn off Mesh Technology for that device. However, leaving it on will not hurt either.
  • Beamforming is not used and could cause an issue. Unless you have Beamforming+ which allows for older devices.
  • Fast Roaming should be on for devices on the move (with the exception of the Vacuum if you can get a decent signal from a central Mesh Node, Like me).

In any event, I finally got a clean run without the issues I have been having. I will see the next time it goes to clean the entire house as that will indicate if leaving Mesh Technology off fully works.

1 Like

Try cleaning the sensors underneath after every use. Get a strong router like an Asus.

I did clean it, and my Mesh is strong enough. I can get a signal 3 houses away. Maybe it is too strong. :slight_smile:

I did get the vacuum corrected by locking it to the center hub. I will know if it works as I have it set to vacuum every Saturday.

I also saw a post that someone was having issues but it was corrected when they let it remap the house after a the latest update. the theory is that the updates posed some issues with the mapping performed on the previous FW.

I have this problem in spades but very different conditions. First pass works perfectly every time. Then, use of the now saved map for a successive vacuuming results in phantom rooms and very poor navigation including going in circles and driving off the edge of a stair. Resetting the map results in a “new” perfect first pass. 9 out of 10 times if it uses a saved map, it ends up getting lost and cannot complete the cycle. I have an Eeros wifi and while it has mesh technology, I see no options to turn it off for either the entire system nor just the vacuum.

I’ve sent many logs and opened an issue with Wyze but no response to any of it.

1 Like