Vacuum is Confused

Like many others I have been having similar issues. Sent numerous logs and opened tickets, but it doesn’t seem like the issues will ever be corrected. In fact, after every update it seems to get worse and it has more problems. Like others, mine will work correctly most of the time if I reset the map, but if I try to use a saved map or schedule a cleaning it almost always gets lost and creates a phantom map. I do not have a mesh system. Mine usually seems to create a map when it gets stuck at a threshold, which it has very little trouble getting over when the map is reset. Does not make a lot of sense why it can cross thresholds at initial mapping/cleaning but has major issues when trying to cross them on a saved map.

I had the exact same issue. Vacuum got stuck on the middle bar under my bed and started mapping phantom rooms. I added a no-go zone a bit wider than the bar but not so big to prevent it from going under the bed. It’s been good ever since.

So after several weeks it appears my robot it finally working without redrawing skewed maps and it is making it over thresholds. For 4 consecutive days I have been able to run it without resetting the map. After going back and forth with tech support and sending numerous logs I was getting frustrated when I was told to do the same thing I was already instructed to do multiple times…factory reset, delete it and reconnect. For whatever reason this time it seems to work. Hopefully it will continue to without problems. I have not tried any scheduled cleanings yet but hoping they will work.

YZ1 continues to struggle with patterned area rugs, particularly those with black, dark brown or red stripes. It vacuums these areas multiple times, in circles until it manages to convince itself that its battery sensor is disconnected or dirty. Then it waits to be moved slightly forward or back until it regains traction. Has no trouble entering or exiting this rug at any other point. This is a serious, unresolved situation which prevents YZ1 from completing scheduled or manual cleanings. One hopes a future algorithm update will fix the issue. Disabling sensors is not a solution as I have a set of stairs that became the final resting place for a previous Roomba vacuum.

I was the OP on this Forum. Since reporting, I think I have finally figured out the Vacuum issues I was experiencing. I have since run 2 complete clean cycles without issue. Here are my findings which seemed to help:

  1. @jawaters and @Bam assumption on the WiFi is correct. I am using the TPLink P7 and get a signal all over the house without fail. However, the Mesh network is set for fast roaming and switches as you walk around the house with the phone or laptop. You can see the signal start going down and then it switches and the signal goes up again. On a phone or laptop, this does not appear to be an issue as it switches much faster. On the Vacuum, it was connected to my Media Closet which is at one end of the house, although I get a signal from that one alone it is very weak. So it appears the Vacuum cannot handle the switching in a timely fashion. I did notice the Vacuum reported no network, when I paused it or sent it back to the charger it would recover and then be fine. To correct this, I ended up ensuring it was on the middle AP and turned off Mesh for the Vacuum. Now there is enough signal for it to complete the cleaning around the house.

  2. The vacuum getting confused and drawing ghost rooms or pivoted rooms was another issues I had. when going down my hall way, it would suddenly start criss crossing in the hall way and spinning, it lost touch with distance, doors and room sizes. Total mess. What I figured out was that My hall carpet, which is a runner and does not go wall to wall, was causing an issue. It would tilt enough, and frequently, when it tried to follow the wall. I think this constant tilting caused the Lidar to get confused as to where it was and distance. I corrected this by rolling up the carpet before vacuuming. This has seemed to correct the confusion. I think my runner which is a high quality plush carpet, maybe just high enough which causes the tilt angle to be to great and the leveling wheels cannot accommodate.

Just wanted to pass this on.


I mentioned WIFI way back, can’t trust mesh as it does go up and down. Strong single point is better and mine covers my entire house 5300 square feet. The carpet not going to the edge is obvious be we cannot see it so we could not address this error.

What router do you have? I have the FiOS quantum Gateway for wired and the TPLink for Wireless. TPLink Connects the the Quantum Router. Never had an issue with this setup, except for the Vacuum.

I have an Asus RT-AC88U, I can receive it 150’ outside my house even though I have 6” walls with steel mesh and 1” mortar and stone on the outside with low E windows. For the rest of the 15 acres I have an Engenius access point on my chimney 45’ AGL.

Looks good. You have the one or did you setup the additional AP for whole home WiFi? I was looking at the ASUS site and they showed additional Access Points for whole home.

I don’t have any other access points inside, Just the router. I use the high mounted one outside for boondockers, (RV)guests. They can receive it almost anywhere on the property. Even in front of our shop building which is steel, twenty four high and blocking the house. It doesn’t come inside the house very good because it sits above the roof which is steel.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.