V3: Getting tired of seeing "Getting video data..." Anyone heard from support?

10 days in, still can’t use my V3. I have opened a support ticket, but no response (big surprise). Has anyone had a response from Wyze? This is getting ridiculous.

1 Like

I just replaced some of my V2s with V3s and have started to run into this issue. Eventually it will connect, like 2 or 3 minutes later. I am hoping a firmware update will correct this. For now, I am holding off replacing any more V2s.

Last night I did a “Sync Time” in Advanced settings. Now my V3 loads video fine!!! Try to ‘Sync time’ and see if it helps.

1 Like

Is this the hanging at 3/3 issue?

1 Like

Yes. I was stuck “Getting Video Data…” until today. Working fine this morning. All I did was “Sync Time” late last night.

The problem varies and not very consistent, hower it is consistent that sometimes it takes a long time to connect. I sync time many times and have not noticed any difference.

Remember, the V2 connected almost instantly. This morning I tried three of the V3. First V3 took 45 seconds, it was stuck on (1/3) and then bang, on to the video, never seeing the (2/3) or the (3/3) stages.

The second camera jump to (2/3) and after 30 seconds failed with a return code “0” . When I tried again, it seemed to connect under 10 seconds.

The third connected in under 5 seconds.

I’m having the same issues with my V3. Many times it rapidly flashes purple and doesn’t come out of it. when it does, I get hung on 3/3. ZERO response from support so far.
I can’t find what the rapid purple flashing means… Anybody know?

I was only having the issue on one of my 6 v3s and I have the status light turned off, so I haven’t seen the rapid purple light.

I am currently testing a test firmware on the one I was having trouble with and so far its connecting every time and quickly. If all goes well, hopefully they’ll push it out asap.


God I hope so. I have been having issues with no real help from support since Nov 20th when I received the cameras. Its always the same…Support opens the flow chart and does not deviate no matter how many times I state that I have tried all of those steps. I need next level support. But there is none. I am about to return all my cams if nothing comes of this. I have 4 v2 cams 4 v3 cams, 1 PTZ, 1 Outdoor cam. I have the doorbell and thermostat on preorder. I would hate to throw in the towel now

I hear ya. I have 5 v2’s with no problems, but this V3 is hopefully not the way things are going to start going, especially since I’ve ordered a vacuum, 2 thermostats, 2 doorbells and a sprinkler controller.

1 Like

Same here. Got them yesterday. One set up fine but still had issues. Showing 15k then dropping to 0k. Rebooted several times and now it seems fine.

The second one the set up seemed to go fine. Just as quick as the first. But now it just says getting video data and it never works.

I put in a ticket but who knows how long that will take.

@desmodog Try this, it works for me. When you are stuck at “Getting video data… 3/3”, go into advanced settings and do a ‘Sync’ for the time. Then reboot. I bet it will work fine for a few days.

Yep, I did that several times with no luck yesterday.

Then now in the last few minutes I did it again and again after restarting over and over and unplugging and reinstalling over and over its finally working.


Won’t be replacing my 4 other V2’s for awhile. That was about 30 minutes to get it working.


I have the the same problem with 1 of my 2 V3s. I set them side by side, one works and the other would be stuck at 3/3. WyzeCam V3 has serious quality control. How do we do an exchange? Thank you in advance.

And after maybe a couple of hours it quit working again. Tried the time sync and reboot and no luck. 0kbs but the camera light switches from blue to red when I open up the stream.

Weird. Please fix.

Anyone hear back from Wyze on their ticket for this issue? I got one canned list of questions 5 days ago which I answered and since then nada.

Why can’t we simply return items that don’t work and get replacements or refunds?

1 Like

I had the same experience. Then after about a week a new support person started helping me and asked me to flash the firmware with the lastest, which is the only version available.

Did that, and had the exact same problem, and told them about it. Not surprising. Haven’t heard from them since, and I’ve requested a new v3.

Defective hardware, and I have no way to return it.

What version of the firmware are you using? Please post so we can compare to others having a similar issue

In spite of my account information saying that they havn’t processed my order yet, today I received the 4 V3’s that I ordered on November 1.

I opened up one of them to test out. I upgraded the firmware, which is now It’s been running for 15 minutes now. The low light vision is fantastic. The alarm thing is cool too. If I can figure out how to use that (IFTTT?), it will be fun.

Anyway… before I replace 4 working V2’s with these new V3’s, is the above mentioned firmware revision known to be stable ?

FWIW, I installed a 32 Gb card in it and have it set to record on motion detect. My WiFi signal is showing as 3 bars.

More: I just added the new cam to my IFTTT devices, hoping that there would be a way to control the siren from IFTTT. I didnt see anything. Has anyone figured out how to control it either with IFTTT or Hubitat ?

I’m having the same problem and I’m using firmware I’ve tried syncing the time, rebooting, over and over again and still can’t get it to connect. However, I’m getting notifications from this cam and can see the videos. Very strange!