V3 Connectivity Issue's

"I have 2 issues with my new v3 cam. I received it on 11/21. setup was easy. But it will not stay connected. The longest I have had it stay connected is about 7 hours. It hangs. It stops recording events. When I go look at it on the app it fails on step 3 of 3. It just keeps retrying. The only way to get it working again is to power cycle it. My Wifi is very good. The V3 is inside of the house during this testing. The other issue is. I have a micro SD card installed. Even though I have the camera set to only record events to the SD card. In a period of 6 hours it used over 3 GB of SD card storage? I am not sure what it is recording???


If you go into playback, is it recording continuously? Can you pull the card and view in in a pc to see what’s on the card? If it’s footage or logs or what?

1 Like

When the Playback is viewed. It shows recording clips. It is not continuous. When I view the clips in playback I do not see any motion? (Clips are 45 seconds on average)
The motion events do show up under the events tab as normal & typically are cars etc.

1 Like

The buttons for continuous or events are set as gray off, white on .
If you want events only be sure that button is white not grey

1 Like

My V3 hung up like that last night. I got purple tinted preview thumbs that wouldn’t play. Rebooting via the power cord this AM restored normal functioning.


I am having the same issue. Most mine stays connected is around an hour. I tried a different power plug and tried without the memory card and still the same issue. Mine also did have a firmware update when I first set it up. When It works the night vision quality is out of this world. But in the 48 hours I have had it ive been only able to video the live stream once or twice. I hope this is just a firmware issue and not hardware

1 Like

I also did a firmware update after the initial install.

1 Like

Having same issue longest its stayed connected is 6 hours but mostly its only 2 hours.
Tried setting up on 3 different networks same issue. When it gets to 3 of 3 just keeps going.


This is very discouraging! I thought Wyze would have basic functionality dialed, I really wanted to upgrade all my v2s!

There is another topic that indicates that the WiFi is not only not as good as the v2 it was to replace, but that the v3 is significantly slower on network transfer rates!

I have the same problem on my Wyze Cam V3. The live stream stops after a few hours. It’s installed on the same spot where I had a V2 before and there were no problems. I hope this gets resolved soon.

Same issue here. I have 2 v3s and one of them is having connecting to video as well as recording to cloud/sd card issue consistently. The “fix” is to reboot the device but it will happen again after an hour or so. Support have been unresponsive.

I also have this issue with my V3. “Getting video data” hangs.

1 Like

I went though support to get it resolved and sent in a log file but don’t expect much to happen. I may have bought a 20.00 dollar paper weight.

I understand. Mine failed 3 times last night in a 15 minute period. I installed a new beta firmware level this morning that may do some good things. Hang in there Wyze will get it fixed.

Moderator Note: Personal information has been manually removed from this post. Such information often gets included inadvertently in an email signature block when replying by email. The forum software attempts to automatically remove email signatures but it is not always successful. When replying to the forum by email, it is best to remove the signature block yourself before sending.

I had/have the exact same issue. Purple previews and gets stuck hanging on 3/3

Where would I find this firmware?


I received two new WyzeCam v3’s on Thursday and was really excited to get them hooked up to replace one of my v2s and add to my setup, but I can get neither to connect to the app. Both will go through the connection process and says “Setup complete”, but they never actually connect to the app. Have tried resetting router, re-running setup for the Cam multiple times, but both display the same behavior. I literally cannot do anything with them because I can’t access them. I emailed into support Friday and still no word. Anyone experienced the same and any tips? Note this is 2.4ghz and I have 2 cam v2, 2 pan cams and a wyze lock so I know the network works.

Any tips would be helpful. I really want to get these setup!

Same problem here. Bought 3 V3 cameras. 2 work great but one has trouble connecting and maintaining a connection. I sent a log in last week but nothing back so far.


Any update if the beta made any difference? I may install it if it fixes the issue.

I could never find the beta for V3 and Wyze has stop responding to me. My neighbor has 4 V3s 3 work find 1 has same issue, the one with the issue got updated other 3 are running firmware they came with.