V3 Camera showing 'rain/bugs' in IR mode but nothing actually there

I have 2 Wyze V3 cameras I am testing in my lanai. The cameras work great in the daylight but I have found that I do not have enough ambient light to operate them in color mode at night. As noted these are being tested inside my lanai which is a metal cage with plastic screening. The lanai provides an enclosure for a swimming pool.

The issue I am having is that I am using IR mode at night but the video looks like it is either raining or that bugs are consistently flying by. It is not raining or there are not any bugs flying by.Here is my question:

Would this situation be caused by the IR being reflected off of the water in the pool? Or has anyone else had this issue? I have tried 2 different cameras but they both operate in the same manner.

Thanks in Advance.

Post a video so we can see what you are seeing. Very likely is dust or insects.


Hello @mncoughlin7 and welcome to the community!

I have increased your trust level so you can post photos, if you could post one we can let you know what you are seeing.


Views from last night- 2 different cameras

1 Like

I don’t even think we need the pictures. This is an incredibly common situation. For me I found that just turning off the IR LEDs on my V2s essentially eliminated the dozens of insect alerts I was getting each night, and there was enough ambient streetlight to get by.

This might work for you, although if the V3 isn’t pulling night color you may not have enough light for ambient IR either.

The other typical approaches are to rely only on person detection or to use separate supplemental lights (either regular or invisible IR).


Yea, the IR reflects off the bugs and makes them appear larger, and it attracts bugs.


Yep. Flying bugs.


Yea like others have said . When in night vision , the camera use the IR lights and it can detect bugs , dust , webs etc .

The best fix for this is to get cam plus , that way you can only be noticed of AI events like ; person , pet , vehicles , etc and you can toggle off all other motion which is what that is…

Best ,


Agree. All itty bitty little flying bugs. Because the cam has the IR emitters surrounding the lens, the bugs, in this case almost microscopic 'no see ‘ems’, are attracted to the lens and the IR light is reflecting off of them, fractions of an inch from cam face, directly back into the lens.

They don’t show during color vision because the IR emmiters are off and the IR filter is retracted. The color light source doesn’t come from the cam, it comes from the opposite side of the bugs and there is no IR to attract the bugs.

Even with CamPlus, I still get a very high rate of false positive AI tags for bugs, spiders, and webs when the IR NV is on.

Some users have found success with leaving the IR mode in Auto, but turning off the IR emitters and installing an IR floodlight away from the cam so that the IR source is not coming from the cam and reflecting back.

I am so jealous of your glass covered/indoor pool setup! It’s so beautiful! This is basically exactly what I want to do at my next house! Right now I have an outdoor pool, and it is insane how much stuff gets into it from neighbors’ trees, etc…your setup is so AWESOME! Still keep the sun, but can use it year round, no wind to freeze you out, fewer things blown into it, just awesome. I am so jealous, it’s so beautiful and perfect.

I don’t have much to add that hasn’t been said already…basically bugs swarming the IR…there are ways around this…have a separate IR light away from the camera somewhere, then they won’t swarm the lens, or a regular light somewhere and leave the camera on daylight mode instead of night vision.


Bugs. I bought a separate infrared light and it works great.


It’s a quantum flux reaction to sub atomic particles dispersed from the Big Bang. They’re everywhere and will be for another million years.

I know this topic is over a year old but I want to chime in anyway. I have the same problem with my two Wyze Cam v3 cameras that are outside. It is not bugs! It’s winter here in Wisconsin and I also see this in sub-zero (F) temperatures. In fact, it seems worse in low temperatures. The cameras are currently looking at a snow-covered yard, though this was happening before the snow fell also. I have to turn off “Night Vision IR Lights” or I get motion events every 5 minutes. I do not have Cam Plus. Very disappointing.

That’s the nature of IR, every brand camera I own does it. I purchased a stand alone IR emitter and placed it a ways away from the camera. $35. and it illuminates an area multiple times as bright and big as the cameras without any annoying reflections.

1 Like

If there are particulates in the air, they will be illuminated by a light source that is close and inline with the camera lense. If you have the option to use a different light source for the camera that is away from the camera location then the particulates, dust, snow, bugs wont be lit up.


Forgot to mention that you can try Cam Plus Lite on the V3. And have 12 second videos to the cloud and what would help you is with the person detection it also allows. Set to person detection only and then hopefully that would rule out the buggy notifications.

1 Like

I would actually say its the nature of having a light source right near and inline with the camera lens. If you had a visible light enabled right on the camera, and there was particulate in the air, then the particulate would be illuminated the same as if you were using IR lights onboard the caera to illuminate the area.


Thanks for the comments, Omgitstony and Snoop1. I do have Cam Plus Lite on the two V3 cameras, and it does allow me select person detection. However, it does not allow me to select person detection only. It will just send me to a subscription purchase page in the app.

So I’m turning off Night Vision. While there’s snow on the ground and moonlight, Color Night Vision should give me something for now. I’ll consider a separate IR illuminator. It’s not a priority though, as I mainly use the cameras for wildlife in the backyard.