V3 camera is buggy, Gets hung on 3 step to view live stream, etc

I found another thread about this same issue and someone suggested configuring a rule to automatically restart the camera, since that seems to restore functionality, at least temporarily. Unfortunately for me, my V3 that’s having the issue sometimes can’t go 5 mins without encountering the issue.

Normally, I wouldn’t want to tag Wyze staff but it seems there are several threads about this same issue. @WyzeGwendolyn can you look at getting a stickied thread for this? These threads all seem related or have comments about the “getting stuck at 3/3” issue:

1 Like

Wyze HQ is like 10 minute drive from my house. Im about to throw this v3 at the front door step with a big sign that says, “SEND BACK WHEN FIXED”


Same problem with two V3s. Although they have been working better the last day. Now to the next problem, Cam Plus stopped working completely on the V3s. There are no events at all when enabled. If I disable it, both cameras record the 12sec events without a problem. Paying for Cam Plus and I can’t use it.

1 Like

Also stuck over here with a V3 that doesnt connect. No live view. It is recording as i have events showing. But when i try to watch the event it was not working. I was getting Error code 06. Now i get Error code 07. So disappointed in this thing. And Wyze is not being clear or helpful clearly to anybody on this.


I am also getting the same error code 07:unknown, when viewing events on my new V3. Specifically, this occurs when attempting to view a recorded event.

EDIT: Right after posting this, I thought about it a little more. Since this was occurring only when attempting to view a recorded event, I began to think about the SD card. I tried reformatting the card a second time through the app, and it seems to have fixed the issue, as all seems fine now. Not sure if this will work for anybody else with the code 07 error, but might be worth a try.

1 Like

I have many of the same buggy issues mentioned before on the new v3 but I am also having WiFi connectivity issues. I received 3 v3 cams and I decided to replace one of my v2 cams I have mounted outside that could take advantage of the color night vision. Wi-Fi in that location is not full strength but it does get a solid 2 bars and the v2 cam had no issue with it even streaming at HD. I pre setup the v3 cam inside and took it outside to replace the v2. When I powered on it would connect but video would freeze. I confirmed it was connecting to the closest router. So I decided to reset the cam and reinitialize it…it would not even find the wifi even though my phone said wifi strength was fine. I moved the v3 cam 10ft closer and then it connected fine. Considering my v2 cam had an outdoor skin on it I would have thought the v3 cam would get better wifi reception. Disappointed so far…hope firmware updates correct this soon!!!

1 Like

fix for v3 issues is coming soon, Firmware i’m testing has been perfect on the v3 for 4 days.


I sure hope so. I have lost faith in Wyze at this point. The night time color blows away all other cameras, Including Nest. But if the fricking Camera hangs every hour I might as well smash it with a hammer.

1 Like

What are they waiting for? Even if it has bugs, it can’t be worse than this!

1 Like

Wyze Support is sending me a replacement V3 camera. Hopefully it doesn’t have the same issue, will report back when I get it.

1 Like

3 out of 4 of my V3 won’t work. They are stuck at 3/3 and then timeout. I’ve replaced the micro USB cord, I’ve reset the cameras, I’ve rebooted the cameras, I’ve On/Off cycled it and put a ticket in with no response. It truly saddens me to see this from a company that seems to just keep producing new products almost every week. I wouldn’t trust their new sense system with my security if their cameras can’t even work. I’m truly disappointed. It would be something if they at least acknowledged the issue with an email and tell us they are working on it. If I missed a post like that, I ask someone to point me to that.

Are you signed up for beta? They just released new firmware that is supposed to address the 3/3 bug. It’s worked for me although now I have one that goes totally offline every so often with error code 90. Have to reboot a few times before it comes back online. I have a V2 next to it for reference that never disconnects so I know it’s not a wifi issue.

1 Like

I have been using the beta with the new firmware and it has been running almost perfectly. Seems like they nailed down the problem with this update.


Signed up for Beta? We are running beta firmware as it is.

Switching to beta seemed to work. All cameras are loading pretty quickly. I was on beta about 6 months ago however it gave me trouble with the wyze lock geofencing with my partner on the normal wyze app and myself on the beta. It wouldn’t auto unlock for him. However I have since stopped using the wyze lock so this shouldn’t be a problem. Thank you for your help! :blush::blush::blush::blush:

Great, glad to hear. I haven’t had the 3/3 issue since upgrading.

1 Like

Wyze Support RMA’d me a replacement V3 camera, which I’ve now been running for over 48 hours without any of the issues the old one had. It’s never gotten stuck at “Getting video data 3/3”, and it’s running the same firmware version as the old one:

I’ve been running beta (.228) firmware on three cameras . One has been up for 3 days ( outside) with no issues . The second one I put in my basement 24 hours ago and is still fine. The third one I set up about 4 hours ago and is also running fine.

I got a notification of a new firmware upgrade 2 days for my V3 camera. One of the fixes is the hang on step 3. Been 2.5 days… the firmware has fixed the problem. So far…

If you get the notification for the firmware update, do it. I think it also makes starting the live stream faster over all too.

Just hit the same problem with the latest firmware. I am investigating property damage, but a) the video event BEFORE shows Error (code 07): Unknown and b) the video event that I suspect contains the damage started at least a few seconds AFTER the movement and missed the problem, even though the two events are exactly 10 minutes apart (well above the 5 min cool down period). One can see it here - this van was exiting from the driveway, but the whole exiting was missed. https://photos.app.goo.gl/1TCxHfLw8qDrBkSe9