V3 black DOA

My biggest wyze disappointment to date. Wanted a cool V3 Black edition on black friday. Ordered it and received in a timely fashion. When It arrived, I plugged it in, and nothing. The only signs of life were the clicking of the IR filter. No lights, no sounds. Setup button does nothing. Tried with and without an SD card, tried all the resets hard and soft. Easy return process, but now I’m sad I don’t have the Special Edition lol.

1 Like

Dang. If you still had it I was going to recommend seeing if “Flashing the firmware” fixed it for you. I know of a very similar situation where that worked.

At least the return was easy.


I tried it. The camera was dead and inop.

Are they at least replacing it with another V3 Black?

They were out of stock, so I just got a refund. I’m a bit annoyed at the company now. Not even because of this, I’ve had a great experience with cameras I’ve purchase even years ago still working great and only 1/15 DOA.

But there moves with the v3 pro, and Pan V3 not being supported by camplus lite is very annoying. So I basically place a v3 pro, or my v3 pan in the same area of a v2 pan or V3 so I can get my instant video of an event and then use the higher res camera for a more detailed view if needed. Especially with security, being able to tap a notification and view a quick clip right away, seconds matter, and the timeline function is buggy and doesn’t work great when I click playback.

I purchased 3 of the black v3 cams less than 2 months ago. 2 of the 3 are already dead. They were being used indoors. I purchased several white v3 cams over 1 year ago for use outside and they are still fine. Two of my v2 cams died, but at least they lasted more than 1 year. Maybe a bad batch of black cams were rushed out because high demand.

Wyze is sending two replacement cameras - so that’s a gold star for them. My two cameras failed at the same time under the same circumstances. I unplugged them to relocate them, and when I plugged them back in, they would not come on. This was so unlikely that it left me thinking that I must be doing something wrong. I tried repeatedly using different known-to-be good components (including the one camera still working), but the two dead cameras were definitely dead. Very odd. Must be a vulnerability in the power circuitry that can’t handle the interruption. I’ll have to stress test the 3rd camera before the warranty expires.