V2 Sensors should allow delays before turning off (in Alexa)

The current “new and improved” V2 motion sensors work with Alexa to turn on/off other devices like lights either when there is motion or not. They don’t allow for time delays when turning off a light like the V1 sensors. Alexa allows me to choose “turn off after no motion for 1 minute” however, anything over “0 minutes” causes the lights to stay on. Would like it to work when I choose “turn off after 1 minute” but that currently leaves the light on indefinitely. When I choose “0 minutes” it turns off anytime someone stops moving. It’s very frustrating and I solely bought these for this functionality because the V1 sensors have always worked perfectly for me and I thought these would be even better.

Both Wyze App rules and Alexa rules already allow this for Both V1 and V2 motion sensors.

Here it is in Alexa for the V2 Motion sensor in my Office:

Just add a routine, and under “When this Happens” Select Smart home, then the V2 motion sensor, then select “Not Detected” and set the length of time.

Then for the action, set it to turn off your light.

You can do the same thing in the Wyze App natively if both your sensor and Bulb are Wyze devices.

There are several other ways of doing this too…in Alexa’s actions for the routine, you can set a time delay for X amount of time before the next action occurs.

If you’re not getting the option for "Not Detected for “X amount of time” then I’d contact support (probably Alexa Support, but you could call Wyze Support too, and maybe they’ll call Alexa Support with you…some have done that before).

It doesn’t work on anything more than 0 minutes is the issue and I keep being told by Wyze that they don’t support this yet. I just got an email right before yours saying I need to request it in the Wyze Wishlist. This is extremely frustrating.

[Mod Edit]

Moderator Note: Personal information has been manually removed from this post. Such information often gets included inadvertently in an email signature block when replying by email. The forum software attempts to automatically remove email signatures but it is not always successful. When replying to the forum by email, it is best to remove the signature block yourself before sending.


Thanks for sharing, that is interesting it shows up but doesn’t work. Usually of something isn’t compatible then Alexa won’t show it as an option. For example, my Wyze cams have a person Detection trigger, but not my Eufy cams. Alexa won’t even show it. I wonder why they don’t do the same thing for motion sensors if they haven’t been enabled for it yet.

More importantly, how on earth hasn’t this been fixed yet. I’ll vote for this option now.

Don’t forget to vote for your own wishlist. You created it but didn’t vote for it yet.

If you are using Alexa routines there is an option to set a wait period after you turn on the light. Not quite the same as after motion stops but you can turn the light off after whatever period of time you want.

1 Like

I’m sorry, I thought this was an email from Wyze support! Yes the issue is that they work with Alexa but they say that they don’t and that it needs to be in this wishlist. So even though they support it, they offer no technical assistance if it is not working properly. My V1 sensors always supported Alexa routines and worked almost flawlessly.

1 Like

That’s just a hack that will cause the lights to turn off and on at random, and I’d rather have it function as it is supposed to. Please make sure to vote for this to urge them to correct it.