Motion Sensor V2 with Alexa Routine

I have a Motion Sensor V2 in our living room. My hope was to have it turn on our Wiz smart bulbs when motion is detected, and turn them off 5 minutes after the motion clears. I am using Amazon Alexa to run a routine to do this. Turning on works just fine, but turning the lights off is not.

I have noticed a few things. First, the lights will turn off just fine if I “play” the routine manually. Also, the lights will turn off without issue if I have the routine set to trigger when motion is not detected for 0 minutes (turns off when sensor clears). As soon as I set it to something more than 0 minutes, it stops working. I have also noticed that the time displayed in the Wyze app for the Motion Sensor V2 events is about 2 or 3 minutes ahead of the actual time (compared to my phone’s time).

Any suggestions?

Would you please post a screenshot showing your routine? It’s hard to help without knowing exactly what your routine is configured to do. I have a couple of routines that turn on lights with motion, similar to yours.

I will work on posting a screenshot. In the meantime, have you had any luck with routines to turn off the lights?

Mine work correctly without issues.

Here are a few screenshots. Notice in one of them, the bottom shows motion in progress, while the main portion says clear. In another, the motion sensor just detected motion and the time is off by 2 minutes from my phone’s time. Apparently, I can only add one picture at a time. See following posts.

This is what works for me (forgoing to move the off command below the wait):

Missed this part. Let me test.

I suppose I should ask if you have had any luck turning off lights when the motion sensor clears after a set amount of time, not when motion is detected.

Heh, you just noticed. Thank you!

Just tested and this worked: (Just a thought, try it with just one light. )

You might want to read this–seems to be a similar issue:

And another:

And another:

Thanks for the posts! It seems that the issue was caused by an update. They are working now!


Bryan Buck

Glad to have been able to help. Just a note, you should remove your phone number from the last post.

1 Like

Hm. Thank you for the posts, but none of them seem to offer a solution that I noticed. The first one suggests there’s a default off time, but I’m not sure where that is. I will look more later when I get back home.

BryanBuck, how did you get yours working? I seem to be having the same problem but can’t find a solution.

After the most recent update to the Alexa app it started working again:)
I didn’t make any changes.

Ah. Maybe I should check my Alexa app. I was focusing on the Wyze app.

Seems as though my app is up to date. I contacted Wyze Support. Hopefully they will come up with a solution.