Unbricking Wyze Contact Sensor - pcb reset pin

I don’t think it’s a problem with a capacitor… The MAC is being corrupted which probably means the sensors are erasing/re-writing a block of flash memory that contains it. It shouldn’t. If that’s the case, the only real fix is for them to rewrite how the firmware works.

That certainly was not a cure… A 'cop out’ is a more apt description

btw I tried the press 3 times idea mentioned above as well, it doesnt work.


I was thinking about all my Wyze Contact Sensor “Colleagues” today when my battery ran low on my TILE Pro.
I removed the protective cover off the back of a new Energizer CR2032, and it tested over 3V, so I felt confident (I had another new one just in case)!
I removed the battery cover on the Tile, and saw the generic CR2032 in there, and thought, do I really want to do this?
My stomach was churning as I popped out the old CR2032 battery, and thought to myself “will this device ever work again”? Well, it was a non-event, all is well !

This really helped, thank you!

RottBite2020 I think its only human that some customers express their frustration with a product that doesnt survive a low battery event. The product was not marketed by Wyze as a use once / disposible. Tens of thousands of contact sensors were sold. People invested time, modified their houses, wiring to integrate the sensors into their homes and garages. With a firmware update Wyze can make its bridge talk to these ‘bricked sensors’ just like Home Assistant can.


FYI, I have attempted to unbrick a contact sensor by grounding the reset pin for up to 15 seconds, with the sensor powered up, I was unsuccessful. I have a sensor that I’ve removed from the housing. Used my Panavise to gently hold the battery in place, while using a fine test lead to ground the reset pin. No flashing, no nothing. Tried removing the battery and replacing, nada. Etc.

Just gotta wait for the new hardware, and get Wyze to own up to this problem with V1 sensors and cut us a break on the new ones.

may I ask everyone here to click on this wishlist topic i just created and vote for it, to increase its visibility to Wyze engineers, maybe it will get us a little closer to getting that firmware update , thanks

I agree! I wasn’t being sarcastic although looking at it now I can see where it may look that way… ugh!

Is the original “from the factory” MAC address still in there somewhere? Is it getting overwritten during power-up to 000000000000?
Even if you had the CC1310 launchpad to “fix” it, where would you get the correct MAC address to program in? Is it printed on the back of the board (that faces the plastic cover)?

The sensor’s address is printed on the back of the sensor housing. It’s an 8-digit hex number which matches what you’d normally see if you went into Settings > Device Info for the sensor. Preface-pad the number with zeros.


If it had been a snake it would have bit me!
I had to wipe off where I wrote “BAD” with a sharpie over that area (like I did on all of them).
In the app (if you are lucky enough to have a working one), the MAC address starts with:
I would assume those 4 characters preface the 8 character suffix on the back of the housing?
Thanks again!

1 Like

2CAA- are the cameras. The sensor addresses are labeled “Sensor MAC Address” in the app. All of mine start with 77 and are 8 digits.

1 Like

So prepend zeros onto the sensor MAC address found in the app or on the back of the houseing like:

I had posted a link to the TI development kit earlier up , the user manual there has a screen shot showing the expected MAC address format.

but before you even reach that stage, you would need to buy the right launch pad model and configure everything. then I imagine you need a way of wiring it to the sensor, just holding the wiring to the pins will be difficult as they are tiny, you will need to build a custom rig. and later when you miss a battery change you will have to go through this trouble all over again.

this is not a practical solution. something straightforward for us users is a firmware fix from wyze to work like home assistant

My guess.
xiaomi assembled board, then insert battery.
put it on a test jig to flash mac address.
then install onto the housing and weld plastic standoff.

you need a jig with pin/nails to the board to program using jtag2usb cable. I made on before toto program tv remote.

if you have not delete device from app, you may be able find the original mac address.

afaik, the sensors use a shorter address scheme that are only 8 digits. What is shown on the app and case are exactly it. They are not the same as the longer 12-digit WiFi/Ethernet MACs.

I made a jig for this, but it turns out I didn’t have anything that can speak cJTag, so that was kinda pointless… lol


actually it does serve a purpose, as it shows how much work & fiddling around would need to go to fix just one sensor, till the next low battery happened. thats why i am asking for Wyze to fix this from their firmware


i can confirm that in my home assistant the mac of many of my sensors change to 00 00 00 00 00 00 00

1 Like