Two-factor (2FA) for TinyCam

Trying to set up a Wyze v2 camera on TinyCam pro - I get the camera added OK, but get a popup asking me to “Enter 2FA passcode”. I have gone into my app on iOS and tried the SMS and Authenticator options (configuring both), however I don’t get SMS messages with the codes when I try it that way, and the Authenticator app generates a 6 digit code that I enter, however the TinyCam app continues to prompt for it (so not working).

Any tips - am I doing something wrong? I tried even turning of MFA (2FA) on the account, however it makes no difference apparently - even with it off on my account, TinyCam keeps prompting for it.

Please help!

1 Like

Wyze should really make you a Maven. You do a great job of referencing other relevant threads and such. I have learned a lot from your responses when something is relevant.

Hi, and thank you for the reply - I had seen the posts you reference, but they do not seem to address my issue, unless I am missing something? I set up Wyze to use the Microsoft Authenticator, but it is not accepting the 6 digit code that it generates as valid in tiny cam.

I did not use the linked account method (where one has 2fa setup, and the other does not and the cameras are shared from one to the other), as I am not sure the difference there between that and just disabling 2fa in the first place (which still prompts me for the 2nd factor regardless).

Was there something in one of those that you think I should try specifically, that I have not yet? (I list what I tried in my original post)

EDIT: I have now tried sharing the camera from a 2FA account to a non-2fa account, and while the sharing works, TinyCam still prompts for 2fa (pointed at the new ACCT); I also tried Google Authenticator (-vs Microsoft), with no difference (acts like wrong one). I do have a question - I have 5 previous cameras in TinyCam (not Wyze brand) - should the channel be set to 1, or 6, or something else? (Have tried both, plus 0)

Here’s a screenshot of what I see:

Thank you!

Sorry I can’t help; I was simply providing links where people had discussed similar issues with TinyCam. Personally I avoid multifactor security for something as simple as this. (It can cause more trouble than it’s worth.)

Wait a sec. Re-reading your post… Do you event WANT to use 2FA? Or was your hand being forced by various prompts? Because neither Wyze nor TinyCam actually requires 2FA at all. linked to a very basic TinyCam setup guide at

On your channel question, the Wyze cameras get assigned channels in order and TinyCam will tell you what it sees once it has your Wyze credentials and you click Camera Status (as in your screenshot). Pretty sure the default is 1 for the first camera on the account.

Did you ever have this working without the 2FA?

You are correct - I do not need/want 2fa for this, but TinyCam keeps asking for it no matter if I have it “turned off” in Wyze, I am using an Nvidia Shield to host tinycam. Maybe this q should go in a TinyCam Pro forum? I will review the link below, but had followed some instructions on setting this up initially, they just didn’t cover the 2fa bit as that is newer than the instructions were.

Thanks for the continued replies - really hoping to get this working!

Is this “just working” for others, or do I have some sort of edge case here?

Yes it should just work and I think you’ve gone down a bad road. Some suggestions:

  1. Turn off ALL account based 2FA settings on your Wyze account.

  2. Test to make sure the regular Wyze app launches without any second factor required.

  3. Completely uninstall TinyCam. (Better yet, install it on a completely separate device.)

  4. Follow the instructions in that linked document to configure TinyCam.

You should probably uninstall any authenticator apps you installed, but I don’t want to see you stranded. If you leave 2FA on in account settings you might lock yourself out of the Wyze app too.

I’ve had the same problem. Tried TC on a android emulator, BlueStacks… Discovered that the TC Channel Number has to correspond to the WYZE ordinal number - Your first Wyze camera has to be Channel 1 in TC. Probably the same for DVR/NDRV but have not tried. Thanks to those commenters that led lead to this discovery.

OK - so I uninstalled TC (TinyCam), then only added the Wyze cam (Channel 1, with 2FA turned off in the Wyze account) - TC still prompting for a 2FA code, so I removed the camera from TC (did not uninstall TC again though, but now the Wyze was the only camera in there), then turned on 2FA in the Wyze account using the Authenticator method. Added Wyze to TC (Channel 1) - still prompting for 2FA (which is expected), but not accepting my input of the 6 digit code, so does not work. :frowning:

I will try pursuing this through TC forums (have to go find one, as I am not sure if/where that is supported), and check there. Logging into the Wyze web page honors the 2FA or not (i.e. when I have it enabled, asks for the 2FA code & lets me in, when disabled, does not ask for it), That makes me think it’s TC’s issue, but not sure.

Here is how I fixed the 2FA pup-up issue for my TinyCam with Wyze cam v3.

  1. Use “Scan network” option to add the Wyze cam to TinyCam. the “Add IP camera …” option will have issue with 2FA at least for me. it would be easier to identify your Wyze cam in the network scan result if you know the IP address assigned your Wyze cam.
  2. After adding the Wyze cam to TC, go the camera settings for the Wyze cam and change to Camera brand to Wyze Labs, change Camera model to Wyzze Cam, Update Username and Password according to your Wyze account, change the Chanel number in Advanced settings if needed.
  3. Select live view for your Wyze cam. You will get the 2FA pop-up message and you should also receive SMS for 2FA code shortly, enter the 2FA code included in the txt message.
  4. Done.

2FA through Authenticator doesn’t work for me.


I fixed it for my Wyze Cam additions: For some undetermined reason, Tinycam Pro lost my camera configurations yesterday. I began adding my 4 cameras from scratch, After successfully adding the first camera on channel 1, I ran into the same 2FA message (I don’t have Wyze 2FA enabled). I found that if I “Copied” the camera on channel 1 to install the remaining 3, it worked without the 2FA error. Hope it works for you. BTW, I am running TinyCam on an NVIDIA Shield TV.

Thank you, @jfourman - qq for you - so you added the first Wyze cam on Channel 1, and then when you copied them, did you re-start on Channel & increment to channel 4, or how did you do that? Are all your cams Wyze then? I have 5 Lorex cams also, and connect to them via RTSP, so they are all on channel 1 - not sure if that will help or not?

As a workaround, I did get this working - I installed the RTSP firmware onto the Wyze cam & then just had TinyCam connect to it that way. Is there any drawback to that approach? I can still access it via the Wyze app if I need to, and so far it seems to be working ok, but not sure if that’s a good approach or not?

Thank you for the help!

All of my cams are Wyze so the userid and password was copied without issue. I added each additional camera and incremented the channel. I knew by IP which camera was associated with each channel increment. Since all 4 cameras were Wyze, I could change the camera model (Pan, Cam 2, Outdoor) without a problem. I think the fact that all 4 of my cameras were Wyze, associated with the same link/account may have been an advantage.

To add… I chose not to attempt RTSP as I am not in the mood to mess with potential unsupported issues.

1 Like

The drawback is that Wyze’s RTSP firmware is only occasionally updated and minimally supported. You’re in luck that they just unexpectedly released a new one so it’s probably about on par with the mainline firmware feature set (if you picked up the new/beta one). If it works for you I wouldn’t worry much about it. :slight_smile:

On the Wyze copies, the channel refers to the camera’s ID on the Wyze account. It doesn’t refer to a particular stream or camera port and it has no affect on other non-Wyze configurations.

Also, if you’re using the RTSP stream in TinyCam then you would NOT configure the Wyze account or channel number in TinyCam. You’d treat them as generic IP cameras and enter the URL / credentials for the RTSP stream only. As you know TinyCam also has the option to use Wyze protocol and credentials. With the Wyze RTSP firmware I believe you have your choice of approaches.

I have the same problem just started with TC, cannot find a method to get around the false message 2FA. This needs to be escalated to development.

1 Like

Whose development? Wyze has nothing to do with TinyCam. Not sure why you folks are hitting this snag and yet it’s never happened to me. (But I’ve never enabled 2FA.)

Yes sorry, I have since an Email to the developer of TC, hopefully, I will hear something shortly.

Yes, it worked for me on the V2 and V3 Wyze cams. I am using a Samsung TV, with Firestick, to run the TC app.

My setup: NVIDIA Shield (tube) running to a TV in my office running TinyCam Pro and 4 Wyzecams.

Four v2 cams running perfection for 1 year on TC.

Today was the day I upgraded all four of them to the V3s

This was a PITA. But…nevertheless they are working. Took roughly 2-3 hours with remounting to second story and all the software jacking. Seems like you have to “play with it” until you find a way to get it to work.

If you try to just add the cams and delete the old versions on TC, it does not work. At least for me, it did NOT. grr. Kept getting the each new cam v3 asking for 2fa passcode, MOTHER FFER

Here’s how I did it.

I had to uninstall/reinstall TC, Read the cams. then get one of the cam’s IP address and go:

  1. Add all the cams to the WYZE app first
    2.Grab the IP of one of the cams (from the Wyze app Settings/device info)
    3.Go into TC and scan network
    4.Match the IP of the one you grabbed from the TC scan (uncheck all others)
    5.Add that as cam #1 (rename it later)
    6.Copy the rest of the cam adds based of cam 1, one at a time.

All in all, this was an advanced setup, but nevertheless working for me now. Love the V3s, btw, seem to be snappier and more fish eye view.

Would be nice if Wyze had their own APP for a PC or a TV.

That worked - THANKS!
Extra hack
Click on MANAGE CAMERAS, click on the one you just got working, run CAMERA STATUS and it will populate with all the Waze devices you have (yes, including the Scale) and it will tell you what channel they are on.
The next one just scroll down to ADVANCE SETTINGS and select which camera you want to watch. Since I have 6 cameras, but only 4 I want going all the time (wireless cam would drain too fast) this helps.
No need to redo the 2FA for each device.