Thermostat offline repeatedly

As I was also. I had been on 1.2.1 since this time last year with no offline or other issues at all. I updated and have yet to experience any adverse affects. I updated to get the remote sensor bug fix.

I still don’t get any insights though. :disappointed:

If it is stable I would leave it alone. I thought the new FW version made a difference but it has not. Without knowing exactly why, I would just leave yours as is.


The latest release did not help… :slightly_frowning_face:

Not much new to report here either. I tried prioritizing the thermostats on my router but made no difference. So I removed both the priority and the fixed IP addresses (went back to just like I had it when they ran for 2 years without issues) and my upstairs is still on line after a week but my downstairs disconnected after a few days. So I’m sure it’s just a matter of time before the upstairs will disconnect again too. The downstairs still shows connected when I look through my router and I can ping it too. And no insights on either one of mine.

I’ve wasted so many brain cells trying to figure this out. It’s obvious Wyze doesn’t know how to fix the problem. This is a rental for me and with this going offline repeatedly since I bought the thermostat I’m moving on. They got my $65.00. I have five cameras, the scales and the vacuum cleaner- they’re all “ok” I guess but I am DONE with this. Good luck y’all.

Oddly enough, when I have my thermostat off for the summer… it never drops offline. It’s only during the winter when it’s actually in use that it happens. Maybe that will give wyze engineers an insight into why it happens.


Ya know the thing that burns me is, they’ve got the resources to design a new toy car with a camera on it, but they can’t fix this thermostat…

I have been trying to figure out what the difference is with my setup and others. I am not experiencing the Offline issue, knock on wood.

Maybe I am one of the lucky ones

1 Like

My downstairs is off all winter and it is dropping at roughly the same rate as the upstairs which is on all winter. So at least for me, no difference if it’s on or off. I still have a hunch the issue is on the Wyze server side simply because I had no issues till maybe 5 months ago. I made no changes to my network or devices on my network when the problem began. Now it only stays connected between days and weeks.

1 Like

I’ve been knocking on wood since the issue was reported. 3 different routers since installing over a year and a half ago and I have never had an offline event either.

Just spit balling a wild thought that flew thru my brain while typing this… @speadie can probably comment on if this is a possibility or not. Is it possible that the offline issue is HVAC unit specific? Is there a possibility that there is some type of power fluctuation or other blip from the HVAC unit board on units that have specific features that might be causing the WiFi chip in the thermostat to wig out? Might those of us that don’t experience it have HVAC units that either don’t have those features or the type of HVAC board that those experiencing it have? Just thinking with my thumbs.

I like your train of thought.

I use a trane HVAC system. Relatively new. I also have mine set to let the HVAC control my fan with no specific intervals. Plus fan is always on. IndicTong this, in the event that this triggers a thought

1 Like

Well for the record… We have an ICP Tempstar, Dual Fuel,3 ton Package Unit, we put in Fall of 2006.
We went for a long time without any issues but after the last beta update I started having problems again.

1 Like

Amana forced air gas with Amana AC as well. I have 2 zones so both my upstairs and downstairs thermostats run through a Honeywell zone controller. No changes to any of this since I installed them in January of 2021. I ran for 2 years without connection issues which seemed to start if I recall in January 2023 while running 1.2.1.
I installed that version when it was released back in May of 2022. I never upgraded till 1.2.7 was released in May of 2023 but it has had no impact.


I’m curious… the connection seems so random sometimes…
Can Wyze tweak the software behind the scenes, experimenting with solutions without the user knowing or having to do an update?
I just wonder, because I don’t know if I’m doing something or if it’s coming from Wyze.

So wyze sent me a new thermostat and after installing it it stayed online for 3 weeks. It just recently went offline twice in the past couple days. This is a bizarre issue and I’m close to giving up on the t-stat because it seems like Wyze has no answer.

1 Like

Something that I’m trying right now… in my Netgear router, under Security… Access Control… I’ve set Access Rules to “Block all new devices from connecting”.
So I’ve had good luck since I did this about a week ago but who knows…
I thought I had this licked 6 months ago… I’d still like to know if they are messing with it behind the scenes.
One other thing… In the router, under Administration, mine has a selection for “Logs”. If you can, you might look for odd things going on in the log.
The thermostat has some kind of weakness because it’s the ONLY thing on my network that looses connection.

they don’t have an answer. Their answer is to shut it off and turn it back on or ship you another thermostate

Just an update as to where I am at: I’ve had my upstairs thermostat running for 3 weeks and downstairs for 2 weeks with no disconnections which has been the longest run I have had since January when my disconnection issues started. As previously reported, my last network changes were that I went back to my original set up by disabling the fixed IP address and network priority which I had enabled to see if it would help. I still had both thermostats disconnect after that change so that wasn’t the problem. So you may ask what did I do? The answer is simple…nothing. The only thing I can conclude is a change was made on the Wyze side. Hopefully my issue is over!

1 Like

Let me preface my remarks here with how much I love WYZE products. Highly functional, very affordable and very stable - except for the thermostat. Thankfully, turning off the QoS “feature” on my router seems to have cured the issue at my cabin (though a similar feature is enabled on my router at home - different brand - with no issues).

I’m very disappointed that a duly-authorized Wyze employee hasn’t shown up in this thread to say something like:

“We are aware of the issue with our thermostat randomly disconnecting and are working diligently to correct it. But frankly, we’re stumped. We’ll keep working night and day until we find and fix the issue.”

If they would do that, I think we all would say “Thank you” and be patient while they work on it. But when their response is silence (unless you complain enough, at which point they just send you a new thermostat with the same issue), it’s very frustrated.

In short, I wish they would “own” this problem and not leave us all having to work it out ourselves.

1 Like

Dittos, to Rambling Texan.
I plan to replace my thermostat at my summer cottage with another brand.
The 2 thermostats at my primary are fine but I so not update them.