Thermostat always offline

Just installed the Wyze Thermostat. Installation and setup appears to work however I am not able to control the thermostat. The app does see the thermostat and it says its connected to the network (has ip address, good signal, etc) but any attempt to control it always ends up with the app saying its offline. The thermostat itself just display “Wyze” and I can’t use it either, nothing happens when turning or pushing in the knob. Kind of stuck without a heating right now. Hate to pull if off the wall and put back the old thermostat but not sure I have much choice.

1 Like

Same here. Guess its got something to do with the server offline issue. Will attempt my2nd thermostat upstairs tomorrow.

I noticed that when I first did the setup that it downloaded a firmware update. So I deleted the device and re-added it and now everything is working as expected. I guess the firmware update foobarred something so I just needed to re-add the device to the app.

1 Like

I tried this and it didn’t work for me. It’s powered and showing Wyze on the screen. No able to pair it through the app or adjust it manually. It was working and I got through the install and initial testing before the firmware update took it out. I am also hoping that I won’t have to put the old one back on. If that has to happen might install the unopened Nest E that I was hoping to return.

Update: Pushing and holding knob allows you to reset. I was only able to pair to it after a reset. Cycling power did not fix it

1 Like

I have 3 thermostats I installed 2 days ago. Within hours, all 3 disconnected from WiFi. I reset all 3 and that resolved the connection, but only for a few minutes. Within the hour, all 3 were disconnected again. When trying to reset them a 2nd time, I had several issues connecting to my wifi and had to retry numerous times. I finally got them connected only to have them disconnect 5 min later. I contacted Wyze via chat and they could not resolve it - transferred to higher level support via email. If I have any luck, I will update here.

Initial behavior on the one I installed was similar. I would be working it through the app and it would go offline. I would restart the app And it would appear to work for a bit then go offline. The only other bit is that I allowed it to factory reset when I pushed and held the button for 10-15 seconds. It has worked fine since I accepted the factory reset. And all of this happened after the firmware update that the t-stat called for after the initial power up.

Thanks for sharing your experience. I reset all 3 thermostats twice already after installing. They all go offline just minutes after setup. Oddly, they all connected a couple days later on their own and stayed connected… until today, when one dropped back offline. I am troubleshooting with Wyze now… more to come if they help me find a fix.

Update: wyze support has tried to support me via email only (no other option). They respond about weekly. I have no resolution and all 3 thermostats are still offline. Sometimes they connect, but not for long. I am using Google Nest Wifi, a very new/current network system. I’m at a loss, my thermostats are not connect, essentially dumb.

Trying a few different Wyze rules with my thermostat and after one of them the thermostat says it is off line. On the app it shows the cloud with a line through it for being off line. Now the interesting part is the app looks like it is controlling the thermostat just fine. But it isn’t responding. Alexa says it is off line too. Did a factory reset and now it is running correctly again.
Update: 1/30/21 There appears to be multiple reasons why this can occur. One fix was to go to the router’s DHCP function and do a Release and Renew for all devices to clear the DHCP table. This has fixed several users who couldn’t get past the factory reset or initial connectivity but had good wifi connections. Thermostat not connecting to cloud, now won't setup after reset - #3 by vtester
Hope this helps some of you.


My case is: The thermostat shows offline icon on the app. When I access the device, it briefly show that it is offline but connects and functions fine. Going back to the home screen still show the offline icon but no longer showing that it is offline when accessing it. Did run few tests to see if it is controlling the thermostat and it is. The concern may be that because sometimes it does require manually accessing the thermostat from the app to reestablish the connection, the automation may not be working correctly.

Resolution: I took advice from vtester and tried to get DHCP renewed but did it by cycling the 2.4ghz antenna.

Steps: Close Wyze app. Turn off 2.4ghz antenna in your router. Turn it back on. Check Wyze app.

1 Like

Same! Once reset on the thermostat itself, I could pair. Thanks!

jk_texas, do you have an update on your 3 thermostats? I only have 1 and keep running into the same issue. Here is what I’ve attempted…

  1. Reset the thermostat 2 different times (resolves the offline issue for a day or so)
  2. Removed the thermostat from my Wyze app and re-added it
  3. Rebooted my home Wifi router numerous times
  4. Running the latest firmware on the thermostat and Wyze app

Did Wyze support ever get back to you on a resolution?

Is the thermostat actually offline when it says it is in the app? I ask because I have a remote camera installed that often says it is offline, but whenever I connect to it from the internet, it works fine. I have just come to the conclusion that the offline/online status in the app is not working properly for some wireless networks.

I find that I can access it and use it as normal. However, updates will not happen. Voice control will not happen. To other devices, it appears off. That has been my experience.


Yes in that I can control the temp and settings. Voice control, much like chillthird, isn’t working through Alexa as it says the “device is offline”. When the thermostat is showing as connected on the Wyze app, then Alexa can connect to it fine.

It just seems odd that many users seem to have their thermostats not staying online for a consistent amount of time. In fact, the only real known resolution is to simply factory reset the thing.

This has been happening weekly for me. The app shows the no cloud icon on the thermostat and is not controllable by alexa or the app. It is idiotic that Wyze has not implemented an automatic network reset feature for the thermostat within their firmware.

There is no way to resolve the device disconnecting from the cloud on the unit itself other than doing the factory reset. I have found that running up into the attic and power cycling the furnace, which also power cycles the thermostat, will bring it back for a few days but that is not viable if I’m away from the house. Wyze needs to add some better automatic network handling to this thing or I’m going to have to throw it away and just get an ecobee.

I have run into this a couple of times, and according to Wyze support, this is because of network traffic congestion on the channel that your wireless router uses. Each time I was able to solve it by changing the 2.4GHz band that my wireless router uses to a different channel. Wyze support will be able to help you decide which channel is the least congested.

I have a mesh network that does not allow for control of the channel. Last I checked though the channels it had chosen were not congested using WiFi analyzer. The thermostat is about 15 feet away from one of the nodes and in direct line of sight.

I changed the 2.4 channel I was on for a general cleanup and management purposes of other items. Once I did that, my thermostat jumped to offline again. Why… Oh why doesn’t Wyze have an open to reboot the thermostat without having to reset the thing.

I know I should add it to the wish list, but the wish list items aren’t even being addressed. Such as always on display. I am 100% into Wyze products, but lately I have been shaking my head with lack of actions/updates on their end.

Just power cycle the furnace by flipping its breaker off and then back on and the thermostat will also power cycle.