Thermostat offline repeatedly

My Wyze Thermostat keeps going offline and never comes back to manage remotely. I have 6 Wyze devices and this is the only one that does it. It’s the closest to the router with the strongest signal as well. Latest code on it and lasts about a week when I travel to the property and hard reset it. In my router, I can see the Wyze stat connected with 5 bars, but app says offline still.

Is there a way remotely to get these working again? Anyone have a tip or trick?




Can you post the App Version you are using and the Firmware version of the T-Stat?

Also, How do you get it to connect again? you can try the Restart from within the App or Removing it from the wall and wait for a few minutes, then put it back on and see if it syncs up again (I know this is not remotely, but we need to get you to a stable state).

The other option is to go through setup process to reset the WiFi connection. I think there is a way of doing that from the T-Stat.

Please see attached. Unfortunately, I am remote right now. Last time this happened, I had to travel 4 hours to visit the house and delete it from the app, then add it, while also hard resetting it.

I’ve tried resetting my remote router several times now and the thermostat does not come back. I can see it reconnects and has full signal strength in wifi router.

This is a remote rental that I require reliability for. My other Wyze thermostat is much further and haven’t had one issue yet with connectivity.


Sorry, here’s app version.

Here’s the pic from the wireless router. It’s the strongest connectivity of 6 devices connected. Haven’t had one device offline from any other Wyze device.

Makes no sense to me.

So a little research on the issue. Wyze has released a Beta Update to the T-Stat which reports the following:

So, you could Join the Beta Group and then you will be able to select the T-Stat for Beta FW releases. Then you could update to this. I am on this version and not experiencing any issues.

If you want to join the Beta Group go here:

Then you should have the following in your App. Under Account, About, you will see a Beta Program Link. That is where you can select Beta Firmware to test. Not 100% sure if you need to have the Beta App to do this.


The dreaded cloud on the Home screen.

Thanks. I will try this now. I head there tomorrow and can hopefully update to beta code.

Appreciate your help.

1 Like


Signed up for beta and updated app. Still no go. I’m talking with support now and hoping to get a new one sent. I did notice during setup it had a few errors even though there were no wires where it said there were.



1 Like

No problem. Hope it works out for you.

Ok on the app,

You need to update the T-Stat with the Beta FW. That is found by going to this location:

  • Start your App
  • go to the Account Menu
  • Select About
  • Tap on Beta Program
  • Click edit in the top right
  • Scroll down to the T-Stat and select it for Beta
  • Select Save
  • Back out to the main screen

Then see if you can connect to the T-Stat, sometimes it wills till connect. Go to the Settings, device Info and do the FW Update.

1 Like

Ok. I can try remotely, but not connected. I will be there tomorrow and can try as well.


I’m also getting offline and am with Starlink. I did the beta update for the application and it was able to connect to the thermostat right after. So then I got the thermostat to update to fw 1.2.3

But it went offline again soon afterwards

I’ve updated to beta on the stat and app. It eventually came back without reset and has been solid this far.

1 Like

That is great news. Glad to hear it is working for you

I’m 130 miles from the duck cabin in north Sacramento valley. Got a buddy to do two power on/off breaker box switches because after the first time it went offline from the router. After the second it’s back online. Hopefully it’ll stay up!

1 Like

It went offline so I rebooted the Starlink Wi-Fi and it came back

I kept trying that in the beginning and it wouldn’t work, but I think I know the trick now if I ever need it again. Push the Reboot wifi button and then immediately push reboot starlink button.

However, so far this beta code has been rock solid.

Thanks but that’s not working either :frowning_face:

Mine just went offline. So much for beta code. They sent me a new stat, so I’ll install that and see if it was just a bad stat and report back.

1 Like