Thermostat offline repeatedly

I think James11 hit the nail on the head with at least some of what is going on here in that the Wyze app showing the thermostat being off line doesn’t necessarily mean it’s a connection issue between the device and the wifi router. Why not everyone is having the issue and why I didn’t have an issue for a year and a half until 4 months ago with no network or firmware changes on my end is still a mystery. I plan to do a little more checking but I am not hopeful the issue will be solved by anything I can do besides power cycling the offending thermostat when it happens 1-3 weeks seems typical).

For sanity sake it’s nice to see someone what confirms how I reported mine acting (connected to network but reporting offline through app). I wish I could suggest a new ‘try this’, but I’ve tried everything and it still just will not stay online.

@HiTech If nothing else has changed on your end and the problem came from no where then it ‘has’ to be an issue with Wyze servers (I use ‘has’ somewhat loosely). Where I initially pointed to the firmware having a leak I am now wondering if it’s inability to heal it’s connection to the Wyze servers or an issue at the Wyze server’s not accepting the connection. I’ve read several times that they are keeping the server farm low foot print to keep device cost down. I’m doubting this is the issue really, but I’m running out of ideas. I do think that the TS bases whether it is online as not by whether it is on the internet, but whether it can contact Wyze. It may be that if it looses contact with their servers for some predetermined amount of time it just quits trying.

I was finally able to get to my remote house where the offending TS is at and it was functioning perfectly at the unit and was not hot. It also reported on it’s display that WIFI was disconnected. I was able to connect to the internet on my iPhone, laptop and Roku. Speed was 200+ MB with about 83ms ping times. I really tried tinkering with it but since you’re only able to either remove power or reset to defaults the testing was pretty low key. As expected pulling power (I pulled it off the wall) did allow it to reconnect to WIFI and it began working as expected. Within 2 hours it was offline again. All the while I was there watching movies over the Roku. So I decided to try reset it and start from scratch; that kept it online for the next 48 hours. I thought I had fixed it honestly and drove home the next day. Checked in on it once I got home and the darn thing is offline again. Total online time was about 52 hours. Crazy. I did not get a chance to connect it to a different access point unfortunately.

I just stumbled onto a way to get it back online remotely. I blocked the thermostat’s MAC address from the internet at my router then removed the block and it almost immediately reconnected. Now this may not really jive with the fact that a router reboot does not work. But maybe if the thermostat is having to authenticate with Wyze servers the block forces it to reset that authentication (as though it is actually talking to the servers but stuck on some authentication function?). Not really clear why a reboot of the router wouldn’t have the same affect. But I do know that I can plug in a MAC block scheduler for an hour out of each day to reset it. More testing to be done to ensure I’m on the right track…

For those that want to test during a thermostat outage. It is connecting to IP on port 8883. That IP belongs to an AWS farm that Wyze uses.


He, hey,hey. Wyze finally did an update earlier this week that"makes fixes thermostat reboot when Internet goes offline". That’s what we’ve been waiting for. Only took a year.

if it’s the firmware update to version 1.2.7 that you are referring to it doesn’t work. I’ve had that version for a while as a beta tester and mine still goes offline.

and how do you do that?

I also have 1.2.7. Is there one newer?

It depends on the router. Some have the ability, some do not. Do you know your router model? Or maybe take a picture of the label under it (not the WIFI name or password of course).

James11, it sure seems that something changed on the Wyze server side for at least my t-stats about 4 months ago since I had no issues before and made no changes. Just checked my t-stats and now both are off-line but are showing connected on my router. I can ping both t-stats and also ping the Wyze server IP you provided successfully with no data loss and less than 100ms response time. Power cycling restored the connection on both within 10 seconds.

One other issue I have had that goes back before I had connection issues is occasional very slow response time for changes made to the t-stats from the app. It’s so slow sometimes that the app display will revert to the setting or state before the change is made. If I let it sit long enough (15-30 seconds sometimes), it will eventually make the change to the t-stat and then update the app to what I changed it to. Even though I had this issue before the connection issue, maybe there is some relationship to your point regarding some ongoing connection interval that passes a threshold of taking too long and it just times out and quits trying.

Your MAC address trick sounds like it could be a promising way to get around this, keep us posted!

T-Mobile KVD21

Hey, its a good day, only 7 of 8 thermostats are offline today. Haven’t seen you in a long time, Living Room thermosat! how’ve ya been? Its kind of fun pretending my thermostats are Martian rovers covered in dust, and I’m just hoping beyond hope to hear a faint ping as the sun finally emerges …

I found the manual for that T-Mobile unit and it just doesn’t have the ability to filter IP or MAC, Which is odd for any WIFI router. Here is the manual

You could get a new WIFI router and plug it into this. Mabey go wit a WYZE router since most it seems do not have issues with the thermostat staying connected to that router.

1 Like

Well it’s been an uneventful week. Since getting it back online on 5/9 it’s been connected since. And that’s with no other changes; I never put the MAC block schedule in place. Fingers continually crossed that there’s no more issues. Maybe that auto reboot the latest firmware has some salt to it.


No issues here either since 5/9 and I rebooted both mine. With that said,I’ve had them go a couple weeks so only time will tell.


I have firmware version 1.2.7 but I’m not familiar with the auto reboot, was that part of 1.2.7?

What did you do to reboot?

It was a software fixed put out for the thermostat about 2 weeksago. There was a prompt on the thermostat app asking for the upgrade. So far so good.

Turned off then on the circuit breaker at my fuse box for the a c unit.

Ok, that’s what I thought. I’ve had to do that twice in the past 3 days.