Thermostat offline repeatedly

Just an FYI. Thermostat would disconnect once a day, very frustrating. I had installed it in a home I would be moving into a month later. I had Wyze stuff at both my apartment and newly purchased house at the same time and on the same app. After I moved into the house, all Wyze items are now on the same internet Wi-Fi. Guess what, no more disconnects. Food for thought.
Chris

Yep. Had zero problems with ANY WYZE products at my house. Had no problems with anything at my cabin until I added a WYZE thermostat. Everything else at the cabin worked fine, but the thermostat dropped offline constantly. That is until I turned of wireless quality of service in my cabin router (forgot the name of the setting). No problems since then. So, the problem would seem to be dependent on how a given wireless router is configured. Except that numerous comments have been made here that the WYZE thermostat is still responds to a PING when the WYZE app says it is offline. So the thermostat is still connected to the wireless network.

My take on all of this is that the WYZE thermostat is not persistent enough in trying to reconnect to the WYZE servers in the cloud when there is an interruption of some sort. I don’t think it is a problem with my cabin router, since no other device from any manufacturer – including EVERY OTHER DEVICE FROM WYZE– has any trouble connecting to anything.

So while changing settings in my router “solved” the issue, I think the changed merely removed something that caused temporary interruptions to the connection between the WYZE thermostat and the WYZE servers in the cloud. And the real problem is that the WYZE thermostat doesn’t try hard enough to restore its connection after a momentary disturbance.

Worth exactly what anyone paid for my thoughts.

2 Likes

Well I’m still looking for that magic Router setting.:slightly_smiling_face:

Mine was fine for months but has gone offline randomly quite a bit in the last month or two.

I’ve started submitting a Log File now every time it goes offline. Unfortunately they don’t give you any way to know what’s in the file. They give you a Log File Number and tell you to contact Support… But that was a dead end. They said the File goes directly to Engineering and to just flip the breaker and do a factory reset. :neutral_face:

I think I’ll just keep sending Log Files and hope for the best.

1 Like

Here I was hoping everyone’s connection problems were a thing the past as I’ve been running since late May with no issues after 4 months of constant disconnections with both of mine. As previously mentioned, I made no changes and the problem went away so the only conclusion I can come to is Wyze made some change on their end.

2 Likes

I would keep contacting support with your log number. It took 2 weeks and contacting support 3x’s , but an engineer did get back to me. He sent me a long ‘to-do’ list that was rather complicated. I was going to start working on that list, but the problem went away after all Wyze items were put on the same Wi-Fi.

1 Like

The following hasn’t been released to public/production firmware yet, but I thought some of you experiencing this might be interested in knowing that there’s a new beta firmware released today for the Thermostat that appears to be directed to help resolve this offline issue for those of you experiencing it:

If any of you decide to load and test this beta firmware, please comment in that thread if it seems to help give you better stability.

2 Likes

Thanks for the heads up! I’ve been having a lot of connectivity issues lately with this thermostat. I’ve sent the about 3 Log Files in the last week… So we’ll put this to test!
Thanks again!

2 Likes

You’re welcome. :slight_smile: Let us know if it helps!

2 Likes

Good to hear. But after having a firmware update brick one of my WYZE thermostats last year, I’ll wait a good while before I update any of my thermostats to new versions. I’ll be watching closely but will let others be the Guinea pigs.

3 Likes

I remember you having issues, I just installed this version and have not experienced any issues as of yet.

Note: I actually did the install while away from my house, took a leap of faith. :slight_smile:

2 Likes

I installed it yesterday… no problem.
Still connected this morning, so that’s a good sign!
If I don’t chime in, that means everything is good on my end. :crossed_fingers:

2 Likes

I recently purchased the WYZE T-stat, installed it on 8/2/2023, device offline mid day on 8/3, read this whole thread last night, signed up for the beta thing (current version 1.2.8.a2), back online last night, and now it’s off again. Wish I would have found this thread before I purchased because I would’ve gone a different route. Wyze camera works great which is why I went with Wyze T-stat to begin with.

Don’t give up too quick…
(You know the trick of flipping your breaker…)

I ask that you Submit a Log File.

T-Stat… Settings… Wyze Support… Submit Log

Thanks

Yes I read that trick but I need it when I’m away from home and that is when it goes offline. I can’t flip the breaker if I’m not there. Submitting one now.

1 Like

I built a relay that’s operated by a Wyze plug to remotely cycle power to mine.

Are you just cycling the “C” Wire, or the whole unit?

Update

I appreciate that they’re making an effort… but I’m Offline again this morning even with the new firmware.

It’s been happening in the middle of the night pretty frequently lately.

I sent a Log File…

Just the C wire. That power cycles the thermostat.

Funny thing. I’ve never had a Wyze plug drop offline. NEVER. After I built and wired in my relay, the first time I actually needed to use it, the Wyze plug controlling it was offline. It was as if the all-knowing Wyze Cloud knew what I was trying to do and prevented it.

Thankfully, changing the prioritization setting in my router has made it unnecessary to use my magic fix. But I left it wired in until we see a permanent fix for this issue.

1 Like

Hey, it came back online… And I didn’t do anything!

That’s different!

3 Likes

This is puzzling as I have not had any issues since we discussed this a while back, I am also on the latest Beta FW.

  • I have a Trane HVAC system and not using the C-Wire Adapter. What is you setup?
  • What Router setup are you using?

Asking the questions above as I am willing to do some testing and comparisons if needed.

Glad it came back on its own though.