Thermostat, I need help pronto

Hello! First post here. I’m now 6 hours, well, 360 minutes into a 30 minute install. I’m losing my mind.

Fast summary:

Manufactured home, or call it a double wide or trailer if that’s what floats your boat. New Bryant AC unit outback. First, the sob doesn’t have a control board. But I know for a fact the wiring is good.

Inside… Ok, I’ll just post pics. I’m so frustrated, tired, hungry at this point that I’m near in the mood to shoot the thermostat. Sorry for my pissinesss but I need assistance.

Here’s old setup 20210101_203413|690x326

Here’s new

There’s a humidistat above, 2 wire, red white. I can’t get a pic of how it’s connected but I think white goes to red or something

B4 I forget, b4 starting this 3 hour tour to the Bermuda triangle, there was an unused yellow wire. In the ac unit there was an unused yellow wire (same one I’m certain) and the install idiots used a blue wire to connect yellow to yellow. I fixed that.

Thermostat has power, thermostat has/had internet. I can see a temperature reading in the app, but device itself only ever days Wyze. And I have no ac. I’m in SWFL and it was 85 today. I NEED ac. Asap.

Thanks for any help, I’m not proof reading this so hopefully it makes sense. Just so frustrated right now that I’m having to listen to Slayer to calm down

Need a picture of the furnace or ac or both if there might be a wiring issue.
Have you tried removing and re-adding the wyze? Push the button and hold and it should ask you if you want to reset it.


Here’s what I too earlier. Wyze app is telling me the yellow wire isn’t connected

Question: any idea how to check it’s continuity with a multi tester from 50 feet apart?

The cluster F of a wiring job the ac company did is making me wonder if they spliced something somewhere as a short cut…

And by all means on my post, I’m not blaming Wyze. I think my HVAC contractor might have been color blind or flat out stupid

It was the crap wiring shortcut done by the ac company. Yellow wasn’t connected, red became disconnected as they apparently don’t know how to use wire nuts.

Everything works perfect now! Thanks for your help!!!

I messaged yellow&speadie, hopefully they went through. Can’t post anymore for 10 hours so I’ll see if this edit works

1 Like

I ran a wire from outside, hooked to the yellow wire, . Inside I stripped a spot and connected the inside yellow to the breach. 0 zero zilch continuity.

So unless I lost my last marble, the yellow wire is broke or not connected somewhere between point a and point b.

If any of this makes sense and you see a flaw in what I’m doing, please say so. I won’t be offended if you call me an idiot for missing something obvious :laughing:

I’m not a hvac tech but from the original pic, you don’t have a common wire. If that is the case you need to add the wyze converter puck they supplied with the new thermostat at the hvac unit.

Also I wouldn’t replace that yellow wire just cus the color makes sense. Best thing is to put old thermostat back and make sure everything works as normal. Then start the installation fresh without replacing yellow wire. Your old thermostat looks like mine with all same color wire in same connection label but I had the common wire so I didn’t need the supplied puck. Good luck.

I’m about to test blues continuity same as I tested yellow.

There’s 2 outcomes to this. Either I figure it out, or I pass out. I’ve got a 4.5L of Jameson that says it’s the latter. Yes, you read that right, 4.5L


Blue wire identical test: beeeeeeeeeeeeeeep

The yellow wire is broke. (Insert every curse word before the word Golf was added to the dictionary.)

Time to find the break. But first, Jameson…


For those of you having any issues, please check the wiring done by the “professionals”

My situation was caused by Pinky (from pinky and the brain) and Stevie Wonder having a child that became an HVAC tech.

At least so far, that’s the case. Too tired to see if Wyze is showing on the stat. But I’m almost out of beer so I’ll have to get up soon.

I’ll continue this saga later

Well, I used to have power going to the stat. Now I gots nothing. Patience and energy wearing thin. To make life funnier, some assclown detonated what sounded like a flash bomb as I was connecting wires (no, I didn’t kill the breaker, it’s only 24 volts)

You popped the fuse. usually an automotive blade style fuse, I see it in this image, looks like a 3 amp one.

1 Like

100% correct on that call. Lowest amp of one I had is a 10, I put that in, turned system on, still nothing. I’m at my wits end and have to reluctantly call it a night. Not looking forward to waking up tomorrow knowing I’ll have this to face

30 minute install now at 840 minutes thanks to custom cooling…

Common should have continuity to case ground.
That yellow wire in your hand says something about high pressure switch on it, is it going to one side of the contactor coil that fires the A/C compressor?
Also, your transformer is only 40VA, it’ll blow before your 10 amp fuse does.

It does say that.

What time zone are you in? I’m eastern and will be back on this tomorrow morning or whenever I get my bearings straight. I greatly appreciate your help tonight,v wish I could keep trying but my eyes are shutoff f

1 Like


I’ll be online randomly throughout the day, If you reply to my post instead of a generic reply to the thread, I’ll be more likely to see your post sooner, as it will ping me.

1 Like

As I mentioned in my post, you should put everything back to original to see if everything works. I’m thinking your making it harder than it is. Did you use the provided puck to get the common wire that your missing? I wouldn’t just randomly hook wires you think is logical, cus you will damage your hvac which will cost you more money.

Here is my original thermostat hookup before installing wyze.

Here is wiring of wyze in my basement for testing. I know i can wire it cleaner lol. It only took me 30 min to setup. 20201226_154131|281x500

Gene 77
"Wyze has me locked out from replying because I’m a noob.

The yellow wire wasn’t connected under the house. I fixed that, put everything back, blew a fuse (my carelessness), fixed that then still had no power inside. Had power outside, isolated issue to red wire, went back under and found red had somehow become loose. Reconnected, and waalaaa, fully functioning Wyze thermostat and AC!!!

Thank you for taking time to help with this. I tried to message speadie but I don’t know if it sent."

Glad you got it working…

Now check out my post about how app and thermostat is to function.

Gene, I am laughing so hard at your posts that I read them out loud in what I imagined your voice would be. I am so mean but it was the best ever! Our 30 minute install took maybe two days, don’t even know at this point since we’re still fudging around with it. I am so glad you got it working.

I hope the Jameson’s helped. It couldn’t hurt right? Rock on Gene!

1 Like