Spotlight issue

Hello, I have a v3 installed with a spotlight and had it working. I had to make an adjustment of the camera later and the spotlight stopped working. I have tried unplugging and reconnecting all the cables several times, and even reinstalling with spotlight on and off. Everytime the camera powers up, the spotlight blinks three times, so I know it works. But when I go back into accessories >spotlight it gives me the error “no spotlight installed”. Any idea what to do?

1 Like

restart the camera in the app( leaving the spotlight plugged in) force close the app.

once everything is restarted go into the v3 with the light and make sure it is connecting ok. see if the spotlight button shows up near the night vision button. if it does, you should be set, if not, go into accessories like you would to adjust settings for the light and advise what it shows you.

1 Like

I have the same issue. Nothing seems to work.

Its currently working, but none of these things you described was working at the time. I had already tried 30 mins of trial an error and nothing was working. For whatever reason as soon as i swapped this camera with another and separate spotlight, i brought the non working one downstairs, and it magically started working. I have no clue why.

I’ve got the same issue but… Mine has never worked. Came in today and it won’t do anything. The usb connection to the spotlight is very loose, is that common? The other (weatherproof) connections seem fine and the camera still works. Opened a case with support, we’ll see what happens.

I can’t get mine to work either.
When first connected, the light comes on, flickering and changing brightness. After a few minutes goes dark.

I have reset camera a couple times along with restarting app. Have also unplugged and reinstalled spotlight.

Spotlight does not show in the accessories

Good luck with that!

1 Like

Does wyze staff not even monitor these forums?

there are a couple of Wyze staff that pop in from time to time, but for the most part the is a user based community. the Mods and Mavens are Volunteers brought in by the Wyze community manager Gwendolyn to help out when we can as all of us are Wyze nerds and tech geeks ourselves and usually can help out our fellow users.

@rsdoowsemaj you are correct in your diagnosis, more than likely the loose connections are your problem. there shouldnt be much IF ANY play at all in the connections. let us know what support says.

@Taxi when you plug your light in, after a few seconds do you get a small symbol that shows up to the left of the night vision controls? it looks like a little pill shape with lines protruding from it, thats the manual control for the spotlight. I dont remember if you have to do anything in the accessories first for that to show up. have you ever gotten the pop up saying you have the spotlight installed when you ever the live view for that particular camera?

I don’t see any signs of the light being connected in the app.
I do know it has power because the light comes on initially although it flickerds and changes intensity.

I’ll let you all know what support says!

So, this was user error. I typically do not force a usb connection into anything. You must force that thing in these spotlights for the water tight seal. Don’t let the resistance fool you.

Support didn’t tell me this, I just figured to try forcing it in there as a last ditch effort… If it’s broke it’s broke, right. I asked support to close the ticket.

Anyways, hope this helps folks out!

My issue is different.

Light comes on, flickers & cycles between different brightness levels. Then goes off after a minute or two. At no time does it show in the app.
Both my app and V3 camera are updated.


My issue is that when I plug the spotlight in it comes on and stays on yet my camera will not connect and says that there is no SD card installed (which there is). I’ve checked and rechecked the connections, swapped out the spotlight for another (I bought 5) and it still does the same thing. If I unplug the spotlight, my camera connects fine and recognizes the SD card without issue.

So, I took a V3 in the house with the spotlight and connected it to a V3 (with a short USB cord) and it works no problem. Recognizes the spotlight etc…

All my cameras are on cables that are min. 10 feet each. Is there a voltage drop issue when I plug the light in? I dunno. Extremely frustrated.

Possible Solution Found: I have two wireless routers. Both are dual band (2 and 5). If my app is not connected to the same 2G that the camera is on, I cannot see the light button in the app. I don’t know if this is a possibility but it seems that a small configuration on the routers to ensure the information is being passed between them would fix this issue.

I have a similar issue. First spotlight I installed it seemed to work fine. Then I noticed a day later it would not turn on and if I tried turning it off and on from the app, nothing happened.

If I rebooted the camera with the app, then the spotlight disappeared from the app. if I unplugged the camera (and spotlight) then it would work again for a while before it stopped working again.

I tried a second spotlight with the exact same thing happening.

I think there is either a QA issue with the Spotlight Hardware or Wyze did not adequately test the spotlight firmware before releasing it. I opened a ticket and submitted a log, Time will tell if they fix this or the spotlight was just a waste of money.

Thank you



I think my issue is voltage drop over the cable I am using. I took an extension cord and ran it direct to the camera and used the included Wyze USB power supply and it worked fine.

Yep, that’s what it was in my case also. Had about a 12 foot usb extension, Set it up without the extension and works fine. Even tried a 2,1 power supply and wouldn’t work. Looks like I will have to run an extension cord also…

Interesting. I am using a Wyze Power strip and a usb extension cable myself. if it goes out again I will try changing that configuration.

Wyze maybe able to fix this with a firmware update though.

I tried a 45 watt power supply this morning and it did not help either.