Spotlight issue

I received a 20’ and 16’ USB to USB Micro cables today. I connected a spare cam (with the spotlight) the 20’ using the Wyze power adapter and it worked fine. Next I am going to piggy back the 20’ and the 16’ and see if it works but I had to order an adapter. Should know Friday.

I was very happy with the 20’ result, though.

You need to leave it connected for a day or two. It took that long for mine to stop working.

Even with all that the camera still worked fine. Wyze has something wrong with their spot lights.

The Wyze Cam 3 is pretty solid so far. I hae had a lot of bad Wyze Cam 2’s and I will not buy SD cards from Wyze. They are junk Everyone failed or was defective from the start


Ok, I finally received the adapter I needed and was able to perform a bunch of tests. I had purchased the following from Amazon:

In order for me to connect the two together (which would give me ~36’ of cable) I had to purchase this adapter as well:image

I am going to try several different combinations of cables with the original Wyze USB Power Adapter as well as a 2.4A USB Phone charger.

-20’ + 16’: With both the Wyze power adapter and the 2.4A, neither provided me with Spotlight Functionality.

-20’ + 6’ micro USB cable (random cable I had laying around)- Both the Wyze power adapter and the 2.4 provided me with full camera functionality along with Spotlight capability. No problem,

-20’ + 10’ micro USB (another random cable I had)- Both the Wyze Adapter and the 2.4A provided me with full camera functionality along with Spotlight capability.

Naturally, the 20’ cable by itself worked fine with both the Wyze and the 2.4A.

So, I feel extending around ~30’ is about max before you lose some camera capability and no Spotlight capability. Next, I’m going to swap these new cables with what I had and use the 2.4A charger and Wyze adapter and will report my findings,

1 Like

Wyze should have tested all of this and provided guidance. Really a miss on their part.

Real simple use case to to envision too.

Sad They are stretching themselves to thin with the breadth of products.

1 Like

WYZE has a major issue with their spotlight accessory and it appears to me like they are doing nothing about it. I am having the same issues with the spotlight not staying connected, I contacted WYZE and all they replied with was to check my connections, something that I’ve done countless times as I am trying to troubleshoot this darn thing.

My camera is working great, I love my V3. But the spotlight has MAJOR MAJOR connectivity issues and they need to start acknowledging this.

I wrote back support telling them I tried all of their troubleshooting tips, they have said nothing. I also submitted logs and heard nothing back yet. I wonder how long it will take them to finally admit their spotlight is faulty.

Even thought the spotlight doesn’t show connected on my app, it turns itself on every night and turns itself off as soon as I switch off night vision.

Hopefully a firmware update will fix these issues fast, because my spotlight has been a useless waste of money so far.

A shorter USB cable seems to fix it. But I agreem it has been a waste of money,

Had issues with one of them. At least I thought it was the spotlight itself . It turns out that it was one of the splitters. I bought 3 lights so I had two others splitters to test it with. Only thing is now I need another splitter.

same issue - working cam 3s. Received 2 spotlights - one of two splitters not working. Second splitter works, however when power up, spotlight flashes, but NO “spotlight detected” message in the app; and NO “accessories” option in the settings menu (per instructions in support). app and cam 3 on same wi-fi network, restarted app, tried “night vision on” – no joy. Submitted ticket

I suspect the cable also. I have same exact issue. Ordered two new lights and will try them when they come in.

Well, both of my spotlight are no longer working. They were fine for a few days but I checked on them yesterday and now the camera does not even recognize that a spotlight is connected. Not sure why they just stopped working. If it was just one, I would say it’s a cable issue but since it’s both and they continue to not be recognized after restarting etc… I am ticked. Bought new USB cables, ran them all and hid them in the eaves for nothing.

The only thing that will get it working again… temporarily is to unplug then plug it back in. Both the camera and the light at the same time. Wyze would tell you to use one of their handy dandy new wifi switches.

I ended up using an electric cord so I could use the original ac adapter and usb cord. That made it much more reliable. It would only work for a few hours with a 15’ usb cable plugged into the wyze power strip. Instead of a few hours, it now goes a few days for something goes wrong. The last time was unique. The spot light was stuck on and rebooting the camera did not fix it. I am not using Wyze outdoor plugs as I already have some Kasa ones and a couple really nice Kasa (TPLink) power strips I bought be before Wyze had their outdoor plugs. I added that so I could reboot the V3 camera and light when needed.

Another subject. I looked to see if there were any rules/actions I could implement to reboot the light etc… but nothing mentions the spotlight.

Pretty disappointing. I did see that there is now an option added to the V3 firmware for independently updating the spotlight firmware. I have not seen a update yet and the longer it takes the more I am thinking there is a hardware limitation to the spotlights that cannot be solved with firmware. it will probably end up being that we will need a special (low loss) power cable and maybe a special (slightly higher voltage) ac adapter to stabilize the spotlights.

Anyone else have any thoughts on that?


Unplugged the main power to the cams and plugged them back in. Spotlights still not recognized. This sucks. They really made a difference when they worked!

How long did you leave it unplugged? Give it at least 30 secs/

How long is the usb Power Cable?

I left it unplugged for a few minutes. The USB cable is 9’ and the camera(s) worked fine for about a week.

That is ridiculous that a 9 foot cable still has issues Wyze is now saying you have to use the cable that came with the camera.

I did that but still had an issue after a week. Light was stuck on which is kinda an improvement.

I had the same issue with two spotlights. I found the issue to be the plug on the rear of the spotlight. Try removing it and plug it back in until it can’t go anymore when you think it’s fully seated push it again, This a design issue, poor male-female connections,

Yeah, I tried that twice. Light will turn on when I plug it in but then shuts off and the cam doesn’t recognize it’s connected.

The fact that the light is turning on when you plug it in means your getting power.

Wyze needs to solve this or stop selling the spotlight.

I bought 5! Yeah, needs to get resolved.

I bought 4, so yah!