Wyze - spotlight says not installed

V3 cam with spotlight accessory attached. Light powers on and cycles, then it turns off. When I choose accessories it states that the spotlight is not installed.
Please help trouble shoot.

Welcome to the forums! What firmware is on the camera?

1 Like

I’m in the same boat, yet the light never turns on. How’s the usb connection to the light, is it loose? Mine would take a light tug to pull it out. Running v4.36.0.248 on the camera with the latest Android app.

I am having exactly the same problem with my three spotlights.


Welcome @mhmmd and @scott_14850!
Is your Wyze app updated?
What version is it?

Beta V 2.17.7


I experienced a similar issue yesterday, after a series of technical troubleshooting steps, turns out the issue was simply that I didn’t get the spot light plugged in all the way. It’s seems like you have it plugged in, but needed to push it in more, i was fooled by the water tight seal. Hope it is as simple for you.


Thank you for the information.

I will try your solution as soon as I get dressed.

Sincerely appreciate the help


You were correct and solved the problem.

Thank you

I suppose in retrospect I should have realized Wyze would not sell a product where the plug was not well seated.


Yep, I usually don’t force a usb in there… Have to with the light thanks!

Thanks for the info - ran into the same issue and just assumed it was a bad USB port or plug. Pushed it in a bit more forcefully, and spotlight was recognized and worked fine.

The issue with the Wyze spotlight is the Wyze spotlight. If you use a long USB Cable for power (say 15 feet or so) the camera will stop working after a while. Camera will continue to work fine.

Reboot the camera and the spotlight will disappear from the cameras configuration. Unplug the power and plug it back in, the spotlight will show up and work for a little while then stop again.

Switch to a short USB cable for power 6 feet or less and all will be fine. The spotlight will turn on at night when the camera detects motion etc or however you have it configured. The downside is if you do not have power close to the camera outdoors. This is a MAJOR oversight on Wyzes part.

Also Wyze support has really really gone down hill. They have no clue. I actually got a email from “Kim” in support that said I need to use rules to make the spot light work. There is no motion detection. Idiotic, insulting and a downright lie. It is a power issues with the spot light and it now works fine with a short usb cable for power. Camera is configured to turn on the spotlight when it is dark and detects motion.
Add in the fact that Wyze broke the Android app again. (Android 11) and I am about ready to give up on Wyze. I canceled my pre-orders with them. Really disgusted with what they are doing.

Worked for me thanks!

1 Like

Having the same problem. Go through settings to spotlight where the only options are

  1. “I already have one installed” tapping that I get “uh oh something went wrong, check WiFi unplug and reconnect the spotlight”
    None of that solves the problem.
  2. Shop
    Option 2 brings me to the Wyze store (seriously???) I’m not buying another spotlight until the one I have works properly. Gimme a break.
    All connections are good and solid using only the supplied cords no extension cords.
    This seems to be a Wyze software issue.

Should also note that the “I already have one installed” window has no way out - no “close”, back arrow, “X” to close. Only way out is too close the app and restart.
Wyze App: V2.23.23

I was able to get it running by unplugging the spotlight and turning it back on then after getting cam to work unplugged cam replugged everything and reset cam via the app too several times

I just bought three spotlights — junk — the Cam V3 is ok

Just bought a spotlight for my V3. Looks like this problem still exists 7 months later.

Not good.

I’m having this problem!?!? December 23 2021. I updated my v3 to the latest firmware after just purchasing it and the spotlight and it does this. Light turns on and then goes off.

Camera acts like it has no clue it’s there?? :sob::weary:

I have the exact same problem using a long USB cable. Couple of things I found out.

  1. When using long USB cables, some power adapters do not provide enough power and will cause the spotlight to stop working after a few seconds. There are some posts on the forum that also mention the included Wyze power brick is barely enough. I had to purchase a high quality 3rd party power adapter to make it work (using a long usb cable).

  2. The Spotlight needs to be powered on AFTER the Wyze Cam. My spotlight would never be recognized when the power comes on at the same time (after power outage). I had to power on the Wyze cam… wait… then plug in the spotlight.