"Show Camera" on Amazon device new issue

Yesterday when I asked alexa to “show camera” she replied “sorry, I don’t know that.”
I’ve disabled the skill, re-enabled. Deletet all cameras reinstalled them ( 4 V2’s and 3 pans) nothing worked. All firmware is up to date. Finally I decided to try it on my fire stick. So I said "Alexa, show me camera on fire stick ", and it worked then tried again on the echo show, and no go… finally I tried the command “Alexa, show me camera on echo show”… and it worked. Over night, without having changed a thing, I now have to call out the device to “show me on”. I never had to do that before. Can someone explain, and offer a fix? Thank you.

Welcome to the Wyze community!
Try asking the Echo Show to “discover devices”

I get the feeling this one is Amazon’s fault. Alexa behavior has always been unpredictable and changes over time (sometimes for the better, where you can try unusual command syntax and it figures out what you mean where it wouldn’t have months easier). Also, when I set up mine, I’m pretty sure it was limited to one Alexa device paired to one display device, period. Sounds as if maybe this is a new feature/capability. I’ll try it some time…

Thanks for the suggestion, but “no new devices found”.

As @Customer said it’s probably Amazon’s doing. I’d contact them.

According to their web site it’s still supposed to be one FireTV paired per device:

On Echo devices – Alexa opens the camera feed on the Fire TV paired to the Echo device you’re currently using. For help pairing devices, go to Use Your Alexa Device to Control Your Fire TV."


The camera should work when asking an Echo Show to “show (camera name)

The fire device is paired to a dot. The echo 8 device always showed the camera just by asking, without specifying that it be called out by name. The link states that for echo devices you just say “show the camera”. My echo device does not do that. It needs you to say “show camera on echo 8”.

It used to. I’ve done everything this article states. It seems to be an Alexa issue. I’ve contacted them by email.

1 Like

Exact same issue here. I agree the change is most likely on Amazon’s interpretation of commands.

It’s pretty frustrating as I have several Echo show devices in the house that I allow my family/guests to interact with but do not expect them to know the specific names of each device they’re talking to. The previous behavior only required them to know the name of the camera they wanted to view.

Previously worked (broken as of a couple days ago):
“Alexa, Show {camera name}” → Specified camera is displayed on the Echo Show device I was talking to.

Current behavior:
“Alexa, Show {camera name}” → “Sorry, I do not know that.”

Work around:
“Alexa, Show {camera name} on {echo device name}” → Specified camera name is displayed on the specified echo device.

I have the same problem but, when I said show the (camera name) it works!

It’s Bezos’s world. We just live in it.


when i said show the (camera name) it works!

Slightly different experience on my end. Using the syntax “show the (camera name)” brings up the camera w/ the “Waiting for Wyze” indicator followed by Alexa responding with “Sorry, the camera isn’t responding.”

At this point, even using the verbose syntax (Show (camera name) on (device name)) I mentioned earlier isn’t working. Both methods now result in the “Waiting for Wyze” indicator and Alexa telling me the cam isn’t responding.

I’ve disabled/enabled the Alexa Skill, Deleted and rediscovered the cameras, soft reset and finally power cycled the cameras and I’m still unable to view their streams on the Echo Show.

1 Like

seems similar to the issue described here:

1 Like

As of 2:00 my time this has started happening to me too! I tried disabling and enabling the Wyze skill with no luck! I definitely think it’s something with Wyze and Amazon because the live stream works perfectly in the app. I will open a support ticket and see if Wyze can fix this!

1 Like

It has to be a mass issue then! I will open a support ticket!

I talked to Wyze and I ended up having to update firmware. For some reason the app won’t tell you to update you have to go: account—> firmware update—> device.

1 Like

I tried updating last night, but the last update on my version 2 cameras was from March 18. And everything was up-to-date.

I tried again this morning to show my cameras on my Amazon echo device and it worked. So it was either Amazon or wyze.

Same here. My cams were all up to date. Appears to be working now though.

Alexa, show the (camera_name) → works

Alexa, show (camera_name) on (echo_show_name) → works

Not sure what was causing the timeout/not-responding issues yesterday, but I can work with this. Appreciate the help @Brlepage

1 Like

@Fubie and @rooster1 same for me!