Scale S won't pair

Got my scale S yesterday. I had to pair it using the Bluetooth settings in my pixel 6 to get it to connect. It updated the firmware once I got it set up in the app. But it wasn’t working right. It wouldn’t record the weight or other measurements. I thought maybe after the update I just need to reconnect it. So I reset it and deleted it from the Wyze app. Now I can’t connect it at all, not even from the Bluetooth settings in the phone.

Any ideas?

2.27.16 app version


Try another device

Worked! If I had been smart, I would have thought to do that. But, evidently, I’m not smart. Lol


Oh my god I’ve literally been with support for hours today because of this exact issue. There’s a problem with the app that needs to be fixed for sure.

We got ours Saturday and it paired right up with no issues

Mine is very picky. I needed to move the phone around to find a place to pair. Now it wants me to install new firmware, but after working on it for a while and showing me some percentages (under 10% done), it gives up and tells me: “Reboot your Device. Update Failed”. I rebooted my Pixel 6, but the problem is still there.
It looks like this product is Not Ready to be on the market.
Does it make sense to return or wait for them to come around and fix it?

I have the same scale and it was easy to pair up no issues

Same issue with mine. My app recognized the scale but failed pairing. It says check that your wyze scale s has sufficient power. Support has not been helpful. Just repeating the same things I’ve tried already.

This is definitely a Pixel 6 issue. My P6 Pro refused to link to the Scale S (kept saying could not pair) but paired to my wifes Pixel 5a just fine. @rmorgan If you have installed the December security update, that could be the cause (it introduced some other Bluetooth issues) but it may also just be the current state the Pixel 6 BT radio. My personal belief is that Low Power Bluetooth is broken on the Pixel 6 radio, but I was able to pair a smartwatch to my phone on the November update and not the Scale S on the December update, which makes me think Google broke something. Wanted to let you know you weren’t alone with this specific issue though!

I had a similar issue with the Scale S not pairing to the Wyze app. This was happening on Android and IOS apps. The problem for me was I had Wyze headphones installed. Once I removed them from the app I could pair the scale with no problem, I have not added the headphones back to the app but I think there could be a bug in the app.

I believe you are right, because the scale now seems to work fine on my Pixel 6 after the latest update (2.27.33). Odd that it didn’t work on a Pixel 6 and worked fine on the Pixel 5a on the same previous version, but whatever!

Thanks for the reply!

My scale S also won’t pair with my Samsung S9 but yet it gets the information from the scale and shows connected in the Wyze app. but on my phone, it shows not paired. Strange?

Did anyone ever find a solution to this, other than pairing to another device? I tried pairing through the app and directly through the phone. It can find the scale and a Bluetooth symbol even shows up on the scale while pairing, but then it fails to finish pairing. It says that there is not sufficient power or the phone is too far away from the scale. It says that even with the the phone sitting next to it.

We use a Samsung note20 ultra with no issues

If you have Wyze headphones or ear buds try unpairing them from the Wyze app. Then factory reset the scale and pair to the app. Once the scale is paired in the app try pairing your headphones or buds again. This worked for me the first time. Good luck

No, I don’t have wyze earbuds or headphones. I do have a Wyze watch, so maybe that is the issue? Either way, you would think that Wyze could get their products to play nicely with one another.

I have a Samsung S21 ultra. Scale does not pair with app. This is my second one. I have done all the trouble shooting a hundred times.

Unfortunately this issue is not as solved for me as I thought. I have been able to pair it correctly only once, after the last Android Wyze app update. I tried to use the scale last night (after installing the new Pixel 6 January update) and was unable to connect to the scale at all. I removed the scale from my app, reset it with the Clear button on the back and have been unable to pair it again since.

I still have trouble with it on my Pixel 6. It see’s it, and says it’s connected. But nothing. I have to use my other device (a tablet) to download the stats. I can then see the stats in my Pixel 6, but I have not yet been able to get the Pixel 6 to download anything from the Scale.

I actually just returned my scale because of this. I have two mobile devices in my house, my phone and my wife’s phone. Neither would pair to the scale. So when customer support wasn’t able to help, and the forum solution was “use a different device”, I was just out of luck. Support tried, they even sent me a replacement thinking it was a defective initial unit, but the second one did the same thing. Hoping to hear they fix it in the future, it seems like a good product if you can get it to pair and work.