Scale X not connected

Since the last update to the Android app my Scale X will turn on when I open the app but it says not connected at the top by the Bluetooth icon. Normally the app updates with the scale when I step on it but now it just shows the last measurement. I tried rebooting my phone, Pixel 6 pro, didn’t help. I just took out the scale batteries and put them back in, again didn’t help. It’s worked fine for months until Tuesday.

1 Like

I am sorry this is happening, we are aware of this issue and working on it. Could I ask you to please submit an app log and let me know the log number?

Recreate the issue. Then in the Wyze app, go to Account > Wyze Support > Submit a Log. Select your device from the dropdown menu. Then fill in the description box with the date, time, and time zone of the most recent time you noticed this issue and a description of what’s happening. Make sure the Send Logs option is selected and then submit your log. When you have the log number, please post it here as a reply to me so I can get it to the right folks


The log is 1132883.
Sorta glad it’s not just me!




Thank you for the log I will get this up to the team.


I am having the same issue i think. I also have a pixel. The scale and the phone see each other since when i select the scale on the app the numbers on the scale light up but the app still says it is not connected and the weight data does not transmit to the phone.

One thing i thought i might try is reinstalling the wyze app, but if I do that would i lose all of my history?

WyzeJasonJ said this is a known bug with their latest version of the app that they are working on. Just going to have to wait for them to fix it.

1 Like

You would not lose your history but this is a known issue and it is doubtful that reinstalling the app will fix it. We are working on this issue currently and hope to have it fixed soon.

1 Like

I have the same problem. I hope that WYZE will notify us when the problem is fixed.

Your log ID number is…


I have two Wyze Scale S’s that stopped connecting two days ago. I’ve tried deleting and readding one of them and it refuses to connect. Wyze App is most current version on Android 13 on a Pixel 7 Pro.

If anyone is experiencing this issue and is on a Pixel device would you be willing to try something for me and report back the results? On your Pixel device

  • Go to settings
  • Network & Internet
  • Mobile Network
  • Device Utilization - toggle it off
  • Then restart the phone and try to connect to the Scale X again

Let me know if this allows you to connect or not, Feel free to go back and change the setting back after trying it. Thank You.

I don’t see a setting like that. I searched for device utilization and nothing like that came up.

Thanks for checking, I have had another user say that setting isn’t there also, I am guessing it is only on a certain version. I had seen it mentioned elsewhere and was taking a shot.

Same here on a Pixel 6A

Nothing like that on my Pixel 7 Pro.

Exact same problem on both a Pixel 6P and on a Pixel 4XL. I submitted an email support request:
"Two days ago after Wyze Android App update, our scale X quit showing as connected in the app. When the scale is selected in the app, it powers-on the scale, however, nothing else that normally happens, ie transfer of the weight etc, happens. This is on both of our Android phones that previously worked without issue. We’ve tried all the resets on the scale and our phones, no change.

Having the same issue. Support kept sending me to a link to watch progress of known issues but it was not listed there. Glad I found the forum. Beyond the same fixes of reinstalling the app, resetting the scale, etc I did try to connect to BT directly. The scale briefly appears in the new device list when you first reboot it, then drops off the list within a few seconds. I add that to the list because it was odd how fast the scale stopped broadcasting. It must need a fast handshake to the app normally.

yes, it is good to know it is not user error

Issue is likely Bluetooth firmware of the scale not acknowledging connection properly. My phone (Pixel 6) upgraded to Android 13 and Wyze Apps upgraded also. When scale was no longer connecting I removed it from the list of devices and now I can no longer add it back. I reset the scale by removing battery and pushing clear button for 5 secs. The scale wakes up and displays Bluetooth symbol, The wyze app switches to pairing display but never completes. I attempted to downgrade the Wyze app to older version but the links in the forum point to non trustworthy websites that appear to have click bait. So only solution is to wait until engineers fix the problem and release a working Wyze App.

I am glad I found this thread, albeit too late, as I spent $40 to get a new scale. :rage:
I am LIVID with Customer Support, because they did not bother to reference this known issue that @WyzeJasonJ has acknowledged.
Instead, I had to bear with the Support person as they had me do ALL the things I had already done to troubleshoot on my Pixel 7 Pro, only to say that my scale was obviously defective, and that since it was out of warranty, all they could do is issue me a $5 gift card. So I went ahead and purchased a new X scale, which arrived today and much to my dismay, I got this during setup:

I also have a Pixel 6a for software development, so I decided to try installing it on that phone. It connected in moments. That phone is running v, whereas my 7 Pro is running

Then, I tried on my 7 Pro again, and it was ready to connect to the scale after the 6a connected to it. But it said I was going to be the secondary user, and that all my data would be wiped out. I did not want to lose all of my precious data, so I stopped.

I uninstalled the scale from the 6a, restarted the scale, and tried setting it up again with my 7 Pro, only to be in same state of fail as above.

I am in week 7 of a serious fitness regimen, and have been monitoring all of my metrics closely every single day. Tuesday will be one week without measurement (aside from me stepping on the scale and getting my weight).
I certainly hope this issue gets rectified with an app update ASAP. :pray:t3: