I am so mad at wyze

tried to contact Wyze regarding my bathroom scale and wyze 47 watch and get automated message about a typhon. Are you kidding me?!!!
Like other companies Wyze thinks that everyone over 70 is computer saavy. I am not.
I asked if I needed to choose Fitbit or Apple Health and couldn’t get a response.
I then downloaded the Help app from Apple Store and then set it by my charger and it responds very good connection.
My scale does not show any of the measurements it’s suppose to show only my weight.
To date, I have no idea what I am doing wrong.
can someone out there help me?

No, it’s true, all of Cebu, Philippines was destroyed by an enormous Category 5 super typhoon. The good news is they may have power back in February 2022.

To expand on what @Customer posted, Wyze, like many other companies, has its main support site in the Philippines. As mentioned, much of the Philippines was destroyed by the typhoon so many support sites were affected.

1 Like

Thank you for the information. I was not aware of the situation. Will just have to sit tight until situation changes.

1 Like

Yes make sure you feet are bare and dry - all parts touching the glass - knees not together

1 Like

Welcome to the forum @judi0932shuler.

The scale only showing your weight could be an indication of not having your account profile setup.

We have a pretty savvy group of community members here and can probably get you squared away.

Starting at the top because, its a good place to stArt without knowing all the details😉

Making the inference that you downloaded and installed the Wyze app on an Android or iPhone device and created an account to be able to login to the Wyze app.

Open the Wyze app and go to account

Then Account

Make sure the below information is populated


I went to the Wyze app and pressed account and the information I entered. Now what? You say make sure info is populated, what does that mean.

Make sure all of these have been entered with data, they need to be manually entered. Once these data points have been filled out, the scale should provide you with the additional metrics (BMI, Body Fat, Muscle Mass, Body Water, etc…) when you use the scale next.

1 Like

There was a very deadly huge typhoon in PH, which hosts many call centers for american customers.

Do you have the wyze app on your phone? You need to go into that, and pick your scale device, then settings cog, then look for “Authorize 3rd party apps”.

1 Like

When I get to Third Party Screen there are two options Apple Health and Fitbit. Which do I use? I have a Wyze 47 watch if that matters.

If you do not use Apple Health or Fitbit the third party app setting should not matter in relation to the additional data you were originally looking for.

I thought I replied to this previously. Anyway, my iphone shows Apple Health and Fitbit. Which do I choose to pair with my scale? Happy New Year by the way.

Which ever one you use. (If you use one or the other)

If you do not use Fitbit or Apple health as a Fitness tracker then you do not need to select a third party app for your Wyze devices to work properly.

Happy New Year!


The scale is still not pairing to my iphone.

1 Like

Make sure Bluetooth is on on your iPhone.
You need to be close to the scale for the data to transfer and also make sure the scale is “active” by touching it or getting your weight.

1 Like

Each of us have a WYZE scale (NOT the S one) in our bathrooms. All the sudden yesterday, both of them lost their connection to our phones and now neither one of them will pair to the respective phone. Wi-Fi was on and Bluetooth was on and listed in the connected devices list. I even deleted one of the scales and added it back, but still had same issue. They’ve been working flawlessly for a year and a half or so. Spent an hour simply trying to pair only one of them. Paring usually takes about ONE MINUTE. Such a waste of my time. Even changed the batteries and stood on it to activate it while pairing, but it won’t pair no matter I what do, and YES I was standing right next to it so BT should work. Frustrated and angry. Firmware is up-to-date. App is the latest version. Please help. Thank you.

I am sorry you are having this experience. I have one of these scales like you do and have run into that issue once or twice. In my case rebooting my phone allowed it to connect, you could try that f you haven’t. I am not confident that will fix your issue since you have 2 scales and it sounds like 2 phone and they both stopped at the same time. I would give it a shot and if that does not help I would contact WYZE Support

Live support is available:


Monday - Friday 4 am - 8 pm PT

Saturday - Sunday 8 am - 6 pm PT


When I have been able to “chat” with Wyze, I am told to turn off my phone for a few minutes and then go to settings and click on third party option.
Why do they say to do this if I don’t need a Third Party sync?
I only have one phone and only one scale but have repeated problems getting the scale to work properly, even though my Blue Tooth is on.
Lastly, this is the second scale as I returned the first one for the same reason.
Very frustrated because I can only send an email and have yet received response from the “support tech team.”

1 Like

Re-starting both phones worked for both scales. Both are working as they should now. Such an easy fix. Gee…would have saved me a good hour had I known. Thank you!!


You’re welcome, had I not run into that myself I would have not known to have you try it.