Wyze 2.16.35 (3) AND WYZE Scale no BMI

Ever since I installed the Beta 2.16.35 (3) BMI doesn’t show. I only see weight. I have removed the Beta and installed release and BMI works. Likewise, I reinstall the Beta and no BMI.


Same here. How do you roll back the firmware?

FWIW, The BMI never worked well. I assume they removed it to avoid the complaints about the inconsistent measurements.

I wasn’t having any problems with BMI, or Body or any measurement. My concern is I get nothing but weight measurement now. I put the release version back on and get everything. I think it is the IOS app not the firmware.

Yeah, I removed the beta app and went back to the regular and it is working normally again.

I’m hopeful that Wyze support is seeing this and will come up with a fix.

I had the same problem. In the app, tap on the scale, settings, users, then your user name. All of my info, such as age, height…had been wiped out. I’m guessing the beta update did that. After re-entering this info, it has been working properly.

1 Like

I didn’t lose info, just wouldn’t take any BMI or other stats other than weight.

Thank you @kboggs1. I was experiencing the same thing (error message below) and per your suggestion I found my height setting got cleared somehow (probably after the beta update). I re-added and was able to get the BMI reading.

Outta add check your profile data to this list

1 Like

Had the same issue with the BMI reading not working after the update. So I knew it had to be either the scale or the app. Checked lots of things but not my personal settings. Just my height was missing. Added it and now everything works. Thanks for the fix. P.S. I’m on the beta software and the fixing the missing height setting and the scale now works with the beta app software on my phone and the scale.

I had the same issue, I deleted and re-added the scale and it started working again even with the beta app. However, the weird part is it made all my stats worse afterwards. My weight is the same but everything else went worse. BMI went up, muscle mass down, biometric age went up, etc. So for some reason after re-adding the scale, I’m now less healthy lol

Didn’t want to know my BMI, but like the other posters, it was there past version, now it is not there.


Strange, mine still shows BMI

I still get the problem where it doesn’t show the BMI the beginning of the week… now it is showing it.

I think that the Wyze developers are doing that to be kind if don’t tell you :wink:


1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.