Scale S won't pair

That’s a shame. But understand. What’s really frustrating about all of this is the original scale worked just fine with my Pixel 6.

Oh that’s great to know! I also have a pixel 6 and was debating whether I should order the original Wyze scale or if I should just wait for the scale s to get fixed. I was worried I’d have the same issues out of the original and I didn’t really want to keep eating shipping costs of ordering and returning if it didn’t work for whatever reason.

I got a replacement and that also did not connect to my Pixel 6 and Moto G4. At this point I consider this to be a bug with Wyze and not with any of my phones, so I returned both. What a waste of time and energy. If Wyze continues like this it will not be good for them

1 Like

I just received my Wyze Scale S yesterday and I’m also having the same issue. My wife’s Pixel 5A works just fine setting up and using the scale, but my Pixel 6 doesn’t seem to want to stay connected. What’s interesting is that if I open the scale in the Wyze app on my Pixel 6, the scale will light up and briefly connect, but won’t stay connected or download any of my measurements. Hopefully this is an app-specific issue that can be fixed soon. I’ll hold off a few weeks before returning the scale. What’s the point of a smart scale if I can’t use the smart functionality?

This is my exact experience as well. My Pixel 6 won’t seem to pair with the scale, it says the devices are too far apart even when right next to each other. The scale will light up and the Bluetooth symbol will come on during this, but seems to drop during the pairing process. Not sure what is happening or why it seems specific to the Pixel 6 / Pro, but you’re not alone here.

Same experience here too. They see each other, but communication is happening correctly. Don’t know what it is, but I hope Wyze figures it out soon.

Agreed. While it doesn’t really help either of us personally, I am glad to find out it isn’t just my Pixel 6 at least. Having multiple reports does make it seem like something that could be fixed with an app update.

1 Like

Just wanted to provide an update: Turns out if I set my phone on the floor perpendicular to the scale (left side of the phone facing bottom of the scale) and a few feet away it stays connected and syncing works well. I wonder if anyone else is able to replicate this and if it signals an actual hardware issue either with Pixel 6’s Bluetooth or with the Scale S’s ability to stay connected to Pixel’s Bluetooth.

I still have another couple weeks to go in my return window and really don’t want to have to return it, but I might have to if there isn’t a realistic fix for this.

This post got me thinking, so I did a little testing and bizarrely may have stumbled on a kind of solution, at least for myself.

As of right now, at least for me and my Pixel 6 Pro, the connection won’t work if the phone is too close to the scale. Within 6 feet, doesn’t work at all. 10+ feet between them, it works perfectly! I’ll have to test again with my wife’s 5a, as it worked fine the first time but I can’t remember what the distance between devices was at the time.

This is a massively strange issue, and at this point I can’t really point any fingers definitively. I want to blame the phone, as it is brand new and has had its own set of update-related issues. But what a weird problem to have, especially with Bluetooth! Close proximity seems to be the problem, not the solution, at least for me.

Hopefully others with this same problem can try this and report back, I would love to know if this is just me, or a valid pseudo-workaround.

Confirmed here that it also seems to stay connected better from farther away. However, setting it down on the floor within ~2 feet also seems to work.

Wow, what a bummer. Just bought two Wyze Scale Ss and was having issues as it is super finicky with my Pixel 6 Pro. Seems like I’m not the only one with this issue :frowning: Also seems like they don’t have it fixed yet because I’m on the latest version of everything as of this date.

I’m also curious as to something else. I read somewhere that with Wyze Scale S the app has to be OPEN for it to get updated. However, if you take say 5 weights on the scale without opening your app that when you finally do open your app and weigh, that it will upload all the measurements that were taken previously (like the 5 times you weighed yourself without opening the app). Well, I tried this and was hugely disappointed to see that the only weight that was uploaded was the CURRENT weight right then. Ugh. Can somebody please tell me how this is supposed to work? I find it ridiculous to have to go to the trouble of opening the app to weigh each time but if it’s something that I can do like once a week (while weighing daily) then that won’t be too bad. I’m hoping that the scale will actually store the info for at least a handful of measurements and what I’m seeing is the glitchiness of the Pixel 6 and Wyze Scale S. IF you have to have the app open for EACH time you want your weight transferred to the app, is this also true for the regular Wyze Scale?


@bfranker - I tested the scenario you outlined and found that despite the connectivity issue, my Scale S does save all of my weigh-ins between connections. However, because of the spotty connection, I have to basically go into the other room, open the app and tap the scale and use whatever long-range bluetooth shenanigans are going on to actually retrieve the stored weights. I believe it’s supposed to store up to 40 weigh-ins in its history. But if it doesn’t do the initial setup and know your weight, or if multiple users are near the same weight then it may struggle to attribute the weight to you.

Thank you for the info! I’ve had some time to do some additional testing and while I’m still having spotty connection issues, it does appear to store multiple weights on a PER DAY basis. That’s what was messing me up… I’d weigh like three times with the app not open and get three different measurements. I’d then get the app to connect and only the last one would show up. That led me to believe it wasn’t storing the others. Then, I tried to weigh just once each day for three days. On the third day I opened the app and got it to connect and the two previous days showed up. So, yes, I’m happy to see that they do carry over (last one each day?) but is your experience like mine and for each day you’ll only get the last one of the day? I have a Withings scale too and you can weigh 10 times a day and each one will show up in the app so that’s what threw me off initially and I thought this one would also record multiple weights per day but I guess not?

Has anyone figured out a solution to this yet? Says low power so i cannot connect with a galaxy note 10+. Changed out batteries with no luck too.

I had the same issue with the Note 10+. What I did to fix was un-install Wyze headphones then installed the scale. I was able to reinstall the headphone without an issue. I heard the issue can happen with earbuds. Good luck

I didn’t have anything other than a webcam set up in my wyze app, so I didn’t have anything to remove to try and fix it. I know this isn’t the answer people are looking for, but my solution was to return the scale S and get the original wyze scale. It has been working flawlessly with my pixel 6. The S didn’t have any features unique to it that I needed or wanted, I just wanted the newer model if it would work for the basic bodyweight and composition tracking.

It looks like the latest firmware 1.0.107 (April 6, 2022) fixed the issue for me. The changelog even specifically calls out the fix. Just had to use my wife’s phone to update the firmware since mine couldn’t stay connected.

  • Resolved Bluetooth connection conflicts between Wyze Scale, Wyze Watch, and Wyze Band for Pixel 6 and Pixel 6 Pro

Hope the fix also works for the Samsung users.

1 Like

The update also fixed it completely for me and my Pixel 6 Pro. It now works exactly like it should, good fix Wyze!

1 Like

Here’s an interesting one…

I couldn’t get the scale to update with this new firmware with my Pixel Pro 6. It just kept going back and forth between downloading and installing and then getting stuck or just stopping. I’d get out and get back into the app and try again and it might get a little further but the same results. After numerous attempts, I gave up. I remembered I had an old Pixel 3XL still in my office and noticed where somebody said they used a different phone to do the firmware update. So, I turned off the Bluetooth on my Pro 6 and booted up the old 3XL. I updated the Wyze app and logged back into the Wyze app. All my new stuff came over and it looked just like it does on my Pro 6 so I clicked on the scale. It immediately told me that there was a new firmware available and I looked over at the scale and it was lit up? What the heck? How did that happen when I never paired anything Wyze related to this phone’s Bluetooth and for sure not this scale? So, I said to go ahead and update it and it downloaded it and did the update and said it was finished and the scale had the dotted box around the display and my app said CONNECTED. I’ve never seen anything connect to any of my phones without me having to pair the two devices or allow “something” but somehow this scale just auto connected to my old phone which hadn’t even been on since I got this scale. Is this normal?

Anyway, I turn that phone off and think I’m in business and turn the Bluetooth back on for my Pixel 6 Pro and… won’t even blip a “CONNECTED” message. LOL! I’ll try rebooting everything and taking batteries out of the scale but just my luck that a phone I never paired works great and a phone I did pair won’t connect. UGH. LOL

The scale uses BTLE (Bluetooth low-energy), so it doesn’t actually “pair” through the usual BT mechanism, That’s why you won’t see it in the list of Bluetooth devices on either phone. I have a smart watch that does the same, it moves from phone to phone just via the app.

I had to go through the same process of using another phone to update it, but it works great on my 6 now.